Installing openhabian 2: avoid automatic update

I would like to install opnehabian 2 (not 3) on a Raspberry Pi. So I download the image from here

burn it on the SD (before, I change the config file so that WIFI works), put in the Pi and start it up. The problem now is, that without any action it automatically updates to OH3, but I would like to stay on v2 so that I can use my old backups…
Can you tell me how to achieve this? Is there something in the config file on the boot partition that can avoid this OH3-update?
Thanks a lot!
Best regards,

I’m still early in my openHAB journey -others who are experts may comment when they wake up on the opposite side of the world to me.

But have you seen this?

if you use openhabian you can choose oh3 or oh2 in the settings.
just type sudo openhabian-config and select 40 and than downgrade.

What about reading the docs for a start ?

BTW there is no such thing as “openHABian 2”, you got the fundamentals wrong.

Hello all,
thank you for all your responses.
Sorry for the openhabian2, that was in the mood of login in 1000 times with openhabian… I think I got the fundamentals roughly, I hope…

Anyway. I also tried the clonebranch=stable and it seems to install openhab2, but it does not start up and tells me that there is no such file when I want to start manually with
sudo systemctl start openhab2

So this way (as descibed in the docs you linked) does not work.
Next I will try the downgrading, but I did already this morning and it also did not work, so I am basically stuck.

Is there no simpler way of getting back 2.5.x …? That would be great…

best regards,


was the openhab2 package installed ?

I installed v1.6.6 with clonebrach=stable and during that it prompted (when reading the config file) that it will install openhab2, yes. So I think it should have been installed, but it seems it did not… Is there a way to find that out easily?
In the meantime I left it at OH3, copied over my things, items, rules-scripts and got it running more or less, with some changes that were required in the rules (receivedEvent.getEvent and such…).
Still it would be helpful to figure out a way to get OH2 running again. Will try some more…
Best regards,

Did you edit the openhabian config file and change to clonebrach=stable before first boot?

yes, do

dpkg -l openhab2

this will show if the openhab2 package is installed.
You also could do

dpkg -l | grep openhab

this will show if any openhab package ( openhab which is OH3 or openhab2 which is OH2 ) is installed.

Yes, I burn the image on the SD, change the config file on the boot partition (the clonebranch input and wifi credentials) and then I let the Pi run for… 30 min till it tells me its finished…

Thanks for the commands, I will give that a try with my next trial!

Best regards,


I’ve updated the v1.6.6 image to contain a bug fix.
Please try again with a fresh download.

Thanks a lot Markus for the quick action!!
In the meantime my Pi400 arrived and I just downloaded the new 1.6.6, change clonebranch=stable and after running it on the pi, the openhab packages still dont seem to exist.
Searching for them with

dpkg -l openhab2

does not give an output.

sudo systemctl start openhab2

gives: “Unit openhab2.service not found.”

Best regards,

To help the team identify the issue can you follow the debug guide

Please upload first-boot.log to more easily identify issue

this is the first-boot.log
first-boot.log (5.2 KB)
Best regards,

Oh man, I’m really tired of telling people again and again what they should have read themselves.
You have to set debugmode=maximum as the guide tells you else this is useless.

I just tried and it works now.
Download again.
Don’t change anything (such as the hardware) while debugging so try again with the old one.

Hi Markus,

I fully understand your point. I did read the guide and the setting for debugging, but in order to provide something quick, I skipped the new initial boot part, hoping that the standard log would be sufficient.

Now downloaded again, now it works, thanks a lot!!! Really awesome work.
For reference:
first-boot.log (191.8 KB)

Best regards,