Item status not showing in detail of item

  • Platform information:
    • Hardware: Raspberry Pi 4 Model B Rev 1.2
    • OS: Raspbian GNU/Linux 10 (buster)
    • Java Runtime Environment: tested with Zulu 11 32-bit and AdoptOpenJDK 11
    • openHAB version: openHAB 3.0.2
  • Issue of the topic:

I have been a long time user of openhab, started with versión 2, now on version 3.

I’m not able to say when this behavior started, but I can see the state of my items in the items list, but when I enter in the detail of an item it seems to always show the default value.

All works as expected, rules, persistence. And If I query the state of an item using a rule it gives me the correct state, it’s only that openhab is not showing the correct state when I enter on the detail page. If I change the state it gets changed, but always shows the default state.

No error in the logs. I attach an example.

Thanks in advance.

Have you defined a custom standalone widget for this item? What is visible in your screen shot is not the default standalone widget for that kind of item.

If so, then the problem is your widget definition.

Hi Justin,

Thanks for your answer. I used oh-knob-card as the default standalone widget, and I assure you it has been working for a long time.

Now I deleted the definition and let OH choose the best widget, you can see that it’s showing a “-” as the value. This is happening with all the items I have, in the item list they show the correct value, but when I enter the detail page I get only a “-”

Picture attached.

Hi Justin,

I give you more information, I have 154 items in my list, when I look at the in the list page all them show correct values, when I enter in the detail page no one shows the correct state. I send you another example of the astro binding.

Thanks in advance.

Which java are you currently using? OpenJDK has some known issues and Zulu is the main recommendation. I don’t know if this is one of the possibly issues, but it’s worth checking.

Other possible things to test:
Have you defined other default standalone widgets for other item types? It also seems possible that the UI is having some sort of trouble with the stream. If there’s an error in one of those widgets it may be interfering with the UI’s ability to render the item page in general?

Have you tried clearing your browser cache? There have also been some strange UI effects reported with some caching issues.

Hi Justin,

Thanks for your response.

I’m using Zulu, I only tried OpenJDK to discard that the problem was with the java virtual machine. All the examples I have published are executed with Zulu.

I have defined other standalone widgets for other item types, but it’s not my default behavior, I normally let openhab choose the widget more suitable for the type of item, and only apply some formatting, but normal behavior is let openhab choose.

I have tried cleaning the cache, browsing in private mode, using Chrome and Safari (I’m in MacOS) and using two different computers, but it’s always the same.

Something curious is that in my iPad all works well, and I have tried entering openhab in a Windows computer and the same, all works as expected, so I suppose it’s something related with MacOS. I have to wait till the next MacOS update and pray.

Thanks a lot for your help.