Km200 binding stops working

After several days the km200 bindings stops working. Values don’t not get updated until restarting openhab. After restart it continues to work for some days…

Hi @maihacke
A bit more inof would help, please

openHAB version?
java version?


Yes, sorry.
Its a openhabian installation, running 2.4, with a km200 snapshot build from the forum here.
I will have look at the logs if I have access to system again - it‘s not mine :smirk:

Looks like a problem…

> grep -i km200 openhab.log | grep "WARN\|ERROR"
2018-11-18 12:18:49.003 [WARN ] [hab.binding.km200.internal.KM200Comm] - HTTP GET failed: 500, internal server error, repeating.. 
2018-11-18 12:20:49.033 [WARN ] [hab.binding.km200.internal.KM200Comm] - HTTP GET failed: 500, internal server error, repeating.. 
2018-11-18 12:44:33.382 [WARN ] [hab.binding.km200.internal.KM200Comm] - HTTP GET failed: 500, internal server error, repeating.. 
2018-11-18 13:20:00.910 [WARN ] [hab.binding.km200.internal.KM200Comm] - HTTP GET failed: 500, internal server error, repeating.. 
2018-11-18 13:46:13.360 [WARN ] [hab.binding.km200.internal.KM200Comm] - HTTP GET failed: 500, internal server error, repeating.. 
2018-11-18 14:08:53.724 [WARN ] [hab.binding.km200.internal.KM200Comm] - HTTP GET failed: 500, internal server error, repeating..

Btw the official App is working…

I´ve seen that type of error on my system as well.
With the latest snapshot build from Markus ist is now working for me with OH 2.4, latest Milestone build.

I updated to the latest milestone and plugin version. The problem is still there…

What I can confirm is:

  • These errors show up when restarting openhab
  • It takes up to 10 minutes until they vanish
  • After that the binding is running stable, with very seldom appearances of that error

This was not the case in earlier versions of the build, where it nearly happened all the time (for me).

@Markinus has done a great job stabilizing things here in his latest builds.:+1:

Overall the impression is, that the kmxxx-devices are not very stable themselves, even the official apps are having a hard time to connect or control them. I´ve tried with two of them, one old, one newer. Independent from the installed firmware version the behaviour is always the same.

So I would suggest to stop openhab, wait for some time to let things settle within the kmxxx-device, start openhab, take your time for a good cup of coffee and have a look into the log via frontail afterwards.
From what I´ve seen thing will calm down here and the values are read properly.
Starting with a single channel to reduce the number of HTTP500 errors is a good strategy, If things work fine, add more channels.
Not all channels work perfectly for me, e.g. the holiday settings cause trouble, so you have to figure that out for you - it also depends on the type of heating you have installed (E.g. mine is a gas/heating pump hybrid that returns different output than e.g. one with a solar pump attached).
I am currently only reading values like hot water temperature, modulation, actual power, outdoor temperatures - these are the things I need first. Setting values did no work for me in earlier version, but I´ll have a look at it again later.

Hope this helps a bit.

1 Like

I have problems to get KM200 working. Get the error message “Decoding ofd the KM200 message is not possible”
After reboot the following KM200 related messages show up in the log:

2019-05-03 09:58:16.664 [hingStatusInfoChangedEvent] - ‘km200:kmdevice:855420462’ changed from OFFLINE (COMMUNICATION_ERROR): No communication possible with gateway to UNINITIALIZED

2019-05-03 09:58:16.704 [hingStatusInfoChangedEvent] - ‘km200:kmdevice:855420462’ changed from UNINITIALIZED to UNINITIALIZED (HANDLER_MISSING_ERROR)

2019-05-03 10:02:18.793 [WARN ] [.core.thing.binding.BaseThingHandler] - Handler KM200GatewayHandler tried updating the thing status although the handler was already disposed.

2019-05-03 10:02:19.035 [INFO ] [ery.KM200GatewayDiscoveryParticipant] - Discovered a KMXXX gateway with name: ‘iCom [gateway_855420462]’ id: ‘855420462’

2019-05-03 10:02:19.326 [hingStatusInfoChangedEvent] - ‘km200:kmdevice:855420462’ changed from UNINITIALIZED to INITIALIZING

2019-05-03 10:02:19.697 [ERROR] [b.binding.km200.internal.KM200Device] - Decoding of the KM200 message is not possible!

2019-05-03 10:02:19.704 [hingStatusInfoChangedEvent] - ‘km200:kmdevice:855420462’ changed from INITIALIZING to OFFLINE (COMMUNICATION_ERROR): No communication possible with gateway

The Java version might be the problem but I don’t know how to upgrade or change.

I run OH2.4.0.1, Java version:

[09:59:50] openhabian@openHABianPi:~$ java -version
openjdk version “1.8.0_152”
OpenJDK Runtime Environment (Zulu Embedded (build 1.8.0_152-b76)
OpenJDK Client VM (Zulu Embedded (build 25.152-b76, mixed mode, Evaluation)

Any idea how to fix the problem?

I found the answer in the forum openHABian hassle-free openHAB Setup

how to install the “zulu cryptography extension kit” which solved the problem

cd ZuluJCEPolicies
cp *.jar /usr/lib/jvm/zulu-embedded-8-armhf/jre/lib/security

Many thanks to @Oggerschummer “Pälzer Bu” who posted the solution there.
(by the way: I’m a “Pälzer Bu” also but now living in Tirol / Austria where the mountains are a bit higher than the hills “in de Palz” :wink: )

1 Like