KNX device is OFFLINE

Hallo,
can some explain to me/ help me with this issue “KNX device OFFLINE” is ?
btw im not to Raspberry und openHAB,
*openhabian
*Raspberry B3

Hello Said,
maybe you entered a wrong device address in the KNX Device ?
Another reason might be that you did not selected your Gateway as the bridge in this device.
Can you show the details of the device “Wohnzimmer” ?
BTW:
I would name devices by the device type plus e.g. the address, not just the location.
Makes life easier. E.g. “MDT Schaltaktor 20fach 1.2.3” - this will show up in the PaperUI Thing list and you directly know with which device you are dealing.

1 Like

Hallo Orggerschummer,
thank your for the quick answer, so i already fixed the problem then somehow i did it again!
i have few questions if you have time to answer,
what shall i write on the KNX Device Adresse ? shall i write the PA of the actuator or the GR (for example a Licht) ??
I called the actuator Hajer … then i wrote the PA from this actuator in the Adresse but the result was not as i expected it, it was OFFLINE !
Locking forward to your answer!

Regards Said

P.S
i forgot to mention that when i save the Device without an Adresse it goes direct ONLINE, is it normal ?
Then when i ADD a chanel to my device i became ERROR 500- Internal Server Error!
Sorry about my beginner’s question:

Hi,
Please check the address (see the hint on the input field?)
You entered a group address where the address of the
( physical) device on the knx bus is required.
Group addresses are related to channels only.
Example :
You have an actor with the physical address 1.2.3 and single channel to switch. This channel is linked to the group address (GA) 1/4/5.

For the actor you have to enter the 1.2.3 as device address in OH, for the channel you enter the knx group address 1/4/5.

The error you get is clear, a group address is not a valid device address, these are different.
With a group address only the binding can not address the physical device (when adding channels or activating the fetch it is trying to actually read data from it).

Good evening,

Sorry for the delay answer!
ive done exactly what you wrote, i changed everything but the result is still the same “OFFLINE”, i dont know where the mistake is :confused: do you have any tip ?
thank you !

Hello,
so either the bridge is not working or the device address is wrong.
Did you check the log with e.g. frontal? What is the output of the knx binding?
We need more information to dig deeper into the problem.

Hallo,
thank you for your quick answer, ok ill try to get deeper this Time.
i just found that when i switch on the ''Wohnzimmer" flash/blinkt mein RETOUR
24

here can you see what i already wrote on Visual Studio Code, i as already, im new to the OH and Raspberry pi, any tips ? shall i do more screens from specific area?

I just had a look on your IP interface and actor definition, seems there is an error with it:
The IP address of the IP router itself is not specified, only the local IP (your openHAB server).
Try something like this:

Bridge knx:ip:bridge1 “KNX IP Interface” @ “Somewhere”[
ipAddress=“xxx.xxx.xxx.xxx”,
portNumber=3671,
localIp=“yyy.yyy.yyy.yyy”,
type=“TUNNEL”,
readingPause=50,
responseTimeout=10,
readRetriesLimit=3,
autoReconnectPeriod=1,
localSourceAddr=“0.0.0”
]

Please adjust:
xxx.xxx.xxx.xxx: The IP address of your IP Router
yyy.yyy.yyy.yyy: The IP address of your OH server
Please enter 0.0.0 as local source address

An example for a tiny single-channel switch actor (there was an error as well):

Thing device Schaltaktor_1_1_4 “Schaltaktor” @ “Somewhere else”[
address=“1.1.4”,
fetch=false,
pingInterval=300,
readInterval=3600,
vendor=“ACME”
]{
Channels:
Type switch : A “Deckenlicht WZ” [ ga=“1/2/10+<10/2/10”]
}

See the “A” ? You have to give your channel an ID !
The knx device address is 1.1.4. I set “fetch” to false as I had some devices that did not work well with it.

The group addresses here are:
1/2/10: The switch object,
10/2/10:The status object of the switch.
Values will differ for you, but you get the idea I guess.

You could then link the channel to an item like this:

Switch EG_WZ_Deckenlicht “Deckenlicht Wohnzimmer” (gWZ, gLighting) [ “Lighting” ] {channel=“knx:device:bridge1:Schaltaktor_1_1_4:A”}

Check to bold parts ,this should give you an idea how everything links together.

Hopefully I did not make any typos…
Good luck :wink:

Mr Oggerschummer thank you so much :pray:
so everything you wrote was 100/100 right [ except this } and few of this " ].
Finally i can switch my first Light on!
next step ALEXA should this light switch on and off, please leave any TIP you have that you think good is!
Best regards Said
thank you again for patience and your time :slight_smile:

Install the hue emulation.
The item is already properly tagged (“Lighting”),
so Alexa should be able to find the light.
Just try a device search in the Alexa app.

Thank for your answer!
i already have HUE, it work fine .

Hi,

my challenge is that although I follow all the suggestions, all my KNX devices stay OFFLINE. The KNX bridge is ONLINE. The strange behavior is that the KNX devices are working. I have defined at least 100 KNX items distributed over several devices and all of them are working, except one specific function in a specific device…: When a KNX device is sending a new status (let say OFF) of a switch, the KNX binding is notifying it and saying “Fine, but I’m not changing the status of the corresponding item, because the device is offline”

First of all I’d like to understand where the general issue is. This is my bridge definition… (again, it’s ONLINE and working properly), followed by a typical device definition. My question is: why it is OFFLINE and working fine?

Bridge knx:ip:bridge "KNX IP Interface"
[
    type="ROUTER",
    ipAdress="192.168.178.17",
    portNumber=3671,
    readingPause=50,
    responseTimeout=10,
    readRetriesLimit=3,
    autoReconnectPeriod=5,
    localSourceAddr="0.0.0",  
    localIp="192.168.178.18"
]
{
    Thing device KG_Gira2174_Dimmaktor1 "GIRA 4-fach Dimmaktor1" [address="1.1.4"]
    {
        Type switch : EG_WZ_EL_Schalten "WoZi-Esstischlampe Schalten" [ga="1.001:2/1/10+<2/1/11"]
        Type dimmer : EG_WZ_EL_Dimmen   "WoZi-Esstischlampe Dimmen"   [switch="1.001:2/1/10+<2/1/11", position="5.001:2/1/13+<2/1/14", increaseDecrease="3.007:2/1/12"]
        Type switch : EG_WZ_SP_Schalten "WoZi-Spots Schalten" [ga="1.001:2/1/30+<2/1/31"]
        Type dimmer : EG_WZ_SP_Dimmen   "WoZi-Spots Dimmen"   [switch="1.001:2/1/30+<2/1/31", position="5.001:2/1/33+<2/1/34", increaseDecrease="3.007:2/1/32"]
        Type switch : EG_KU_SP_Schalten "Kochinsel-Spots Schalten" [ga="1.001:2/1/40+<2/1/41"]
        Type dimmer : EG_KU_SP_Dimmen   "Kochinsel-Spots Dimmen"   [switch="1.001:2/1/40+<2/1/41", position="5.001:2/1/43+<2/1/44", increaseDecrease="3.007:2/1/42"]
    }
}

(adding “fetch=false, pingInterval=300, readInterval=3600” to the device definition won’t help)

What I do not understand is that you setup a separate switch besides the dimmer.
From my understanding there is no need to do so, the dimmer should be enough (It contains the switch).

Here a running example from my config (I just left one dimmer in and dropped the others to simplify it):

Thing device Dimmaktor1_2_22 “KNX 1.2.22 Dimmaktor” @ “UV”[
address=“1.2.22”,
fetch=true,
pingInterval=300,
readInterval=3600,
vendor=“MDT”
]{
Channels:
Type dimmer : A “Some ceiling light” [ switch=“1/2/2+<10/2/2”, position=“9/2/2+<11/2/2”, increaseDecrease=“2/2/2”, frequency=8 ]
}

The only difference I see is that I do not create separate switches, do not specify the data points and the use of “Channels:”. As for the bridge only difference is the autoReconnectPeriod set to 1.

Sorry that I have no further info for you.

:question: maybe someone else can jump in here :question:

BTW: Debug log data would be helpful…

Thanks Oggerschummer,
good suggestion. I will try out whether I can take a dimmer item for a switch. I’ll do it tomorrow.

However, I’m with you: it’s not the reason for an OFFLINE status, because it’s working. From logical standpoint this is a bug in the KNX binding. So maybe I should create a bug entry…

Quick question: how to turn on the debug mode for the KNX binding?

You need to use the karaf console.
There you can set the log level for the knx bundle.

Here is the DEBUG result for two operations (turn on a switch and then change the dimmer value) with the above device:

2019-04-18 17:21:29.054 [DEBUG] [nx.internal.client.AbstractKNXClient] - Wrote value 'ON' to datapoint 'command DP 2/1/10 'knx:ip:bridge', DPT id 1.001, low priority' (0. attempt).
2019-04-18 17:21:29.326 [DEBUG] [.internal.handler.DeviceThingHandler] - onGroupWrite Thing 'knx:device:bridge:KG_Gira2174_Dimmaktor1' received a GroupValueWrite telegram from '1.1.4' for destination '2/1/11'
2019-04-18 17:21:29.348 [DEBUG] [.internal.handler.DeviceThingHandler] - onGroupWrite Thing 'knx:device:bridge:KG_Gira2174_Dimmaktor1' received a GroupValueWrite telegram from '1.1.4' for destination '2/1/14'
2019-04-18 17:21:31.981 [DEBUG] [nx.internal.client.AbstractKNXClient] - Wrote value '70' to datapoint 'command DP 2/1/13 'knx:ip:bridge', DPT id 5.001, low priority' (0. attempt).
2019-04-18 17:21:33.360 [DEBUG] [.internal.handler.DeviceThingHandler] - onGroupWrite Thing 'knx:device:bridge:KG_Gira2174_Dimmaktor1' received a GroupValueWrite telegram from '1.1.4' for destination '2/1/14'

While the device has the status OFFLINE everything is working properly. So for me this is a bug within the binding. The downside of an OFFLINE status are situations where a KNX device is sending period values, which then cannot update an item…
I’m going to file a bug entry.

Yes this would be the best thing to do, from my impression your config looks good and it may just be an issue with the status reported.
Sorry I was not able to help more.

BTW: For anyone looking for the created bug-entry (and the possible (unbelievable!!) solution), refer to Issue #5484

At least the solution mentioned there set all my devices to ONLINE…