KNX Device Status Offfline | First attempt with OH3 and KNX

Continuing the discussion from KNX Things remain offline | First try with OH3 and KNX:

Hi guys

Sorry for reviving this thread but Im having a similar problem migrating to OH 3.2 but I dont see what Ive configured wrongly.
My system is Windows based
Knx was working fine under OH 2.5.9 and the old KNX Binding 1.x

Managed to setup the KNX IP gateway (This one has online status)

UID: knx:ip:edde0658ef
label: KNX/IP Gateway
thingTypeUID: knx:ip
  useNAT: false
  readRetriesLimit: 3
  ipAddress: 192.168.xx.xx
  autoReconnectPeriod: 60
  localIp: 192.168.xx.xx
  localSourceAddr: 0.0.0
  readingPause: 50
  type: TUNNEL
  portNumber: 3671
  responseTimeout: 10

But once I try to add a device linked to the KNX Brige is OFFLINE and here is the settings

UID: knx:device:edde0658ef:f9dc2350cd
label: KNX Device
thingTypeUID: knx:device
  pingInterval: 600
  address: 1.1.2
  readInterval: 0
  fetch: false
bridgeUID: knx:ip:edde0658ef

Any ideas?



Since I don’t know what devices you use,
You could try to switch that to router

Works for me.

You need to add a channels that should be read or write to. The address of the device is not needed.

Example (I do use router not tunnel)

UID: knx:device:knxpm_flurEG
label: PM Groundfloor
thingTypeUID: knx:device
  pingInterval: 600
  readInterval: 0
  fetch: false
bridgeUID: knx:ip:knxrouter
location: KNX
  - id: ch1
    channelTypeUID: knx:switch
    label: AreaA
    description: null
      ga: 1.001:6/2/15

Please take a look into this little post containing a step by step description on how knx configuration links to OH config. and how to set up a basic knx switch.