KNX invalid frame , discarded

Hello everybody,
after having paused some years i just installed the openhab 3 and I am very impressed about the changes and the new frontend. Just amazing - Thanks a lot!

I installed on my PI3 an Weinzierl 838 kberry and have got it running, using the installation description from lo4dro in the knx member forum. Now I can see bus traffic using the knxtools.
For example:
knxtool vbusmonitor1 local:
“LPDU: BC 11 A3 1A 00 E1 00 00 0A :L_Data low from 1.1.163 to 3/2/0 hops: 06 T_DATA_XXX_REQ A_GroupValue_Read”

So it seems that the KNX-connection is working.

But in OPENHAB 3 with the KNX binding I have problems. The binding is online, but instead of getting the knx messages, I get always warnings “2021-02-27 14:33:46.569 [WARN ] [calimero.serial.ft12./dev/ttyAMA0 ] - invalid frame, discarded 38 bytes: 67 16 68 0c 0…”
This is coming in the same interval or after using an knx-switch etc… In the knxtool the output was understandable, but the binding seem to have problems with it.

I can post my configuration if needed. Does anyone have an idea what this can be?

Best regards,

Have you solved this problem?
I experience right now almost the same issue…


Sorry, but I Didn‘t got any answer, the problem is still not solved.What do you have now?
Best regards, Stefan

Gesendet mit der mobilen Mail App

I’m trying to follow up the suggestions from this thread:öffentlicher-bereich/knx-eib-forum/1344429-ungültige-frames-auf-dem-bus/page3
Still under investigation…

Dear Pirx,
this threat doesn´t have anything to do with my problem. I can see and get the information correct with the knxmonitor, but in Openhab on the same device the frames are not interpreted. I belive that this is an openhab error. I will try it again with a never release, perhaps it is solved by now.

Hi Stefan,
I have two knxd instances running. One with the USB Adapter from Busware ( and one with an IP Gateway from Hager. Both work fine.
The busware USB TPUART adapter is on a PI4.

With both instances I can connect using the openhab binding. I just posted parts of the knx.things configuration here: KNX Binding stopped working after power loss - #5 by Jonas88

Best regards