[KNX] One Function (GA) of a single KNX device does not work


I am getting crazy over this strange problem here. I am running a OH 2.5.12 server with 6 x MDT JAL-B1UP.02 roller shutter switch (Application 3.5).

All my KNX things are defiened in the knx.things, using the same pattern (the TREPPENHAUS one is the problem, the other one is for comparison):

Thing device RA2MDTUP "RA2 MDT Rolladenaktor UP Treppenhaus" @ "KNX" [ address="1.1.61", fetch=false, pingInterval=600, readInterval=300 ]
Type rollershutter : Channel01 "Rolladen Treppenhaus West" [ upDown="3/1/8", stopMove="3/2/8", position="5.001:3/3/8+<3/5/8" ]
Type contact : Channel02 "Fenster Treppenhaus West" [ ga="8/4/9" ]
Type switch : Channel03 "Status Beschattung Treppenhaus West" [ ga="1.011:<6/7/8" ]
Type switch : Channel04 "RL Treppenhaus sperren" [ ga="1.003:3/7/8+<6/4/8" ]

Thing device RA3MDTUP "RA3 MDT Rolladenaktor UP Zimmer West-West" @ "KNX" [ address="1.1.62", fetch=false, pingInterval=600, readInterval=300 ]
Type rollershutter : Channel01 "Rolladen Bibliothek West" [ upDown="3/1/9", stopMove="3/2/9", position="5.001:3/3/9+<3/5/9" ]
Type contact : Channel02 "Fenster Bibliothek West" [ ga="8/4/10" ]
Type switch : Channel03 "Status Beschattung Bibliothek West" [ ga="1.011:<6/7/9" ]
Type switch : Channel04 "RL Bibliothek West sperren" [ ga="1.003:3/7/9+<6/4/9" ]

Just in case, here are the corresponding shutter.items

Rollershutter RLTreppenhaus "RL Treppenhaus [%d %%]" (gRLOG,gRL) [ "Lighting" ] { channel="knx:device:KNXRouter:RA2MDTUP:Channel01", autoupdate="false" }

Switch RLTreppenhausSperren "RL Treppenhaus sperren" (gRLSperren) [ "Lighting" ] { channel="knx:device:KNXRouter:RA2MDTUP:Channel04", autoupdate="false" }

Rollershutter RLZimmerWestWest "RL Mediazimmer West [%d %%]" (gRLOG,gRL) [ "Lighting" ] { channel="knx:device:KNXRouter:RA3MDTUP:Channel01", autoupdate="false" }

Switch RLZimmerWestWestSperren "RL Mediazimmer West sperren" (gRLSperren) [ "Lighting" ] { channel="knx:device:KNXRouter:RA3MDTUP:Channel04", autoupdate="false" }

I can control all my rollershutters via OH2 but only ONE group adress (GA) gets ignored → “RL Treppenhaus Sperren” (this ist the first switch in the code example above with GA 3/7/8 for switching and 6/4/8 for state). Running the rollershutter up and down or switching automation all works well for this one. It just doesn’t want to switch to LOCK (=sperre in German).

On the KNX side all is well. I can switch the GA with a physical MDT Switch, the state gets set accordingly.

Now to the real weird stuff: Pressing the button in the sitemap for the second switch from the example above, I can see this in the events log:

2021-09-19 20:57:21.753 [ome.event.ItemCommandEvent] - Item ‘RLZimmerWestWestSperren’ received command OFF
2021-09-19 20:57:21.898 [vent.ItemStateChangedEvent] - RLZimmerWestWestSperren changed from ON to OFF
2021-09-19 20:57:22.883 [ome.event.ItemCommandEvent] - Item ‘RLZimmerWestWestSperren’ received command ON
2021-09-19 20:57:22.990 [vent.ItemStateChangedEvent] - RLZimmerWestWestSperren changed from OFF to ON
All good, switch set and state ok

Now to my problematic one, the Treppenhausaktor:

2021-09-19 20:58:06.527 [ome.event.ItemCommandEvent] - Item ‘RLTreppenhausSperren’ received command ON
2021-09-19 20:58:08.691 [ome.event.ItemCommandEvent] - Item ‘RLTreppenhausSperren’ received command OFF
Seems the GA does not even get passed to the KNX bus. Pressing the KNX hardware-switch, the switch is set and state is updated on the KNX side, but the command as well as the status do not make it across to OH2…wtf?

KNX IP Router (enertex) has been rebooted, no filter tables. A test from NodeRed with KNX Ultimate worked as well with no problems. So the router might not be the problem as well.

I am running out of ideas here…anyone any suggestions?
Thanks a lot!

Hi Frank,
from what I see the configuration is fine, I have a similar setup.
Did you try clearing the cache of OH and restart it afterwards?
I had such a behaviour long time ago and remember clearing the cache did the trick.
But that is just a rough guess.
Any plans to move to OH3.x ? Maybe you could try it out on a spare Raspi and see if the issue is there as well (Yes, big effort, but just for that test it would be easy)

Hi Thomas,

good idea, thanks. I tried to clear the cache (using this howto Clear the Cache) but ended up with OH2 Dashboard no longer starting. Something broke, don’t know what. But then I decided to roll back to the last snapshot, reinstall the latest changes and rebooted…and BANG, it now works.
So I am sure you were correct, must have had something to do with the cache I guess.

Thanks a lot !

Edit: Not sure when I will move to OH3, as I am not happy with the new GUI and the Location Concept… seems like a lot of work for a still quite mediocre (and in my oponion more complicated) GUI… and I have read about some issues with the KNX binding. As KNX is my main system, I might wait just a little bit longer before I move. What would be the benefit though?

Good to hear things are now working fine, the cache is always worth a look :wink:
Regarding OH3:
Big benefit is that you will still receive fixes and feature updates whereas OH2.x will slowly be dying.

Oh boy…I knew you would use THAT one on me :smiley:

Ok…maybe it is time to start the move…

So don’t use it. BasicUI and HABPanel are still there and still supported. You don’t have to use the semantic model either. One is not forced to use any of the new concepts and features in OH 3. It can be set up and configured pretty much exactly like OH 2.

As Thomas said though, the benefit is getting fixes and new features in bindings. I’ll add that not only is OH 2.x slowly dying as the vendors change their APIs and break stuff, but the ability of people here on the forum to support problems on 2.5 is also slow dying. I personally haven’t looked at OH 2.5 in almost a year now.

Lol…now I’ve moved all my text config files over to OH3.1 to see if it works for me with the old sitemap…Rich, you are correct, all works as before…only the iOS App (v 2.4.36) did no longer connect to the Server. Web-GUI is working fine, but not the iOS App… oh Dear. Did I miss something here?

My understanding is that the iOS app won’t display MainUI yet but it should still work with sitemaps. I don’t use iOS so I can’t say any more than that it should work for sitemaps at least. I assume you’ve not messed with any of the new security settings in OH 3?

I know that it can currently only show the old sitemap. But it obvisously doesn’t do that currently, and it seems that I am not the only one: OpenHab App -> white screen

I have allowed BASIC AUTHENTICATON, nothing else I changed in OH3.

Since I don’t use iOS the best I can offer is to watch and participate in the thread you found. The iOS app doesn’t have as many people working on it as the Android app so it often falls behind, but that’s always been the case.

Never had any issues with the app… so i need to wait until this is fixed.