Kostal Binding can not use things for PICO10 in openhab3

Tags: #<Tag:0x00007fc8f5ecbbf0>

Hello,
I have a Kostal Pico10 second generation and will use the Binding in Openhab3.

My problem is, in Gui of openhab3 I can not change Code to piko1020 as shown in documentation
And in visual studio code when I make a thing it is not used.

can anyone help?

THX

Hi,
I will try to help you, I have done the part in Kostalinverter binding regarded to PIKO1020.
I see that the documentation still is as I understand regarded to 2.x, sorry for that!

In OH3 to install binding:
Administration / Things / Install more bindings / Chose Kostal Inverter Binding / Install with your parameters
Now you should see the Kostal PIKO 10-20 at Administration / Things and hopefully is it ONLINE

Best regards Basse

Thank you,
I can install the Costal Inverter binding in OH3, but add Thing in Administration / Thing
I only can chose other PIKO, no PIKO1020 was shown there, see picture attached
I uninstall and install the Binding again, but alwasys the same.
Can you tell me what I make wrong?

Best regards

Hi, great so far. It seems like Kostal Piko 10-20 is not available in this version. The extension for PIKO10-20 in Kostal Binding is rather new.
I am not at home over the Eastern but I will have a clooser look at next week and be back asap.
Best Regards basse

THX, If I can help testing let me know.

Hi, you should have Kostal Binding version 3.1.0 for Kostal Piko 10-20 functionality, so Please check which version you have and let me know.

BR Basse

Hello, I can only install Version 3.0.1. in Settings > Bindings.
How can I get the Version 3.1.0?

THX

Hi @civilnote and @Basse_03 ,

I just switched to openHAB3.1 Milestone Build for the new featured PIKO Second Generation of the KOSTAL binding.

I own a PIKO15 Second Generation (as a second inverter, the first “PLENTICORE” is working fine with the binding).

The configuration should be kind of easy, but the thing does not go “Online”.

I have a working HTTP Binding for the PIKO, but as long as this HTTP-Binding is active I cannot even open the webpage of the PIKO. It is currently deactivated, to configure the PIKO via the KOSTAL binding.
Also while my HTTP-Binding is active my openWB cannot read the values out of the PIKO.
I also shutdown my openWB to make sure, that this is not the reason for the openHAB PIKO thing to not go “Online”.
image

I hope someone can help me out :slight_smile:

BR
Lukas

THX, now I see the binding Version 3.1 in Milestone Version.
And it works great.

I get the data with Piko Solar App and in OpenHAB Binding.

@Astra : the ip adress must have http: in front e.g. http://192.168.3.92
this works for me.

THX to you all.

@civilnote
Goof for you :slight_smile:

For me it still is not working.
Even with prefix http://

Thing code:

UID: kostalinverter:piko1020:ae44166ab4
label: KOSTAL PIKO 10-20
thingTypeUID: kostalinverter:piko1020
configuration:
  password: ...
  refreshInterval: 60
  url: http://192.168.3.92
  username: pvserver

Hi all, I’m not at home for the moment, but I will do my best to help asap, could be today Friday otherwise in next week.
BR Basse

Hi,
sorry for the delay but now back to business :slight_smile:
Your described thing code looks OK.

You can try to scrape your PIKO with any webbrowser with the url : http:// ‘your piko IP’ /api/dxs.json?dxsEntries=67109120
This should leave an response similar to:
{“dxsEntries”:[{“dxsId”:67109120,“value”:5974.706543}],“session”:{“sessionId”:0,“roleId”:0},“status”:{“code”:0}}

This response is regarded to the Channel GRIDOUTPUTPOWER

Please have a try and let me know.

Br Basse

@Astra
I have a Pico 10 second generation with the green panel.
image
and I use this settings:


and ist works good.
I did every settings in the new Webgui

This response is working fine.
{“dxsEntries”:[{“dxsId”:67109120,“value”:1778.047974}],“session”:{“sessionId”:0,“roleId”:0},“status”:{“code”:0}}

I also have a HTTP thing that works, but as soon as I let the HTTP thing run, my PIKO is not reachable from any other device (website, openWB, …).

UID: http:url:aab63091b9
label: HTTP URL Thing
thingTypeUID: http:url
configuration:
  authMode: BASIC
  ignoreSSLErrors: false
  baseURL: http://192.168.3.92/api/
  delay: 0
  stateMethod: GET
  refresh: 60
  commandMethod: GET
  timeout: 3000
  bufferSize: 2048
channels:
  - id: Piko_Leistung_String_1
    channelTypeUID: http:number
    label: Piko Leistung String 1
    description: ""
    configuration:
      mode: READONLY
      stateExtension: dxs.json?dxsEntries=33555203
      stateTransformation: JSONPATH:$.dxsEntries[0].value

So far so good.
Just to sort things out, if you have the HTTP binding running is it then not possible to get the response as described above?
If so, Please try with the HTTP binding not running. You can if you prefer use dxsEntries as 33555203.
Br Basse

As soon as I activate the HTTP-Thing i cannot receive the response anymore.

http://192.168.3.92/api/dxs.json?dxsEntries=67109120
ERR_CONNECTION_TIMED_OUT

That is the main reason, why I waited for the new Kostal binding.
I think there must be a way to read the data properly (without blocking aditional requests), because openWB for example is able to read from the inverter. If openWB read the data, I can still open the website from the inverter or call the API above via browser.

Addational info:
You can see directly in openWB, whenever the HTTP-thing is activated (to be clear, in that case even openWB cannot read data).
I only can read the data from my 1st inverter (plenticore).

So, you have one HTTP-thing connected to Plenticore and running and then is it possible to read data from this inverter (Plenticore) , and you have another HTTP-thing connected to Piko and running and then is it not possible to read data from this inverter(Piko)?
I just try to find out who is disturbing who.
It seems like the HTTP-binding occupies the entire Piko-inverter.

The plenticore works directly with the KOSTAL binding from openHAB. Never had any problems with that.
For me it also looks like the HTTP-binding occupies the entire Piko-inverter

My hope was, that the updated binding did a better job than me with my HTTP-binding. :slight_smile:
I would like to get rid of the HTTP thing.

If you stop the HTTP-binding and run a Piko-thing parallel with a Plenticore-thing, will this not work?

Correct, that does not work. It does not switch to “Online”
image

It seems to work for @civilnote , but the difference in my setup is an openWB that also reads data from the PIKO and a second inverter plenticore which is read by the same KOSTAL binding.