Kostal Binding can not use things for PICO10 in openhab3

Tags: #<Tag:0x00007f43421e0b68>

Hm, I understand.
Could you Please try to run the Kostal binding configured for connection to Piko, and the other 2’ not running, I just like to be shure that you can have the binding running as expected for Piko as @civilnote , and ofcourse myself has, I have an Piko-12.
The bad thing is that I have just this one, so we will have to improvise to try to found out how to have this 2 instances running as we want.

I have made some tries, so if you can get the Kostal Binding work alone connected to PIKO, please try as:
Set up one Kostal PIKO 10-20 and one Kostal Plenticore in MainGUI / Add a new Thing.

I have in IDE succed to have two instances of PIKO1 10-20 running, by set them up in demo.things as
kostalinverter:piko1020:mypiko1020 [ url=“http://192.168.0.XX”, username=“pvserver”, password=“XX”, refreshInterval=60, hasBattery=false ]

and

kostalinverter:piko1020:mypiko1021 [ url=“http://192.168.0.XX”, username=“pvserver”, password=“XX”, refreshInterval=60, hasBattery=false ]

Don’t know if it will work with different type of inverters, but Please try.

@Basse_03
The HTTP-thing is disabled all the time currently.
I disabled the plenticore thing from the KOSTAL Bindung.
I also disabled the connection from openWB to the PIKO.

I deleted the PIKO thing and set it up again.

All without success.

Status: UNINITIALIZED
HANDLER_CONFIGURATION_PENDING

I also got this message when I try to add another Kostal Piko to my already existing/running one, could it be that you already somehow has one configured since when your earlier tries to have it working.

Have you tried to restart OH3 inbetween?

I’m from Sweden, and in my MainGui is it a link under Administration / API Explorer where you can see the different bindings in registry, hope you find it and can make it a try to see, that the thing realy is not there when you have it disabled. I will remember I have had some similar problems, and I think I have to totally delete the Thing and the binding and start from scratch again to make it work.

I checked the API Explorer/Swagger and I could only find the disabled HTTP-thing with „Piko“ in its name. So the KOSTAL binding piko thing seemed to be deleted correctly.

I also rebooted openHAB.

I think I have to delete and reinstall the binding and set up my plenticore again together with the piko.

I deleted and reinstalled the binding.
But the outcome is the same.

Plenticore is online, Piko HANDLER_CONFIGURATION_PENDING

I think the problem is that you try to set up booth Plenticore and Piko.
Please, try to delete and reinstall the binding again but this time only choose Piko.
I am confused thought that I have set up the binding severel times with only Piko and it works.

That is what I did.
After the new install, I only created the Piko thing via Kostal binding.

But it has the same error.

Please have a look, might be for some help

" ## Thing Status
UNINITIALIZED This is the initial status of a Thing when it is added or the framework is being started. This status is also assigned if the initializing process failed or the binding is not available. Commands sent to Channels will not be processed.

HANDLER_CONFIGURATION_PENDING The handler is registered but cannot be initialized because of missing configuration parameters."

Another thing to try could be to start OH3 in debug mode, see below:

Command Line Interface (CLI)
After installing openHAB, a shortcut named openhab-cli provides access to the openHAB-specific commands (such as backup, restore, and console). To use the shortcuts in a terminal, simply type openhab-cli followed by the command. For example:

Usage: openhab-cli command [options]

Possible commands:
start [–debug] – Starts openHAB in the terminal.
stop – Stops any running instance of openHAB.
status – Checks to see if openHAB is running.
console – Opens the openHAB console.
backup [filename] – Stores the current configuration of openHAB.
restore filename – Restores the openHAB configuration from a backup.
showlogs – Displays the log messages of openHAB.
info – Displays distribution information.

Hello all,
I have only one Piko10 an it works, nearly one day.
then the values don´t change.
Then I must set the thing to offline and online again, to get the right values.
Best regards

Hi, Thanks for your input, I have also seen this and I am just trying to find out the reason. I my case it took like a week or at least several days before it happens. I think so far that the problem is regarded to the HTTPClient part of the binding.
Any input or other ideas is very helpful, so just let me know.
I have a redesigned binding running for test since a week now and still no stop, so Please hold your thumbs.

Br Basse