Kostal Binding can not use things for PICO10 in openhab3

The reboot of the whole converter by switching of the “grid” Power Fuse for 5 Minutes was not helping.
Same behaviour.
By curling in the shell i get Data, but the openhub binding is offline :-/

Thank’s for the info, and I’m sorry that you have had to wait for an answer, there has been some busy days.
I think I might have found a cause for yours or rather a general problem regarded to this.
I have done some changes regarded to Second Generation and have not seen that there has been an code-change regarded the entire binding. All 3 generations is possible to use from the very same binding, which is very good. I have to check more just to be shure of my thoughts.
I will be back asap.
BR Basse

Thanks for the Info.
Take your time. For me, it is not very important.
If you need me to test something, it would be a pleasure.

Hello Tuffi, Hello Basse,
I have exactly the same problem with the Kostal binding of my Pico 12. I had also a short period of an “online” status of the pico. Then the Pico goes into status “offine” with error message. I have a KSEM online with the modbus binding.
Is there a chance to read the Pico data with the HTTP-Binding as an alternative to the kostal binding?
kind regards from Germany

Hey Kallixtus
I wait humbly waiting, if Basse find something in his Code :pray:t2:

Thank’s for your interest of the binding. I think I have found a solution and will just do some more tests and then asap make an PR for reviewing.
So hopefully will it not be too faraway before we can have the binding working as expected.
BR Basse

1 Like

Thanks a lot for your work and support. I look happily for your new binding. :grinning:
No stress, there is no pressure. :wink:

Hi Basse,

I hope you are fine. Quite a while ago again since we were in contact.

I just stumbled over this thread as I had the same issue. Actually this type of issue occured for the very first time for me after 3 years of operation. I also tried to activate/deactivate the things, uninstall and install the binding etc., but without success. And it happened out of a sudden on my side, without that I have changed anything on openHAB or my server at all.

Keeping a long story short, I would claim, that I found by what it is caused. I wondered that for “Self-consumption” as well as a for a few other parameters, there was “-” as value in the webserver. I believe I have never seen this before. Following to that, I reduced the max. depth of discharge for the battery to pull some power from there, the webserver should a value for “Self-consumption” again and I was immediately able to activate the Thing.

By the way Basse, I would also appreciate when your latest improvements could be merged into the official binding. The 3.1.0-SNAPSHOT you provided doesn´t work on the 3.1.0 release nor on the actual 3.2.0 version anymore. From there I live also again with the drops-out and my automated restart of the binding, which works fine, but could be avoided by your improvements you made.

Best regards,

After it discharged to the new min. battery capacity set, the issue occured again. Totally strange, I have never had problems with that before.

in detail the following parameters don´t provide a value:

  • Power values: Self-consumption
  • Home consumption covered by: Solar generator
  • Home consumption covered by: Battery

Hi Tobias,
nice to hear from you.
Thank’s a lot for your input.
I will have a closer look asap, but a guess is that there is an issue regarded to jsoup.
The binding use jsoup to read the data sent from the inverter, jsoup has been upgraded to 1.14.3.

There is a new version of Kostal binding 3.3.0, but I think that this one has not been public yet.

I will be back and let you know, but for now.

Have a very nice weekend!!

Regards basse

Hi Basse,

Only to avoid any potential misunderstanding. What I meant is, that the webserver shows and thereby most probably provides a “-” instead of any valid value like e.g. 0. I assume that creates problems with the read-out of the binding.

Have a nice weekend too!

Hm, I’m confused.
There has not been any changes to this part of the binding for a long time.
When i use these channels everything works and the answer is like 0.00W.

What is the answer if you do like:
http://‘Inverter-IP’/api/dxs.json?dxsEntries=83888128 //Self Consumption
http://‘Inverter-IP’/api/dxs.json?dxsEntries=83886336 //Home Consumption PV
http://‘Inverter-IP’/api/dxs.json?dxsEntries=83886592 //Home Consumption Bat
http://‘Inverter-IP’/api/dxs.json?dxsEntries=83886848 //Home Consumption Grid

And also another question:
What version is your inverters UI, FW, HW of ?

Best regards Basse

Hi Basse,

thank you for your work!

I’m facing a problem with my second gen PIKO 8.5 (FW 5.61) / OpenHAB 3.2 and 3.3 rc2

Data comming for round about 16-30h, then hanging, thing say it’s still connected (online)

i need to pause / unpause the thing to let the data flow again.

How can i support you to fix this?

best regards

thanks for your input, I will let you know if I need your support, be so sure :wink:
I have done some changes regarded to your problem but I still don’t know if this code is public yet.
Let me check, but first will I went away from home over the weekend, so next week will I have a closer look.
Br Basse

I have had similar problems with earlier versions, but I have done changes and run the binding with this changes for weeks now without any problems.
This new binding is like: 3.3.0 and will as far I can understand be released with OH3.3.0 M2

You can see the version of yours in karaf-console with command bundle:list
Please have a look at Main-UI / Things / Kostal Piko 10-20 / Thing / Inverter Type and let me know if this parameter is required or not in your configuration-page!

It should be possible to download the new version from openHAB3-Distribution [Jenkins]

open openhab-addons-3.3.0-SNAPSHOT.kar with your archive-handler
open repository / org / openhab / addons / bundles / org.openhab.binding.kostalinverter
open 3.3.0-SNAPSHOT
copy org.openhab.binding.kostalinverter-3.3.0-SNAPSHOT.jar
paste it to your openhab/addons directory ( i run openhabian and then it is like: /usr/share/openhab/addons

I usually do like: //There is probably other ways also
In caraf-console
bundle:stop ‘number of ordinary Kostal binding’

In terminal, stop OH3
sudo /bin/systemctl stop openhab.service

Cut and paste binding as abow

In terminal, start OH3
sudo /bin/systemctl start openhab.service

In caraf-console
bundle:start ‘number of new Kostal binding’

bundle:list //Check that new binding is Active

Then you have to Stop and Delete thing for the old Kostal Piko 10-20and setup the new one as you already have done with the old one

Hope everything will work out fine, Please let me know either good or bad!

Br Basse

1 Like

Hey Basse.
Sorry for not responding and thank you very much for your great work.
I’m on a longer commissioning at the moment, and when I’m at home I don’t have much time or interest in openhab.
But I will definitely test it. It may only take a few months before I get around to it.


no worries, take your time.
Br Basse

Hi there,
I’m having the same problem with my Kostal PIKO BA 10, so the 1st. gen. inverter w/ battery installed.
Trying to get the inverter connected on OH3.2 w/ the latest kostal binding.
Ping is working, tried to use the “kostalinverter” and the “kostal1020”, but both doesn’t work.
Message is “ERROR: COMM”
Username and password for the inverter are still default pvserver/pvwr
IP settings “http://MY_IP_ADDRESS/” with and w/o “http://”, also the suffix “/#/login” has been tried.

Is there someone who had alredy sucessfull connected the “BA” version to OH3.2 or any earlier version?
BR Frank

Are you sure that this is a inverter of 1st generation, regarded to the name should it be an 2’nd generation inverter?
If so, shall you use the Kostal 10-20 part of inverter and configuration as: ( mine is without battery, so just Please try with Inverter Type with battery )

Another thing you can try is to in an Web-browser do like:
http://‘Inverter-IP’/api/dxs.json?dxsEntries=83888128 //Self Consumption
http://‘Inverter-IP’/api/dxs.json?dxsEntries=83886336 //Home Consumption PV
http://‘Inverter-IP’/api/dxs.json?dxsEntries=83886592 //Home Consumption Bat
http://‘Inverter-IP’/api/dxs.json?dxsEntries=83886848 //Home Consumption Grid

then should you get the value back for each dxsEntries.

Please try, and let me know!!

Br Basse

1 Like

Hi Basse,
that’s gorgious, now it works!
Many thanX!!