Kostal Inverter (Plenticore plus 10 FW 01.42) no connection

Tags: #<Tag:0x00007f616e550470> #<Tag:0x00007f616e5502e0>

Hi!

I got a new Kostal PLENTICORE plus 10 Inverter today.
And I want to integrate it in my openhab setup.
PI with 2.5.4-1 installed

I installed the Kostal binding and configurate it in paper UI.
But OH will not connect to the thing.

I got a error message:
HTTP communication error: No response from device

I can connect the webpage of the inverter via webbrowser using its IP.

On the inverter there is the newest FW installed:

Type designation: PLENTICORE plus 10
Serial number: XXXXXXXXXXXXX
Article number: 10335959
UI version: 01.14.04213
MC version: 01.42
IOC version: 01.42

Does anybody have a idea?

KR
Stulp

Did you install the HTTP binding?

No, I just installed the Kostal Inverter Binding (binding-kostalinverter - 2.5.4).

Is the HTTP binding necessary?

Necessary? Not sure, I do not use the Kostal binding, but I would install the HTTP binding and see as the error is HTTP comm issue. :thinking:

Installed the HTTP Binding, still the same error :frowning:

Try creating the Thing in a file. Location is /etc/openhab2/things

Example:

Thing kostalinverter:kostalinverter:inverter [ url="http://192.168.0.128" ]

Just make sure to use your IP address, not the one in the example. :wink:

Hmm, now I got a “Status: unkown” in PaperUI

You will want to delete the Thing created via PaperUI, you can only create it in one place. Also, since creating via files try giving OH a restart.

sudo systemctl restart openhab2 and watch the logs (via frontail) as it starts up.

Sorry:
when I USe kostalinverter:kostalinverter:inverter [] i got java.lang.IndexOutOfBoundsException:Index: 4, Size: 0

when I use kostalinverter:PLENTICOREPLUS100WITHOUTBATTERY:MyPlentiCore100 [ url = http://192.168.0.153, username…] I got Status:inknown

when I use kostalinverter:PLENTICOREPLUS100WITHOUTBATTERY:MyPlentiCore100 [ url = 192.168.0.153, username…] I got HTTP communication error: No response from device

And now we start leaving my skill in IT…

Are you using a password? Username is not mentioned in the doc’s so try excluding it in the thing config.

Yeah, I just set it up like in the discription in the wiki

Thing kostalinverter:PLENTICOREPLUS100WITHOUTBATTERY:MyPlentiCore100WithoutBattery [ url = "192.168.1.2", userPassword="myPassword", refreshInternalInSeconds="30"]

Made a reboot and got the log:

For [url = "http://192.168.0.153, …] I got

2020-04-24 12:28:48.979 [hingStatusInfoChangedEvent] - ‘kostalinverter:kostalinverter:inverter’ changed from OFFLINE (COMMUNICATION_ERROR): java.lang.IndexOutOfBoundsException:Index: 4, Size: 0 to UNINITIALIZED
2020-04-24 12:28:48.992 [hingStatusInfoChangedEvent] - ‘kostalinverter:kostalinverter:inverter’ changed from UNINITIALIZED to UNINITIALIZED (HANDLER_MISSING_ERROR)
2020-04-24 12:30:26.250 [hingStatusInfoChangedEvent] - ‘kostalinverter:PLENTICOREPLUS100WITHOUTBATTERY:MyPlentiCore100’ changed from UNINITIALIZED to INITIALIZING
2020-04-24 12:30:26.262 [hingStatusInfoChangedEvent] - ‘kostalinverter:PLENTICOREPLUS100WITHOUTBATTERY:MyPlentiCore100’ changed from INITIALIZING to UNKNOWN
2020-04-24 12:30:27.979 [hingStatusInfoChangedEvent] - ‘kostalinverter:PLENTICOREPLUS100WITHOUTBATTERY:MyPlentiCore100’ changed from UNKNOWN to OFFLINE (COMMUNICATION_ERROR): Error during the initialisation of the authentication
2020-04-24 12:30:36.386 [hingStatusInfoChangedEvent] - ‘kostalinverter:PLENTICOREPLUS100WITHOUTBATTERY:MyPlentiCore100’ changed from OFFLINE (COMMUNICATION_ERROR): Error during the initialisation of the authentication to OFFLINE (COMMUNICATION_ERROR): HTTP communication error: No response from device

For [url = “192.168.0.153”, …] i got
2020-04-24 12:31:31.347 [hingStatusInfoChangedEvent] - ‘kostalinverter:PLENTICOREPLUS100WITHOUTBATTERY:MyPlentiCore100’ changed from OFFLINE (COMMUNICATION_ERROR): HTTP communication error: No response from device to UNINITIALIZED
2020-04-24 12:31:31.360 [hingStatusInfoChangedEvent] - ‘kostalinverter:PLENTICOREPLUS100WITHOUTBATTERY:MyPlentiCore100’ changed from UNINITIALIZED to UNINITIALIZED (HANDLER_MISSING_ERROR)

Are you referring to the frontail log? If so you can add it via the opanhabian-config tool.

sudo openhabian-config

Look through the options till you find install frontail log. Also while in the tool pick option 10 then select apply needed packages, add svr mounts, and fix permissions.

OK, I installed everything as told

Do you have the Zwave binding installed (there is a known issue if so)?

Now you should have frontail log and you can open it in a separate browser and watch the logs as OH starts. Next set the binding to DEBUG via the console (sudo openhab-cli console) and see if you get any additional info.

No, no ZWAVE Binding


I#m a new User, only 7 post per day…

done

12:54:40.975 [INFO ] [smarthome.event.ExtensionEvent ] - Extension ‘binding-kostalinverter’ has been uninstalled.
12:55:41.092 [INFO ] [smarthome.event.ExtensionEvent ] - Extension ‘binding-kostalinverter’ has been installed.
12:55:41.759 [INFO ] [ome.event.ThingStatusInfoChangedEvent] - ‘kostalinverter:PLENTICOREPLUS100WITHOUTBATTERY:MyPlentiCore100’ changed from UNINITIALIZED (HANDLER_MISSING_ERROR) to INITIALIZING
12:55:41.783 [INFO ] [ome.event.ThingStatusInfoChangedEvent] - ‘kostalinverter:PLENTICOREPLUS100WITHOUTBATTERY:MyPlentiCore100’ changed from INITIALIZING to UNKNOWN
12:55:43.261 [INFO ] [ome.event.ThingStatusInfoChangedEvent] - ‘kostalinverter:PLENTICOREPLUS100WITHOUTBATTERY:MyPlentiCore100’ changed from UNKNOWN to OFFLINE (COMMUNICATION_ERROR): Error during the initialisation of the authentication
12:55:51.903 [INFO ] [ome.event.ThingStatusInfoChangedEvent] - ‘kostalinverter:PLENTICOREPLUS100WITHOUTBATTERY:MyPlentiCore100’ changed from OFFLINE (COMMUNICATION_ERROR): Error during the initialisation of the authentication to OFFLINE (COMMUNICATION_ERROR): HTTP communication error: No response from device

next step: restart inverter. Will take a moment

restart of inverter does not show any logevent

Removed the Thing in the file.
Added the inverter in PaperUI, with IP and password

13:10:17.343 [INFO ] [ome.event.ThingStatusInfoChangedEvent] - ‘kostalinverter:PLENTICOREPLUS100WITHOUTBATTERY:4d20cb55’ changed from UNINITIALIZED to INITIALIZING
13:10:17.367 [INFO ] [ome.event.ThingStatusInfoChangedEvent] - ‘kostalinverter:PLENTICOREPLUS100WITHOUTBATTERY:4d20cb55’ changed from INITIALIZING to UNKNOWN
13:10:18.817 [INFO ] [ome.event.ThingStatusInfoChangedEvent] - ‘kostalinverter:PLENTICOREPLUS100WITHOUTBATTERY:4d20cb55’ changed from UNKNOWN to OFFLINE (COMMUNICATION_ERROR): Error during the initialisation of the authentication
13:10:27.482 [INFO ] [ome.event.ThingStatusInfoChangedEvent] - ‘kostalinverter:PLENTICOREPLUS100WITHOUTBATTERY:4d20cb55’ changed from OFFLINE (COMMUNICATION_ERROR): Error during the initialisation of the authentication to OFFLINE (COMMUNICATION_ERROR): HTTP communication error: No response from device

OK, no Zwave, good.

Now try uninstalling/reinstalling the binding or set log to DEBUG and restart OH. Also power down the Inverter for a few seconds and see if OH connects when powering back up.

Hi,

I´ve got the same issue here, tried to setup the thing with paper UI as well as with a thing file,
unfortnately also getting the
OFFLINE - COMMUNICATION_ERROR HTTP communication error: No response from device

Might it be a problem that the kostal gets an IPv4-adress and not an IPv6?

Update: It seems that there is a connection to the inverter; when I enter a wrong password I get the error that the password is wrong…

Any ideas?
Thank you,
Stefan

Hi,

the same situation at my systen (OH 2.5.4):

2020-05-02 12:41:59.046 [hingStatusInfoChangedEvent] - ‘kostalinverter:PLENTICOREPLUS85WITHOUTBATTERY:scb’ changed from OFFLINE (COMMUNICATION_ERROR): Error during the initialisation of the authentication to OFFLINE (COMMUNICATION_ERROR): HTTP communication error: No response from device

grafik

Any informations if it was working with OH versions <2.5.4?

BR
Bertl