Kostal Inverter (Plenticore plus 10 FW 01.42) no connection

Hi guys,
I’m on OH 3.0 an get the same issue here.
Java 11 installed.
Binding goes to “UNKNOWN” and that’s it :frowning:

In the log, I found an error message:

021-01-22 18:20:32.872 [WARN ] [mmon.WrappedScheduledExecutorService] - Scheduled runnable ended with an exception:

java.lang.IllegalArgumentException: Expected closing bracket for IPv6 address at index 13: http://[]

at java.net.URI.create(URI.java:883) ~[?:?]

at org.eclipse.jetty.client.HttpClient.newRequest(HttpClient.java:442) ~[?:?]

at org.eclipse.jetty.client.HttpClient.newRequest(HttpClient.java:431) ~[?:?]

at org.openhab.binding.internal.kostal.inverter.thirdgeneration.ThirdGenerationHttpHelper.executeHttpPost(ThirdGenerationHttpHelper.java:84) ~[?:?]

at org.openhab.binding.internal.kostal.inverter.thirdgeneration.ThirdGenerationHandler.updateChannelValues(ThirdGenerationHandler.java:155) ~[?:?]

at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:515) ~[?:?]

at java.util.concurrent.FutureTask.runAndReset(FutureTask.java:305) ~[?:?]

at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:305) ~[?:?]

at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128) [?:?]

at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628) [?:?]

at java.lang.Thread.run(Thread.java:834) [?:?]

Caused by: java.net.URISyntaxException: Expected closing bracket for IPv6 address at index 13: http://[]

at java.net.URI$Parser.fail(URI.java:2913) ~[?:?]

at java.net.URI$Parser.failExpecting(URI.java:2919) ~[?:?]

at java.net.URI$Parser.parseServer(URI.java:3292) ~[?:?]

at java.net.URI$Parser.parseAuthority(URI.java:3216) ~[?:?]

at java.net.URI$Parser.parseHierarchical(URI.java:3158) ~[?:?]

at java.net.URI$Parser.parse(URI.java:3114) ~[?:?]

at java.net.URI.<init>(URI.java:600) ~[?:?]

at java.net.URI.create(URI.java:881) ~[?:?]

... 10 more

I seems, as if there’s an error with IPv6 based on this message:
java.lang.IllegalArgumentException: Expected closing bracket for IPv6 address at index 13: http://[]

can now answer the issue by myself.
you have to ommit the “http://” in the IP-adress field.
Now it works, bur I think, at least a note/comment beside the field would be fine, or automatically strip the “http://” before processing.

1 Like

Hi Jörg,

Thank you for the information!

Out of your message I conclude that the binding is nk working well with OH 3?

BR Stefan

Hi Stefan,
yes, the binding is now working in my my OH 3.0 test environment.
But I still don’t get it working in my 2.5. production environment.
There’s another issue.
I cannot setup the thing, as I get an “Error 500” as soon as I select the Plenticore Plus 8.5 and there are no fields to enter IP, username, etc.
Just name, ID, location.
I allready uninstalled an reinstalled without any success.
Will try to get more infos by enabeling DEBUG level

Thanks for your efforts in developing an maintaining this binding.

Hi @pfoerti10,
I still cannot install things (in this case Plenticore PLUS 8.5 with battery) in OH 2.5.
Even after deleting cache and tmp and reboot, I get the same Errorr 500 with lack of the fields IP, password, …
I enabled DEBUG, but I don’t see any debug message from binding.
What is the latest version for 2.5.x? IS there a jar for download?
Thanks Joerg

Am I running in the same issue as here:
Is this bug still not resolved?


Can’t you install things on general, or only in the kostal binding?

Unfortunately the bug with simultaneous use of Zwave and Kostal binding isn’t resolved until now. The bug also exists in OH3. I uninstalled the Kostal binding and integrated the inverter via modbus binding. It’s a lot of work instead of using the Kostal binding, but it works.

@pfoerti10 : It only regards adding things from Kostal binding while Zwave binding is installed simultaneously.

Hi @pfoerti10,
can confirm. Only Kostal things. Error 500 and fields mentioned above are missing.

while waiting for feedback from @pfoerti10, can you share some information on your modbus implementation?
Thanks Joerg

Hi Jörg,
so you have installed the Zwave binding also which means you´re having the issue linked and also described by torsten, right?
I´m afraid I don´t know how to help currently, I´m not using Zwave so far;

But I saw this is also discussed here


sry just recognized the linked discussion had a dead end and is from April,
my apologies…

Hi @pfoerti10,
maybe @chris as Zwave binding maintainer has an idea, why and how the Kostal and the Zwave binding can interfere.

I found a workaround to get both bindings running.
Uninstall the Z-Wave binding. Just the binding, already configured things are kept and will work again after reinstalling.
Now, you can install/configure the Kostal binding/things/channels/items.
Afterwards reinstall the Z-Wave binding.
All configured Kostal and Z-Wave items will still work afterwards.
For changing anything of Kostal binding, you have to uninstall the Z-Wave binding again temporarily.
Not nice but at least both binding are running together until the bug is fixed.


Hi all,
just want to let you know, that -thanks to basse04 the issue is solved at least for OH 3.1. and up.
See github issue #7090


I am having the issue (OH 3.2) also:

I set the url to the IP (not including http:/).

Thing ‘kostalinverter:PLENTICOREPLUS70WITHOUTBATTERY:PlenticoreUI’ changed from UNKNOWN to OFFLINE (COMMUNICATION_ERROR): Error during the initialisation of the authentication
Thing ‘kostalinverter:PLENTICOREPLUS70WITHOUTBATTERY:PlenticoreUI’ changed from OFFLINE (COMMUNICATION_ERROR): Error during the initialisation of the authentication to OFFLINE (COMMUNICATION_ERROR): HTTP communication error: No response from device

Also did a Restart with the last configuration.
I get “Wrong password”, if I enter the wrong password - so the IP is fine. Software: MC-Version: 01.57

I would be grateful for some help!



same problem here after updating to Openhab 3.3:

Thing ‘kostalinverter:PLENTICOREPLUS55WITHBATTERY:74718620f9’ changed from OFFLINE (COMMUNICATION_ERROR): Error during the initialisation of the authentication to OFFLINE (COMMUNICATION_ERROR): HTTP communication error: No response from device

After another downgrade to 3.2 it works again.
Any idea how to solve this problem?


I’m on vacation and will have a closer look asap.

If I remember right, I had the same issue and restarted the inverter.
Afterwards everthing went well.

Edit: Or uninstall the binding and install it again. Sorry, I’m not quite sure, what I exactly did.
But afterwards I had no issues.


Wow, finally got around my problem. The Solution was the missing Enviroment-Setting in my Docker:
CRYPTO_POLICY: “unlimited”

Found the Solution here: