LCN Binding : After changing IP address of the bridge thing : Port 4114 connection timed out ( LOGfile shows : old IP is used)

Dear

I changed my router and have to use another IP adress range. old : 192.168.1.xxx new AVM 6600 cable forced me to use 192.168.178.xxx.

So i have to change all my IP adresses in openhab. Works fine only with LCN Binding some problem.

LCN Bridge thing stays offline after changing IP. So i deleted thing and make new thing with same credentials but new IP address.
Afterwards all LCN things showing online.

But get warnings in the logfile:

The logfile shows no item state change Events from the modules

Here i see that the old IP is somewhere used from the openhab Base thing handler

The question is now how can i get rid of this failure.

It seems that i get values from the things as i see temperatures values and temperatur diagramms are ok.
But the other direction set a new setpoint doesn´t work.

Openhab 3.3.0 M2 on a Raspi4 with textual item configuration.

Dosn´t know where i can get rid of this old IP in the bridge configuration as i changed it there and in the modules only the channel is referenced.

Hopefully somwhere out could interpret the warning in my logfile.

Thanks

Karl

Isn’t it possible to change the network range like described for this model IP-Adresse der FRITZ!Box ändern | FRITZ!Box 6660 Cable | AVM Deutschland ?

I don’t know if it will help but you could search for files that still show the old IP address:

find /etc/openhab /var/lib/openhab -type f -exec grep -l 192.168.1. {} \;
1 Like

Thanks for the replay. Should search for this before i changed my IP´s. :disappointed_relieved:
But have all with DHCP on the router so it was´n so much work.

Will try out tip this evening.

Karl

1 Like

Found something in services : runtime.cfg

under rest api:
for fronttail
and node-red

After changing it and cleared cache and reboot now it works!!!
[Clear the Cache]

Great! not sure what really helped out of this of this 3 actions :slightly_smiling_face:

1 Like