Lightwave RF Gen1 with Openhab 2

Hi there,

I’ve just recently installed a Gen1 double dimmer in my bedroom. I’ve a single 1 to go in the living room and a couple of sockets for the home cinema.

Went down this route in the UK because no neutral etc

Anyway, in doing this, overall want to get one of the sockets working with a Harmony Hub and found an article about using HA-Bridge and OpenHab. Whoop.

I’ve installed OpenHab on my NAS which is a vortexbox media server, running a modified linux distro based on redhat 25. Getting Openhab up and running wasn’t too hard. Modding my distro web page with a link for openhab on 8080 and HABridge on 8081. Nice!

Now the lightwave issues. I did a fair bit of reading, found lots of old and broken links to cloudbee, found newer stuff and a topic on here - LightwaveRF - New LightwaveRF Binding

After a bit of false start, got the jar, got installed, hit an error and it seems that it’s the Gen2 Hub!

Ok back to the older Legacy stuff…However i can’t find the install in the PaperUI - a search for light and i get 4 options, including milight and mighlight (1.x) which says the legacy option is enabled?

So I’m either missing something simple…or there’s an issue with the PaperUI and this binding not being there ???

OK…Manual Jar

Again i can’t seem to find the .jar file - I go to files and i see bundles/actions but no bundles/binding let alone the lightwave one???

I must admit I feel a right dunce at the moment

Any ideas ???


From memory, you’ll need the separate Lightwave WiFi Hub (LightwaveRF Wifi Linkhub?) either Gen 1 or Gen 2 before the Lightwave binding will be any use to you. That connects networked devices to the 433MHz radios that Lightwave use. With no Lightwave hub, the binding has nothing to talk to.

If my understanding is right, you want to press a button on the Harmony and have the Lightwave socket turn on? Basically I think you are missing the other end of the connection:

Harmony -> HA-Bridge -> OpenHAB -> Lightwave/Other Hub -> Socket

I’d suggest that you look at RFXCom devices and the associated binding instead - it will work with Lightwave and other 433 devices. It’s also a OH2 binding, so should be ported across to OpenHAB3 which is rapidly approaching its first release. Most v1 bindings are not being ported directly to OH3.

Update: Not even sure the RFX devices are still made! Maybe look on here for other 433 controllers that people suggest?

Hi Nick

Oh I have the LightWaveRF hub. It’s the Gen1 rather than the Gen2 which is why the Newer binding, which i DID get installed via a Jar file error’d out!

Does the RFXCOM binding work with the lightwaverf kit??? Or Are we talking a new bit of kit here???

Ok, so looking in a local dev version of OH2, I can’t see the LightwaveRF binding even once the Legacy 1.x Bindings capability is enabled.

Looking in the off-line versions from the bottom of the download page, this doesn’t seem to contain them either.

I have to admit, it appears that the Gen 1 binding has been removed and no equivalent is available - unless someone else knows where in the depths of the build system or github an old version might lurk. Have you reached out to the creator of the ‘new Gen 2’ version to see if it is backwards compatible with Gen1?

The RFX device is a new bit of kit for you - but it’s also quite an old piece of kit that may no-longer be made. The few Lightwave devices I did have I controlled via the RFX binding that also allowed me to control Nexa and Somfy kit as well.

I stopped using 433 devices a while back and went to Zigbee, so I’m afraid I can’t offer much more help.

Hi Nick,

Thanks for confirming i’m not going mad with the Gen 1 binding and it not being in openhab2 despite the wiki and in the offline versions etc.

The RFX looks to be rare and expensive on ebay and if i’m honest the reason i started looking at OpenHab was not needing an extra box - I’d first come across a Smartthings plug in and a nodejs server and using a pi to have a local install.

I’m now swinging back towards that route. Maybe even using the nodejs server and figuring out the commands to send it…There’s also HomeBridge that appears to play nicely too, though unsure if you need an apple box or something there.

I’m sure OpenHAB is great and if I’d have gotten what I wanted to do to work, i’d have explored and built on things, but I’m early on in my HA journey (Actually a lie, decades ago i had some x10 kit in the 90s that had a PC plugin) and I really want to solve a specific problem first!

Seems to be down atm as won’t load on my phone but have you tried looking through jfrog

@Ulfilias found this too:

Buy a linkplus and use my binding (the connect devices work with it still but it’s cloud not local)

Be patient and eventually I’ll add the gen1 link

Hi there

Sorry if I sounded petulant or something. Not the aim at all…Just a bit new to OpenHAB and it’s not my only option to solve my quite specific irritation…The Harmony Hub being a bit useless for some of my home cinema automation. And I’ve just bought a load of the lightwaveRF gen1 stuff after a fair bit of research as they seemed to do what i needed!

The throw money at it option, would be a smartthings hub, far less powerful, cloud(ish) based but wheres the fun it that :wink:

Thanks for that jar link. Downloaded, placed in /usr/share/openhab2/addons but it didn’t pop up in Configuration/Bindings as you later one did (i deleted yours first)

Searching for things i found

via [SOLVED] OpenHab2 and MPD

Which has some tracing through, albeit for a different addon

Compatibility layer is now on via the console, but still no joy…But at least i have the jar and there are some things to read, try and work through…So It’s a start!

Interestingly earlier on I worked though some of this

I’ve now got a nodejs server running on the box and after getting the lightwave link to register to the NAS box and can turn my lights on, off and dim with

(server on 8082, this is on, level can be 50 for 50% and off to switch off)

I also accidentally (!) installed a slimserver binding because it was there and i was playing with the interface and i can now play music via OpenHab


Just to update
following this -

I’ve managed to get the habridge to use a http get with the url${intensity.percent}

To get on/off/dim replacing the commands and percent/null

I may be able to get Openhab to play with the HA Bridge - It’s a bit of a reverse from what i was trying to do (which i can now with just node.js and HA Bridge) but it solves MY problem and may be a way to get things working for others with Gen1 and the advantage of being non cloud so very quick response.

Probably limited to dimmers and socket, but it’s something!

Time to go play with OpenHab and see what it can do!

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.