Limit=2000' failed: Not Found

openhab> bundle:list | grep -i ama
216 x Active x 80 x 3.0.1 x openHAB Add-ons :: Bundles :: Amazon Echo Control Binding
it is now the old one :frowning:
I have cleared the cache and rebooted, and the “old” Binding is active.

Yes. After clearing the cache you get the distribution Version.

ok, thanks for the hint. But after update to:
update org.openhab.binding.amazonechocontrol https://janessa.me/esh/org.openhab.binding.amazonechocontrol-3.1.0-SNAPSHOT.jar

i cannot access the amazonechocontrol
and it says

Thing ‘amazonechocontrol:account:6c171fb8’ changed from UNINITIALIZED to UNINITIALIZED (HANDLER_MISSING_ERROR)

But that snapshot JAR isn’t even available anymore, if I’m not mistaken. Try going to https://janessa.me/esh/org.openhab.binding.amazonechocontrol-3.1.0-SNAPSHOT.jar with your browser and it says no longer available.

That may explain, why nothing worked after the update.
Are there any suggestions to resolve the issue?
[ERROR] [nal.common.AbstractInvocationHandler] - An error occurred while calling method ‘ThingHandler.handleCommand()’ on ‘org.openhab.binding.amazonechocontrol.internal.handler.EchoHandler@1921ebf’: GET url ‘https://alexa.amazon.de/api/behaviors/automations?limit=2000’ failed: Not Found

Is there an updated download link? That one doesn’t work anymore :frowning:

1 Like

Weird, extracted the JAR from " 3.1.0~S2222/", placed it into the addons-folder, but still have the same error. :flushed:

Index of openhab-linuxpkg/pool/main/3.1.0~S2217 try this

did you check which binding is the active one ?
in the openhab karaf console run:
bundle:list | grep -i amazon

1 Like

Thank you, stopped the old one and activated the 3.1.0 one and now it works.

1 Like

I downloaded the jar file to the addons folder.
How do I activate it?

after restart of OH service the binding should be visible in the karaf console and you should see if it is activated.

bundle:list | grep -i amazon

I run the command

bundle:list | grep -i amazon

And got empty answer…

You are on OH3 ? The owner of the jar file is user openhab and group openhab ?

This is OH3.
The output of ls -l of addons folder:

-rw-rw-r-- 1 openhabian openhab    466281 Apr  1 08:14 org.openhab.binding.amazonechocontrol-3.1.0-SNAPSHOT.jar

Do I need to change the owner from openhabian to openhab?

1 Like

Does anyone have a current link for the updated addon? The two links mentioned in this thread no longer work.

browse through Index of openhab-linuxpkg/pool/main and select the directory related to the version you are looking for.