Logitech Harmony Hub Binding - 4.15.206 firmware broke local API connection

harmonyhub
harmony
Tags: #<Tag:0x00007f0145a749a8> #<Tag:0x00007f0145a74700>

(Joachim Boeddeker) #110

I am using exactly this with my Fritzbox 7490. This locks down the internet for that device.


(Claudio) #111

Thank for the quick answer. Than I will downgrade today and use this feature. I hope, that Logitech is not blocking that downgrade feature, before I downgraded my device…

Claudio


(Rainer-Michael Gottert) #112

Yes, this is absolutely possible. Just give it a moment after downgrade and startup to initially connect (otherwise it won´t initialize completely). After your remote can connect (or it shows up in OH as online) you can block internet access via Internet -> Filter -> Listen -> Gesperrte Internetseiten (Blacklist).

I added these domains:
myharmony.com
svcs.myharmony.com
content.dhg.myharmony.com
logging.dhg.myharmony.com
sus.dhg.myharmony.com

Afterwarts I created a new access profile at “Zugangsprofile” with setting
“Filter für Internetseiten” enabled and “Internetseiten sperren” checked.

The last step is to assign this access profile to the harmony hub device in tab “Kindersicherung”.

The steps above are for a Fritz!Box 7390 with Firmware 6.85.

Best regards,
Rainer


(Alex) #113

@dr_vergleich

Me too. It’s a “Fritz!Box 6490 Cable”. I also set “HarmonyHub” to “gesperrt” (=blocked).

–> No firmware updates from Logitch!

P.S: Check your DHCP settings for “HarmonyHub” if “provide always the same IP-Address” is activated!


(Konstantin K.) #114

Let’s see if this really blocks it. Also have the 6490 and blocked internet use completely for the hub. Hopefully logitech reacts and re-enables local access.


(Johanes Morgenroth) #115

Logitech has released a special developer firmware. This one opens XMPP again. You can find it within the same tool used for the down-grade. For me it worked very well.

=> FIRMWARE TO ENABLE XMPP. FOR DEVELOPERS ONLY.


(j4ckz0n3) #116

Thanks for sharing. I’ll try later at home.

Looks like the community put enough pressure on Logitech :+1:


(Constantinos Contis) #117

trying to update to xmpp firm but i get a blank white screen when i press “Update Firmware”…


(Stefan) #118

For me it worked very well. THX


(Mathias Stiastny) #119

Many thx, worked fine for me too :slight_smile:

Merry Christmas


(jeshab) #120

I had the same issue. I was running an older version of the MyHarmony application. You should download the latest version. It seems they updated the application framework to use .NET instead of deprecated Silverlight although it looks exactly the same.


(Constantinos Contis) #121

many thnx mate !!!


(Kristof Rado) #122

where this update can be seen? For me there is just a regular update screen

Ps.: found it, you have scroll all the way down


(Constantinos Contis) #123

hehe i was surprised from Logitech’s kindness to allow the XMPP firmware…i was wrong :slight_smile:
after update i get this…


(jeshab) #124

I am not getting that message after updating to .210 even after syncing my configuration through the desktop application.


(Kristof Rado) #125

Hope @digitaldan will make some progress to move to websocket API until then :slight_smile: and we can update…


(Alex) #126

Maybe websocket api now is not necessary.

@digitaldan what do you think about?? Should we upgrade to developer firmware 4.15.210 and use the XMPP again? Or wait until websocket api is implemented (by you) and then use official firmware 4.15.206?

For me it would be associated with a lot of effort or would be annoying to connect each time the hub via USB cable to PC getting a new “developer firmware” version!


(Marcel) #127

Thx! Saved my day :slight_smile:


(Christian) #128

Thank you so much for posting! Worked perfectly!


(Dan Cunningham) #129

Agreed, upgrading is up to you. I plan on moving to the websocket connection, but I don’t have an ETA on when it will be done. I started last night and so far so good, but I will be completely re-writing our connection library. The good news is that it will be 90% less code, most of the logic was in managing XMPP messaging, much much easier using websockets, so I’m kinda excited to go down that route. Let’s hope logitech doesn’t stop this method as well.