Logrotate dying

Using openhabian with OH2.5 they uses logrotate to preveny unwileildly log file sizes.

my journalctl is showing that logrotate service is failing mutliple times so a forced stop applied by systemd.

the problem is that every log file rotate is failing because of permissions and that it reports “use su user group to fix”.

never used logrotate and so is there an OH doc that might help with fixing this?


There are multiple statements in the docs how to set the correct permissions.

1 Like

no no no

that’s irellevent

I’m asking for help with specific issue, if you can help with SPECIFIC answers, then by all. means do.

but that reply really, didn’t help, did it. I mean, come on, play the game pal.

We help those refine what they already tried. I see no details of that in this thread.
This is not a Help Desk that provides solutions for those with a paid support contract.

If it is too much for you to read documentation for yourself, it must not be important to you and we cannot help.

1 Like

please enlighten me Bruce because I’m quite stupid…

Exactly where does the docs suite provide guidance as to my OP
Hyperlinks more than welcome.
I mean i dont mind learning and developing my skills through self tuituon Bruce, however, after reading docs that stood out to me as “obvious” candidates, I’m still non the wiser as to the options per my OP.

Im sure members who join here, like myself, do not anticipate being chastised, but rather to have their ignorance re-educated in a reasonably polite and friendly manner, and not, to be left feeling unworthy in the face of such eminence.

many thanks in advance

@sihui said they are in the official documentation and I know he does not say things he is unsure of. What he said, I am sure is relevant (note the correct spelling). Perhaps he can post the links if you ask kindly. :wink:

my spelling is atrocious, because 100% of the time, i use my mobile, that believes its dictionary is superior than that which i type, and it changes text AFTER i click Send. Awful but thanks to Samsung i remain illiterate :roll_eyes::grin::grin:

prey tell please.

btw, i did use openhabian-config option, to “fix permissions” but that failed to fix these permissions. Maybe something for you to consider??
Hence you will hopefully understand my confusion and provide constructive feedback?

many thank
just to prove my case…

gives ZERO indication of logrotate function, which is std *nix stuff that i am fully conversant with.
problem is, I’ve no idea what OH is doing wrt logrotate :roll_eyes:

Good, you’ve found it.

1 Like

for real ?

come on mate

i did that BEFORE coming here for help obviously :pleading_face:

I sense you don’t have a solution, other than to present me as a schmuk mmm

point made

i might be noob, i certainly am dumb, in fear of ignorance, … but … I’m far far from stupid and recognise a game play, pal!

anyway, to be respectful…

i thank you for your"support" and will bear that in mind whilst i persue a finite reply to my OP from a polite experienced chap whom might shed light on the fabled streaming prob , in my OPm no need for you to reply, I’m already cognisant of your directionb and feelings. :roll_eyes::grin::+1:

thank you

bit of a gentleman’s club this forum is, mere mortals not tolerated eh…

I really feel so so so sorry for you

here’s advice from a humble ignorant dumb ass…

you’re only human

ok !!!

come down to earth and be responsible and respectful to those who are not as emminet as you



Hi tilly
Does the error message indicate which file has not got proper permissions?
You mentioned in your post that you are using openhabian running OH2.5 so I’m guessing it is a Pi but I am guessing
Do you know how to change file permissions ect?

BTW sihui is one of the most active trouble shooters on this forum, he helps dozens of folks here on a daily basis and all of us are extremely grateful for his contribution
No one here intended to try to make you feel like a smuck, we literally are trying to help you help yourself because this is a community. And that is OpenHAB’s strength, this community

Obvious to you but not to us because you did not tell us!

You go first. :wink:

OpenHABian will run on any Linux system. My Debian VM is using openHABian.

OK great
@tillykeats what is platform please?

Sorry… Bruce can be a little… terse some times
especially considering he isn’t even German :grinning:
kidding fellas kidding :wink:

1 Like

When somebody discounts one of our respected users of providing irrelevant information because the OP expected us to be mind readers, that is considered respectful??
Perhaps you use a different dictionary that the rest of the English speaking world.

yeah it ticked me off to Bruce


I just put them on a 2 week ignore to see if he gets more respectful here.


Hi Andrew THANK YOU for trying to help and rising above the “gentleman’s club” whereupon we cant say anything negative in regard to certain members and their flock of sheep whom take it upon themselves to dishonour any freashman who dare critique.
TBH.im really unswathed by threats to “ignore me” because, and god willing, there are people like your goodself who rise above the internal politics of these forums. God bless YOU.


all files are causing a problem

every message says “use su.to set…”

I’ve really no idea as to what that means.
Can you think of what i could provide to help you with this diagnosis ?

I look forward to further dialogue with you Andrew… much obliged. You are very positive and uncritical. thank you once again.

all said and done, I can work this out myself, in time, and thus it is with gratitude to you if i can resolve this sooner.

OH is a great product and the investment of many hours by kind keen development.

but I’m nobody’s whipping boy and i scour at premadonnas who in some forlone belief, think they are superior.

in uk
we say

F.K.U , G.A.L


( 'll wotk it out in time )

I’ve fixed it
no prob now
thanking you all

1 Like