M4 testing results

Off-topic since you are running a snapshot, not M4.

I just updated my “test” setup… Update seems to do fine, however I´m still struggling with the “Failed installing ‘openhab-misc-restdocs’” … How the hell do I get rid of this one… Its driven my nuts and spamming my logfile (specially tailog which I have open almost all the time).

It has been moved to ui section. openhab-ui-restdocs.

Thx, but it does NOT solve the problem.
In the UI section, Rest-doc is NOT installed… I tried to install it form there, only to see the error continues, because the error is regarding the old path… I then removed Rest doc from the UI section. The error still continue.

But how can I remove something, which Karafthinks it´s there, but actually is no longer there… To me it seems like something is stucked somewhere, and I cant seem to fix it. I really thought M4 would have fixed it… It didnt

I had this problem long ago. If I could remember well, I went back to my version before (from backup) then I’ve uninstalled “Rest Docs”. Then I made the update again.

here is solution from another thread


Arghh, damit…
You´re right Andrew… So sorry… This is a “test” system which I didnt install from the start. I never used addons.config file on my main system myself. So I simply didnt think about that… Thanks alot for telling me… this has been nagging me for quite some time, and the reason (as well as solution) was so obvious :hot_face: (my mistake)…

1 Like


Please see this post.

Since this is basically a new install, I just entered them again.

There are some commands in update.lst for this change. Though it looks like runCommand in postinst doesn’t support all commands of the update script @Benjy?

This was basically a fresh OpenHABian Milestone 3 install on Debian running in a Microsoft Hyper-V VM.

On every openhab2 package I’m asked if I want to replace one or two files such as runtime.cfg or org.ops4j.pax.logging.cfg with the distribution-provided one.

Is that upgrade script of yours supposed to merge any diff someone has made in his installed copy ?
I always had to manually merge my changes, including in this latest M3->M4 upgrade.

I only had the ops4j.pax prompt moving from an OpenHABian M3 install to M3.
Would it be possible to coordinate OpenHABian with OH releases? It appears to me you are needing to scurry around after a release to fix OpenHABian.

Not a criticism, just an observation.

No it doesn’t merge these changes. That question is asked by APT for resolving conflicts during an update.

There are several different scripts that use update.lst during updates:

  1. The update/update.ps1 scripts in openhab-distro used for manual .zip/.tar.gz installations
  2. postinst in openhab-linuxpkg that’s used with .deb/.rpm’s
  3. openhab2-update.sh in openhab-docker used for Docker container updates.

Currently they all have there own logic and it seems the one in openhab-linuxpkg is missing some commands.


So far so good. All things Seems to working!

Updated from m3 to m4 here are my findings:

1. Dummy Item could not be found in my rules here the sample:

// my rule points to a LICHT_OUT_DIMM_OLD wich will hold the last state 
var DimmerItem DimmOldValueSaveItem         = LICHT_OUT_DIMM_OLD;

// default.item worked 2.x M1/M2/M3
Dimmer        LICHT_OUT_DIMM_OLD             "Old Values Store"

// have to change it to a dummy channel!
// default.item M4
Dimmer        LICHT_OUT_DIMM_OLD             "Old Values Store" { channel=""}

2. HueEmulation is not working since m2?
Here the Log:

16:45:43.746 [INFO ] [.io.hueemulation.internal.ConfigStore] - Hue Emulation pairing disabled
16:45:45.179 [WARN ] [mulation.internal.HueEmulationService] - The UPnP Server service has not been started!
16:45:45.183 [INFO ] [mulation.internal.HueEmulationService] - Hue Emulation service available under /api
16:45:45.628 [INFO ] [hueemulation.internal.upnp.UpnpServer] - Hue Emulation UPNP server started on

Reported also here: [hueemulation] No Longer Able to Pair with Harmony Hub

That’s all for now.

Thanks for reporting Erkan

Yikes!.. I might need to go thru a bunch of item files. Is this a regression or an enhancement?

was afraid of that…

Can anyone comment on if the REST docs are working?

@weakfl is your sshd working?

1 Like

Not yet able to test this but should be the fix. I really need to find time to make the necessary changes to bin/update so that this process can be called externally…


They are working for me but I do not have any of the conflicting bindings. :wink:

Yes, sshd is fine :+1:

You can easily check this by installing such an addon.