M4 testing results

Tags: #<Tag:0x00007f7454811b70>

Thanks @Kai!

I guess there will be an “M4 testing results” thread similar to the one for M3 to provide feedback?

One thing I’ve noticed so far is that all my charts are empty. Persistence seems to be fine, new values are written to the (mysql) database, but charts don’t show anything.

UPDATE:

Only group charts are affected, charts with single items are working ok.

SOLUTION:

It looks like item labels need to be unique now, even if they are in different groups.

@weakfl

Having the same problem (but with snapshot 1731, almost the same build)

12:00:21.592 [WARN ] [.ui.internal.items.ItemUIRegistryImpl] - Cannot retrieve color item Weather_LastUpdate for widget
12:00:21.596 [WARN ] [.ui.internal.items.ItemUIRegistryImpl] - Cannot retrieve color item Weather_LastUpdate for widget
12:00:24.834 [ERROR] [.ui.internal.items.ItemUIRegistryImpl] - Cannot retrieve item 'Weather_Temp_Max' for widget org.eclipse.smarthome.model.sitemap.Text
12:00:24.838 [ERROR] [.ui.internal.items.ItemUIRegistryImpl] - Cannot retrieve item 'Weather_Temp_Max' for widget org.eclipse.smarthome.model.sitemap.Text
12:00:24.842 [ERROR] [.ui.internal.items.ItemUIRegistryImpl] - Cannot retrieve item for widget org.eclipse.smarthome.model.sitemap.Text
12:00:24.846 [ERROR] [.ui.internal.items.ItemUIRegistryImpl] - Cannot retrieve item 'Weather_Temp_Min' for widget org.eclipse.smarthome.model.sitemap.Text
12:00:24.849 [ERROR] [.ui.internal.items.ItemUIRegistryImpl] - Cannot retrieve item 'Weather_Temp_Min' for widget org.eclipse.smarthome.model.sitemap.Text
12:00:24.853 [ERROR] [.ui.internal.items.ItemUIRegistryImpl] - Cannot retrieve item for widget org.eclipse.smarthome.model.sitemap.Text
12:00:24.867 [ERROR] [.ui.internal.items.ItemUIRegistryImpl] - Cannot retrieve visibility item Weather_LastUpdate for widget org.eclipse.smarthome.model.sitemap.Text
12:00:24.869 [ERROR] [.ui.internal.items.ItemUIRegistryImpl] - Cannot retrieve item 'Weather_LastUpdate' for widget org.eclipse.smarthome.model.sitemap.Text
12:00:24.872 [ERROR] [.ui.internal.items.ItemUIRegistryImpl] - Cannot retrieve item 'Weather_LastUpdate' for widget org.eclipse.smarthome.model.sitemap.Text
12:00:24.877 [WARN ] [.ui.internal.items.ItemUIRegistryImpl] - Cannot retrieve color item Weather_LastUpdate for widget
12:00:24.879 [WARN ] [.ui.internal.items.ItemUIRegistryImpl] - Cannot retrieve color item Weather_LastUpdate for widget
12:00:24.881 [ERROR] [.ui.internal.items.ItemUIRegistryImpl] - Cannot retrieve item for widget org.eclipse.smarthome.model.sitemap.Text
12:00:24.883 [ERROR] [.ui.internal.items.ItemUIRegistryImpl] - Cannot retrieve visibility item Weather_LastUpdate for widget org.eclipse.smarthome.model.sitemap.Text
12:00:24.885 [ERROR] [.ui.internal.items.ItemUIRegistryImpl] - Cannot retrieve item 'Weather_Chart_Period' for widget org.eclipse.smarthome.model.sitemap.Switch
12:00:24.887 [ERROR] [.ui.internal.items.ItemUIRegistryImpl] - Cannot retrieve item 'Weather_Chart_Period' for widget org.eclipse.smarthome.model.sitemap.Switch
12:00:24.889 [ERROR] [.ui.internal.items.ItemUIRegistryImpl] - Cannot retrieve item for widget org.eclipse.smarthome.model.sitemap.Switch
12:00:24.891 [ERROR] [.ui.internal.items.ItemUIRegistryImpl] - Cannot retrieve visibility item Weather_Chart_Period for widget org.eclipse.smarthome.model.sitemap.Chart
12:00:24.894 [ERROR] [.ui.internal.items.ItemUIRegistryImpl] - Cannot retrieve visibility item Weather_Chart_Period for widget org.eclipse.smarthome.model.sitemap.Chart
12:00:24.896 [ERROR] [.ui.internal.items.ItemUIRegistryImpl] - Cannot retrieve visibility item Weather_Chart_Period for widget org.eclipse.smarthome.model.sitemap.Chart
12:00:24.898 [ERROR] [.ui.internal.items.ItemUIRegistryImpl] - Cannot retrieve visibility item Weather_Chart_Period for widget org.eclipse.smarthome.model.sitemap.Chart
12:00:24.901 [ERROR] [.ui.internal.items.ItemUIRegistryImpl] - Cannot retrieve visibility item Weather_Chart_Period for widget org.eclipse.smarthome.model.sitemap.Chart
12:00:24.903 [ERROR] [.ui.internal.items.ItemUIRegistryImpl] - Cannot retrieve visibility item Weather_Chart_Period for widget org.eclipse.smarthome.model.sitemap.Chart
12:00:24.911 [WARN ] [.ui.internal.items.ItemUIRegistryImpl] - Cannot retrieve color item Weather_LastUpdate for widget
12:00:24.913 [WARN ] [.ui.internal.items.ItemUIRegistryImpl] - Cannot retrieve color item Weather_LastUpdate for widget
12:00:50.766 [WARN ] [.ui.internal.items.ItemUIRegistryImpl] - Cannot retrieve color item Weather_LastUpdate for widget
12:00:50.769 [WARN ] [.ui.internal.items.ItemUIRegistryImpl] - Cannot retrieve color item Weather_LastUpdate for widget
12:00:55.408 [ERROR] [.ui.internal.items.ItemUIRegistryImpl] - Cannot retrieve item 'Weather_Temp_Max' for widget org.eclipse.smarthome.model.sitemap.Text
12:00:55.410 [ERROR] [.ui.internal.items.ItemUIRegistryImpl] - Cannot retrieve item 'Weather_Temp_Max' for widget org.eclipse.smarthome.model.sitemap.Text
12:00:55.412 [ERROR] [.ui.internal.items.ItemUIRegistryImpl] - Cannot retrieve item for widget org.eclipse.smarthome.model.sitemap.Text
12:00:55.414 [ERROR] [.ui.internal.items.ItemUIRegistryImpl] - Cannot retrieve item 'Weather_Temp_Min' for widget org.eclipse.smarthome.model.sitemap.Text
12:00:55.416 [ERROR] [.ui.internal.items.ItemUIRegistryImpl] - Cannot retrieve item 'Weather_Temp_Min' for widget org.eclipse.smarthome.model.sitemap.Text
12:00:55.419 [ERROR] [.ui.internal.items.ItemUIRegistryImpl] - Cannot retrieve item for widget org.eclipse.smarthome.model.sitemap.Text
12:00:55.423 [ERROR] [.ui.internal.items.ItemUIRegistryImpl] - Cannot retrieve item 'Weather_LastUpdate' for widget org.eclipse.smarthome.model.sitemap.Text
12:00:55.425 [ERROR] [.ui.internal.items.ItemUIRegistryImpl] - Cannot retrieve item 'Weather_LastUpdate' for widget org.eclipse.smarthome.model.sitemap.Text
12:00:55.427 [WARN ] [.ui.internal.items.ItemUIRegistryImpl] - Cannot retrieve color item Weather_LastUpdate for widget
12:00:55.429 [WARN ] [.ui.internal.items.ItemUIRegistryImpl] - Cannot retrieve color item Weather_LastUpdate for widget
12:00:55.431 [ERROR] [.ui.internal.items.ItemUIRegistryImpl] - Cannot retrieve item for widget org.eclipse.smarthome.model.sitemap.Text
12:00:55.433 [ERROR] [.ui.internal.items.ItemUIRegistryImpl] - Cannot retrieve visibility item Weather_LastUpdate for widget org.eclipse.smarthome.model.sitemap.Text
12:00:55.435 [ERROR] [.ui.internal.items.ItemUIRegistryImpl] - Cannot retrieve item 'Weather_Chart_Period' for widget org.eclipse.smarthome.model.sitemap.Switch
12:00:55.437 [ERROR] [.ui.internal.items.ItemUIRegistryImpl] - Cannot retrieve item 'Weather_Chart_Period' for widget org.eclipse.smarthome.model.sitemap.Switch
12:00:55.439 [ERROR] [.ui.internal.items.ItemUIRegistryImpl] - Cannot retrieve item for widget org.eclipse.smarthome.model.sitemap.Switch
12:00:55.442 [ERROR] [.ui.internal.items.ItemUIRegistryImpl] - Cannot retrieve visibility item Weather_Chart_Period for widget org.eclipse.smarthome.model.sitemap.Chart
12:00:55.445 [ERROR] [.ui.internal.items.ItemUIRegistryImpl] - Cannot retrieve visibility item Weather_Chart_Period for widget org.eclipse.smarthome.model.sitemap.Chart
12:00:55.447 [ERROR] [.ui.internal.items.ItemUIRegistryImpl] - Cannot retrieve visibility item Weather_Chart_Period for widget org.eclipse.smarthome.model.sitemap.Chart
12:00:55.452 [WARN ] [.ui.internal.items.ItemUIRegistryImpl] - Cannot retrieve color item Weather_LastUpdate for widget
12:00:55.454 [WARN ] [.ui.internal.items.ItemUIRegistryImpl] - Cannot retrieve color item Weather_LastUpdate for widget

Could you explain it in more detail, please?

EDIT: It was a problem with persistence “rrd4j”. Please IGNORE.

This does not work anymore (items have the same label but are in different groups):

Group  gThermostatHallway                       "Thermostat Hallway"
Number HallwayThermostatCurrentTemp             "Temperature" (gThermostatHallway)
Number HallwayThermostatCurrentHumidity         "Humidity" (gThermostatHallway)

Group  gThermostatOffice                        "Thermostat Office"
Number OfficeThermostatCurrentTemp              "Temperature" (gThermostatOffice)
Number OfficeThermostatCurrentHumidity          "Humidity" (gThermostatOffice)

This does work (different labels):

Group  gThermostatHallway                       "Thermostat Hallway"
Number HallwayThermostatCurrentTemp             "Temperature Hallway" (gThermostatHallway)
Number HallwayThermostatCurrentHumidity         "Humidity Hallway" (gThermostatHallway)

Group  gThermostatOffice                        "Thermostat Office"
Number OfficeThermostatCurrentTemp              "Temperature Office" (gThermostatOffice)
Number OfficeThermostatCurrentHumidity          "Humidity Office" (gThermostatOffice)
1 Like

To me, that appears to be a bug.
Why should OH care about the labels? Aren’t they designed just for human readability without needing to be unique?

To be fair, it’s mentioned in the docs. But it was working fine previously if the items were in different groups:

“When charting a group of item, make sure that every label is unique. If the label contains spaces, the first word of the label must be unique. Identical labels result in an empty chart.”

2 Likes

I solved my problem. Persistence rrd4j was not set anymore, after update.

Post has moved to this topic…

No NPE for me, but my regional settings were lost :frowning:

1 Like

Off-topic since you are running a snapshot, not M4.

I just updated my “test” setup… Update seems to do fine, however I´m still struggling with the “Failed installing ‘openhab-misc-restdocs’” … How the hell do I get rid of this one… Its driven my nuts and spamming my logfile (specially tailog which I have open almost all the time).

It has been moved to ui section. openhab-ui-restdocs.

Thx, but it does NOT solve the problem.
In the UI section, Rest-doc is NOT installed… I tried to install it form there, only to see the error continues, because the error is regarding the old path… I then removed Rest doc from the UI section. The error still continue.

But how can I remove something, which Karafthinks it´s there, but actually is no longer there… To me it seems like something is stucked somewhere, and I cant seem to fix it. I really thought M4 would have fixed it… It didnt

I had this problem long ago. If I could remember well, I went back to my version before (from backup) then I’ve uninstalled “Rest Docs”. Then I made the update again.

Kim
here is solution from another thread

2 Likes

Arghh, damit…
You´re right Andrew… So sorry… This is a “test” system which I didnt install from the start. I never used addons.config file on my main system myself. So I simply didnt think about that… Thanks alot for telling me… this has been nagging me for quite some time, and the reason (as well as solution) was so obvious :hot_face: (my mistake)…

1 Like

@Bruce_Osborne

Please see this post.

Since this is basically a new install, I just entered them again.

There are some commands in update.lst for this change. Though it looks like runCommand in postinst doesn’t support all commands of the update script @Benjy?

This was basically a fresh OpenHABian Milestone 3 install on Debian running in a Microsoft Hyper-V VM.

On every openhab2 package I’m asked if I want to replace one or two files such as runtime.cfg or org.ops4j.pax.logging.cfg with the distribution-provided one.

Is that upgrade script of yours supposed to merge any diff someone has made in his installed copy ?
I always had to manually merge my changes, including in this latest M3->M4 upgrade.