MainUI full screen

I am making an IN/OUT sign using MainUI pages and have it all working but would love to know how to get it full screen in a browser (this isnt a tablet question).
I basically want to be in Run Mode and have the function the Fullscreen button in the bottom right does - is there a URL I can reference directly for this, if not some sort of script I can embed or something similar?

Do you mean that you want to get rid of the left-hand menu? If so, just click the pushpin to unpin it.


Or do you mean that you want the browser to be a full-screen window with no tabs/taskbar? That’s possible with JavaScript, but I don’t know how you’d build that into a MainUI page. Maybe you can make it the default for the browser when it launches.

Full screen - when I go to htp://server/page/pagename I get this:

when I press the fullscreen opton in the bottom left it does this:

Thats what I would like to embed in a browser window/iframe


I’ve never actually noticed that option before. Looks like it is just triggering a Javascript, but I can’t think of how you’d do that without human intervention.

Id be happy to run some javascript to do it if I could work out how - just running the URL in fullscreen in chrome isnt doing this

OK I think fixed grid layout gets me very close

1 Like

was there a solution for the challenge?
i use Fully Kiosk Browser and would like to start the page in full screen and run-mode.


I’m struggling with exactly the same issue… I would like to run a dashboard on a wall screen - and the dashboard should be displayed in rendered mode by default. So a get parameter as &render=true would be awesome :wink:


see here

1 Like

Thanks Oliver,

unfortunatally this thread is only about fullscreen, but not for rendering it by default

what do you mean by rendering? If you mean, it should directly jump into fullscreen mode then yes, the solution provides exactly this.

to not show the edit mode but the “run mode”. So the view you get after clicking on “run mode” or “Ctrl r”

just read through the link provided incl. its sub links.
It works as requested

This seems to be a solution IF you set this page as the default start page (which seems to be rendered by default) but not for any other page.
I don’t want to change the default page (as this doesn’t make sense for me at all). I wan’t to apply this for a dedicated page which is only build for a dedicated wallscreen.

you didn‘t read carefully the post. Again, it provides what you are requesting. Even the title of the linked post provides the information…

you need to adjust the parameter „start_url“ of the manifest file