Manually install addons on Ubuntu

Hi,

I have recently updated to 4.1.1 release build and I am facing some problems with my Tapo things, which apparently have been solved in the snapshot.

I am running the OH on Ubuntu and copied the jar file into the following folders (the 2nd one didn’t exist so I created it just in case, since the default was not working):

/usr/share/openhab/addons &
/opt/openhab/addons

as per the instructions here .

But the addon is not recognised and my things that worked in version 3 are not showing any more.
I also changed the owner of the folders but no luck.

image

I can’t see anything related in the logger.

Anyone can guide me on how to enable the addon?

Thanks

I’m not familiar with the directory structure with your type of installation, so only guessing: the addons directory is usually on the same level as conf, runtime and userdata

$ ll
total 60
drwxrwxr-x  7 openhab openhab  4096 Jan 17 11:59 ./
drwxrwxr-x  5 openhab openhab  4096 Jan 17 11:59 ../
-rw-r--r--  1 openhab openhab 13430 Dec 22 18:53 LICENSE.TXT
drwxr-xr-x  2 openhab openhab  4096 Jan 17 12:05 addons/
drwxr-xr-x 15 openhab openhab  4096 Jan 17 12:00 conf/
drwxrwxr-x  2 openhab openhab  4096 Jan 17 12:00 rake_state/
drwxr-xr-x  6 openhab openhab  4096 Dec 22 18:53 runtime/
-rw-r--r--  1 openhab openhab   223 Dec 22 18:40 start.bat
-rwxr-xr-x  1 openhab openhab   199 Dec 22 18:40 start.sh*
-rw-r--r--  1 openhab openhab    72 Dec 22 18:40 start_debug.bat
-rwxr-xr-x  1 openhab openhab    73 Dec 22 18:40 start_debug.sh*
drwxrwxr-x  9 openhab openhab  4096 May  5  2023 userdata/

In case it’s different, look inside userdata/etc/org.apache.felix.fileinstall-deploy.cfg file and check out this key:

felix.fileinstall.dir           = ${openhab.home}/addons

The location is the same, I have
felix.fileinstall.dir = ${openhab.home}/addons

My folder structure looks different, I cant find conf and userdata, and the jar file is located in the addons folder here

drwxr-xr-x   4 openhab openhab  4096 jan 17 08:54 ./
drwxr-xr-x 249 root    root    12288 sep 25 21:04 ../
drwxrwxr-x   2 darko   openhab  4096 jan 17 09:21 addons/
-rw-r--r--   1 openhab openhab 13430 jan  7 22:04 LICENSE.TXT
drwxr-xr-x   6 openhab openhab  4096 jan 17 08:54 runtime/
-rwxr-xr-x   1 openhab openhab    73 jan  7 22:04 start_debug.sh*
-rwxr-xr-x   1 openhab openhab   276 jan  7 22:04 start.sh*

That looks like the right place. Check the file permissions and ownership, make sure openhab can read it.

I was playing with the permissions but it makes no difference.

drwxrwxr-x 2 openhab openhab   4096 jan 17 13:14 ./
drwxr-xr-x 4 openhab openhab   4096 jan 17 08:54 ../
-rwxrwxr-x 1 openhab openhab 103990 sep  1  2022 org.openhab.binding.synologysurveillancestation-3.3.0-SNAPSHOT.jar*
-rwxrwxr-x 1 openhab openhab 208514 jan 17 10:10 org.openhab.binding.tapocontrol-4.1.0-SNAPSHOT.jar*
-rwxrwxr-x 1 openhab openhab     70 jan  7 22:04 README*

I think the problem is the jar file, I removed the Synology Surveillance Station addon from the marketplace and it works when the jar is manually placed in the same folder

Hmm… the synology jar shouldn’t have interfered, but I’m glad you’ve got it sorted.

No I think the Tapo jar is bad (or I used incorrect one). I put the Synology jar in, just to check if the location is good

You are running oh4.1? Then you have to use the binding for 4.1.x

I tried all 3 versions that are on the github, none of them worked for me when I put them in the addons folder.
I guess i need to wait for the next official release

where did you find them? You could build it or I could build it for you if needed. 4.2 release is still a few months away I think, unless you want to use milestones, or the fix has been cherry-picked to 4.1.2

EDIT: I guess you’re referring to GitHub - wildcs/oh3_compiled-addons at tapocontrol

The PR hasn’t been merged yet, which you probably already knew :slight_smile:

You might want to report this in https://github.com/openhab/openhab-addons/pull/15725