MaxCubeBridgeHandler - IO error occurred during execution: Read timed out

Hi all,

after I updated to the latest snapshot tonight I found that connectivity to my MAX!Cubes is no longer working :frowning: .

I see the following warnings in the logs and no data at all is gathered from the cubes anymore.

2018-07-26 23:08:39.318 [WARN ] [nternal.handler.MaxCubeBridgeHandler] - IO error occurred during execution: Read timed out
2018-07-26 23:08:39.324 [WARN ] [nternal.handler.MaxCubeBridgeHandler] - IO error occurred during execution: Read timed out
2018-07-26 23:08:50.541 [WARN ] [nternal.handler.MaxCubeBridgeHandler] - IO error occurred during execution: Read timed out
2018-07-26 23:08:50.580 [WARN ] [nternal.handler.MaxCubeBridgeHandler] - Error sending command org.openhab.binding.max.internal.handler.SendCommand@1591ca8[id=0,channelUID=<null>,command=<null>,cubeCommand=org.openhab.binding.max.internal.command.F_Command@187835,serialNumber=Cube(KEQ1234567),key=Cube(KEQ1234567)-F_Command,commandText=Request NTP info] to MAX! Cube at IP:
2018-07-26 23:08:51.169 [WARN ] [nternal.handler.MaxCubeBridgeHandler] - IO error occurred during execution: Read timed out
2018-07-26 23:08:51.179 [WARN ] [nternal.handler.MaxCubeBridgeHandler] - Error sending command org.openhab.binding.max.internal.handler.SendCommand@a7d506[id=1,channelUID=<null>,command=<null>,cubeCommand=org.openhab.binding.max.internal.command.F_Command@603962,serialNumber=Cube(MEQ1234567),key=Cube(MEQ1234567)-F_Command,commandText=Request NTP info] to MAX! Cube at IP:
2018-07-26 23:09:02.330 [WARN ] [nternal.handler.MaxCubeBridgeHandler] - IO error occurred during execution: Read timed out
2018-07-26 23:09:02.540 [WARN ] [nternal.handler.MaxCubeBridgeHandler] - IO error occurred during execution: Read timed out

Any idea what could be wrong?

  • There was no change except updating to the latest snapshot.
  • MaxCubes are fine when accessing via the native Windows application.

PS: Tried to clear cache and tmp files already, but didn’t change the situation…

Any ideas are greatly appreciated :slight_smile: !

Best regards

Can confirm this. Same error messages here.

Just a quick update on this:

Did a reinstall of openhab2,

  • purged openhab2 installation completly
  • rebooted
  • reinstalled openhab2
  • recovered my fully file based config
  • started openhab2
  • waited for openhab2 to start up and load all packages, bindings, etc.
  • restarted openhab2 once more (just to doublecheck everything else starts up without errors)

=> Still same problem with the MaxCubes!

Everything else seems / is working fine…

Went back to the latest stable release (2.3.0-1) today.

=> Connectivity to Max!Cubes started working again immediately :slight_smile:

I assume some changes introduced that error in one of the recent snapshots (2.4.x) therefore. Is anyone there to help and fix this :slight_smile: ?

Hi Karsten,

The MAX! Binding doesn’t work properly in the lastest OH2 snapshot. I have the same issues. I assume we can trace them back to the following changes (see If I find some time I will try dig into it and to solve it.

Hi Christoph,

sounds great! Thanks for your feedback and your help fixing this :slight_smile:

I’m looking forward to be able to switch back to the latest snapshot.

Best regards

I have the same issue. Maxcube thing remains offline (although I see in debugging that OH reads from it) and thus no max device works. Seems the “fix” mentioned above broke it. Asked to revert it, but Kai refused and is waiting for Christoph to come up with an analysis/fix.

Any news ?

1 Like

I am afraid not. Perhaps I will work on it this weekend.

Hi together,
I’m watching this thread quite a while now and I’m really looking forward to a solution. Heating period is going to start soon (and I know my wife can be quite uncomfortable if this is not working as expected :). I also have to rework some of the rules for heating though.
Basically, I just wanted to mention that a fix to that binding would really be appreciated.
Thanks in advance,

As a workaround, you can install the max binding from the 2.3 release (install the addons 2.3 addons package , extract it from the .kar and place it into the addons folder).

But I’d highly appreciate a proper solution, too.

I looked today into the issue and created a fix

Hope to have that soon merged

Is it a complete rollback of the PR#1789 mentioned above ?
(which is what I had requested but Kai actually refused) or just a
partial one where we still benefit from that earlier PR (whatever the improvements of that one are supposed to be, that I didn’t get) ?

@marcel_verpaalen Thank you very much. The PR has been merged and will be part of the next snapshot.

@mstormi The fix only reverts a partial logic wrt reading the responses from the MAX! Cube. You will now benefit from all the other changes.

Indeed small rollback.
PR#1789 was a very large change, which was for 80% cleanup of code & coding style.
However, it also introduced some thread improvements, which some of were wondering if that indeed would fix an issue or introduce new ones.
My PR only reverted small part of ‘logic improvement’ which actually did not work

Hmm, I installed #1354 and now #1355 (openhab2 and openhab2-addons packages) but they still include version of the max binding to not have that fix. What’s wrong ?

Good morning, I have updated yesterday evening and it seemed to work again. I havent checked the version numbers, but at least the error is disappeared and all MAX! devices are found again.

Just read about this.
eQ-3 is to refer “for programmers” on Open Source being among the sessions, based on FHEM and OH I think.
Maybe someone’s interested. Certainly an opportunity to get in touch with them and maybe tell them what they need to improve upon :slight_smile: (so if anyone attends, please tell them on behalf of mine that they should implement a MAX! config backup/restore).

Oh and yes, latest snapshot (binding version as of 09/09) did indeed fix my(our) recent problems.
Thanks again Marcel and Christoph for looking into it.

PS: came together with the new ZWave binding so I was able to remove two workarounds right the same day.
I’m running stock OH 2.4 now, and everything’s still working. Scary, somehow :wink:

Indeed that would be very useful. Also a more formal description of all available commands would be very useful.
There are still many commands poorly understood