MCO Home IR Thermostat IR2900 Unknown Device

searching in the forum I haven’t found this information.

This is done automatically by making that version the default java version. Thus java will be found via it’s path.

And to do the Java 17 the default Java in openHAB, what do I have to do apart from installing it in raspbian?

Btw, it looks like openHAB now uses Java 17, but still MCO Home IR Thermostat device shows Unknown Device. I’ve attached openHAB’s about, console’s bundles, and MCO Thing.

There are some things look odd. First is that your device appears online despite the binding not being active. Is there only one zwave binding listed? Second is the osgi.extender error. I haven’t seen that and do not know how to fix. Third it looks like you are still on buster “linux/5” not bullseye “linux/6” and that I thought there were conflicts with java17. Not sure what to advise. If you are not too far along with OH it might be best to backup what you have to a separate computer and burn a fresh openhabian image. It should have everything updated.

thank you very much for the quick and long answer!

I have erased the SD of the Pi and performed a clean install following this guide.
Then I installed Java 17 and rebooted the Pi.
After that I installed Z-Wave from the UI and then I updated the bundle with this command:

bundle:update 264

There was no error in the process, but in bundle:list it shows “Installed” instead of “Active”, and when I go to “Things” → “+” in the UI in order to add a new thing, it says “No Binding”.

Im attaching the openHAB’s about and the budle:list output.

that should have worked. could try bundle:restart 264 ?

I get the following:

Error executing command: Error restarting bundles:
        Unable to start bundle 264: Could not resolve module: org.openhab.binding.zwave [264]
  Unresolved requirement: Require-Capability: osgi.extender; filter:="(&(osgi.extender=osgi.component)(version>=1.5.0)(!(version>=2.0.0)))"

Oh man ! :unamused: after all that !! That is the one I haven’t seen. It is likely something recently added. There is always a risk that the newest binding will not work on an older version of OH as the compile process is subject to revision. I knew about the Java17 requirement but not this one.

@J-N-K I hate to ping you, but is this something (see last message from @Sotirios_Tsakalidis) that has been changed ? Is it resolvable on an OH3.4?

@Sotirios_Tsakalidis There is a possible workaround using an older binding, but would like to see if this way is fixable first.

No problem! Thank you for the quick repspone!

It‘s related to the upgrade to Karaf 4.4 and can‘t be easily resolved. If absolutely necessary I would suggest to branch of 3.4.x and cherry pick the changes to that branch.


Unfortunately, there is no straightorward fix. Can you suggest a workaround?

I have an appointment soon, so can’t do a step by step until later. However we are going to try this Modify a zwave binding jar to add/change a zwave device while waiting for a build - Tutorials & Examples - openHAB Community. You will need the 3.4.2 zwave jar and use the OH2 XML from the database. The process adds the xml to the .jar Take a look
edit: this is the path

1 Like

Sorry for being the noob here. I have the following issues:
1)I can’t find the 3.4.2. zwave jar.
2) And I’m a bit confused on after the step 6 of the guide. Do I have to also copy the jar file in the /addons folder?

Actually those are very good questions. There is a lot of OH flux especially since the guide was written.

  1. I located the jar here.

  2. I have been placing modified jars in my openhab

  3. and then doing this as appropriate

openhab> bundle:update 280 file:///usr/share/openhab/org.openhab.binding.zwave-3.4.0-SNAPSHOT.jar
openhab> bundle:update 280 file:///usr/share/openhab/org.openhab.binding.zwave-personal-700-final-4.0.0-SNAPSHOT.jar running 2-11-2023
openhab> bundle:update 280 file:///usr/share/openhab/org.openhab.binding.zwave-zse29-4.0.0-SNAPSHOT.jar

Here is where I can find the jar file of the 3.4.2 zwave, after I install it from the UI?

Here is where I place the modified jar after step 6 of the guide?

Everything worked fine with the modified jar file! Thank you all!
Now I have another issue :slight_smile:
I can see data coming from the sensor and change the thermostat mode of the device (heat, cool, etc) but I cannot use the set_temperature mode of the device from inside the UI. For example change the set point on an A/C from the UI. Do you know, if this is possible from the UI?

Glad that is working. :slightly_smiling_face: With OH in flux between OH3 and OH4 there were more stumbling blocks than normal.

Much easier question. There are probably a half dozen ways to do that and personal preference dictates what you use. Probably should read documentation on widgets Building Pages - Components & Widgets | openHAB. I use the stepper card, but a slider card is also an option.
Stepper card

1 Like

Thank you all guys! You have been very helpful! :innocent:

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.