Mi(Xiaomi) Smart home bindings?


(Ted) #486

hey guys,

i have just installed openhab on my qnap by following this guide…
http://docs.openhab.org/installation/qnap.html

the main reason that i wanted to install openHab, is for the xiaomi mi smart home binding. the problem is that it seems like it is the only thing missing from the list (lucky me?) here is a screen http://c2n.me/3OmQ9DP

can you PLEASE help me with this? what can i do to install it? (once again let me remind you that i have installed this on my qnap nas)

thank you
Ted


(Tazeem Naqvi) #487

The binding is named “Xiaomi Mi Smart Home Binding”. It may be further down the list. I would also recommend installing the latest 2.2 Snapshot as some of the Xiaomi items did not work well with prior versions.


(Ted) #488

i looked and searched it is not there. can you please tell me how to check which snapshot i have and how i could update it on my qnap?

thank you


(Tazeem Naqvi) #489

You can grab the latest (and older ones if you like) from here https://openhab.ci.cloudbees.com/job/openHAB-Distribution/.
I have used #1048 with Xiaomi gear and it worked well. You can check the installed version at the bottom very first page when you access OpenHab Web Page (or in the OpenHab console when you start it). I don’t have Qnap so can’t help with updating that.


(Ted) #490

i found a new qpkg to install and i can see it now just fine. it seems to be working.
the problem is with myopenHAB. i have found the UUID and the secret, created the account and it still says that it is offline. not sure what i have to do now


(Tazeem Naqvi) #491

Have you installed “openHAB Cloud Connector”? and configured it?


(Ted) #492

i managed to “fix” it by restarting my nas.

  1. is there a quick way to restart openhab without the need of restarting the whole nas again?
  2. does anyone know if this binding supports Yeelights too?
  3. is it possible to get an event from openHAB to IFTTT? meaning… i want to set an event that if my xiaomi temp sensor reaches 64% of humidity… to do something on IFTTT.

thanks


(marcolino) #493

Hi,
after I installed latest snapshot 2.2.2, strange happen.
If i control Gateway Light from OpenHab, then I cannot turn it on /off from MiHome App.
I have to change the brightness to get back controll from MiHome app.

Second, on illumination channel, i got higher value when i turn off the light. For Example, I got 430, i turn on light and i got 480, then i turn off light and i got 520 and after 2/3 second 490 than is greater that 430.
How i can check if light is turned on or off?

Marco


(Brian M. Pedersen) #494

I get several updates from the illumination reader per hour, its a bit annoying, I get up to about 1200 lux(I think) in the day time and 80-30 in the night time. I also notice that the illumination reader changes value when I switch on the light on the gateway.
I also noted that it reads much higher than my mi flower and auqa motion sensor that was illumination readers too. they are not placed in the same room but the difference can be up to x5.


(Gonzalo Echevarria) #496

Hi, V2.0.0 solved the problem


(Dominic Bonneau) #498

Ok so I had some issue to add my new Xiaomi gateway in openhab so I did a fresh install of openhab 2.2.0 snapshot I had the binding (manually and with the paper UI ) and openhab can’t find my gateway

I’m running openhab on a mic mini on the same wifi my gateway is in dev mode ( I think so it’s in Chinese ) and the firmware is 1.2.1_150.0143

I just check and I think I have a V3 gateway is it suppose to work ?

Can you help me please ?


(Brian M. Pedersen) #499

My gateway registeres as a version 3 dateway, it looks like this: https://www.aliexpress.com/item/Original-Brand-Temperature-Humidity-Sensor-Smart-Socket-Plug-WiFi-Remote-Multifunctional-Gateway-Wireless-Switch-Home-Sensor/32757544238.html?spm=2114.search0204.3.1.7Sh0Yc&ws_ab_test=searchweb0_0,searchweb201602_2_10152_10065_10151_10068_10344_10345_10342_10343_10340_10341_10304_10307_10060_10302_10155_10154_10056_10055_10054_10059_10536_10534_10533_10532_100031_10099_10338_10103_10102_5590020_10052_10053_10142_10107_10050_10051_10171_10084_10083_5370020_10080_10082_10081_10110_10111_10112_10113_10114_5610015_10312_10313_10314_10078_10079_10073,searchweb201603_24,ppcSwitch_5_ppcChannel&btsid=e2ddea85-a46e-43a2-92f2-f3bbe01a9fcb&algo_expid=8ea0d17c-053c-4846-80ef-fedc29777e13-0&algo_pvid=8ea0d17c-053c-4846-80ef-fedc29777e13


(Brian M. Pedersen) #500

I was wondering if there is any difference between the:
auqa (https://www.gearbest.com/access-control/pp_626695.html) and the
classis miaomi switch?(https://www.gearbest.com/smart-light-bulb/pp_257679.html)
The aqua cost a bit more, I was wondering if there was extra feature in this auqa version


(Benjamin) #501

Hi,

today I received my new Aqara water leak sensors and I updated the mihome binding from 2.1.0 to 2.2.0 to get proper support for it. But I cant get them appear in the inbox of openhab :confused:
I add new xiaomi devices via the offline method mentioned here: http://docs.openhab.org/addons/bindings/mihome/readme.html

Any hints how to pair the new sensors? Should it work like it did before with the none-aqara sensors?

Thanks!


(Dominic Bonneau) #502

I have the same one a v3 gateway ! Is it’s working for you ?

I cant find mine paper ui :pensive:


(Sergey M) #503

just a guess, maybe you have not updated the gateway firmware and it does not have leakage sensor support?


(Benjamin) #504

Yes! After a firmware update I can pair them, but nevertheless they don’t appear in openhabs inbox. I paired them manually…


(lonce) #505

Hi did you figure out how this works? I would also like to install the new addon, however the old one keeps showing up.
I’m hoping in this version my In wall Aqara double button switch will work.


(Benjamin) #506

I placed the jar from github in /usr/share/openhab2/addons so it gets automatically picked up by openhab :slight_smile:


(lonce) #507

Mine still shows up as

Xiaomi Mi Smart Home Binding
binding-mihome - 2.1.0

I dropped the file “org.openhab.binding.mihome-2.2.0-SNAPSHOT.jar” in /usr/share/openhab2/addons
I’ve rebooted my pi, the same issue . Still no dice. :frowning: