Missing z-wave device: POPP keypad

Hi, I have an issue with a new Z-Wave+ device, a keypad POPP (#700045). It is not recognized by OpenHab2.

My configuration is as follows:

  • Raspberry Pi with openhabian, openHAB 2.3.0-1 (Release Build).
  • Z-Stick Gen5 AEOTEC ZW090.

I tried multiple paths to have it work, but without success:

  • Uninstall and re-installing the Z-wave binding
  • Remove and re-add the thing
  • Ensure the keypad is in active configuration mode (as battery operated)
  • Use Paper UI or Habmin on my Android device for the addition/removal of the thing

… but unfortunately always without success :frowning:

Each time I get the same unsuccessful message…

Z-Wave Node 8
Unknown Device

This device has not been fully discovered by the binding. There are a few possible reasons for this -:
The device is not in the database. If the device attributes show that this device has a valid manufacturer ID, device ID and type, then this is likely the case (eg. you see a label like “Z-Wave node 1 (0082:6015:020D::2.0)”). Even if the device appears to be in the database, some manufacturers use multiple sets of references for different regions or versions, and your device references may not be in the database. In either case, the database must be updated and you should raise an issue to get this addressed.
The device initialisation is not complete. Once the device is included into the network, the binding must interrogate it to find out what type of device it is. One part of this process is to get the manufacturer information required to identify the device, and until this is done, the device will remain unknown. For mains powered devices, this will occur quickly, however for battery devices the device must be woken up a number of times to allow the discovery phase to complete. This must be performed with the device close to the controller.

Status: ONLINE

zwave_class_basic CONTROLLER
zwave_class_generic SENSOR_NOTIFICATION
zwave_frequent false
zwave_neighbours
zwave_nodeid 8
zwave_version 0.0
zwave_listening false
zwave_routing false
zwave_beaming true
zwave_class_specific NOTIFICATION_SENSOR

I seem to understand this keypad is not setup in the underlying database.

Is there any way to include it?

Thank you very much!
Chris

My guess is that you need to wake the device up - at least, I don’t think it has initialised (based on the very limited properties list you have shown in your mail), and normally this is the reason.

I should have added - it’s also possible the device isn’t in the database from the quick look, but until it’s initialised in your system, we won’t be able to confirm, and wont be able to add it.

https://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-database-guide

Did you get it up and running? I am struggling with the popp keypad in openzwave (Home Assistant or openzwave-control-panel). Does OpenHAB use openzwave, or its own drivers?

No - not at all.

OK, that’s interesting, then we should be able to check similarities/differences between openzwave, HC2 (where it works, but it’s hard to get any meaningful logs), and OpenHAB.

What is the issue in OpenHAB? In openzwave, I can’t include it properly - during the “secure phase” (I think), it stops replying (I get timeout messages).

1 Like

What issue are you referring to? I guess if you have the device, then you can test it right?

I mean from the original post - what exactly is not working (nothing at all, or just “undefined device” and parameters/association groups missing)?

I will probably install openHAB at a point to test, yes.

The original post says that it is not discovered. As you can see there was some discussion to try and work out what is wrong. As far as I can see there shouldn’t be any reason it shouldn’t work but I’ve not tested this myself. I know other keypads are working though.

Hi, unfortunately no. It was not clear to me if the keypad was not completely recognized by the Z-Stick Gen5. Or if openhab could not initiate correctly the device. I made all possible efforts to “wake up” the device, but could not get any better result than the one described in my initial post. Thus for the time being I have installed a simple wired keypad. This is not really comparable to the expectations I had with the POOP Keyboard…

Not sure if you guys could do it work?

  • I just bought the same keypad (POPP 700045)
  • I include it with my USB Gen5 Stick.
  • OpenHAB gets it in the PaperUI (node46)
    But also with “The device initialisation is not complete”.
  • Push ‘ring’ to wake up the keypad?
    Nothing happens.

But… I could get it to work with following steps:

  • Open the back cover (=entering maintenance mode?)
  • I had a master code, so I enter this
    (not sure if it’s needed)
  • Hit the ‘ring’ key 2 times fast
  • Repeat last step 2-3 times

And voila! Nicely added/recognized by Openhab2.

Next step is getting the codes to work. Guess I still have an issue with the network/standalone mode of the devices. Nothing comes in to my server, except when I push the ring key 2 times…

Seems that something isn’t working correctly.

@chris can you have a quick look at my debug log file?
It’s node 48 in my config. Seems that when I hit the ring button 2 times, it’s sending out the battery state. But nothing else. When I enter a code, the node says it’s correct (green light on it), but I can’t find it in the log.
So I’ve got the feeling that we’re missing something on the node (keypad).

openhab.txt (943.4 KB)

I already removed the keypad (before node46), and added it once more. In the manual they mention network mode or standalone mode. And I was afraid I had it the first time in ‘standalone’. So now I’m sure about the network mode. And I didn’t enter a ‘master code’ yet. Easier to test.

ps Is it correct that I say that there are also a lot of timeouts? I’m about 3m away from the Gen5 stick.

You need to wait a couple of days until he is back from holidays.

I don’t see any for node 48:

There are only battery level updates, did you link any other channel to items?

Hey Ben, Sorry, I did not manage to go any further with this keypad…

Lucky guy. Hope that he has a very good time. He earns it. Some offline time. :wink:

I call the ‘no ack’ with ‘huge ms’ timeouts. :blush:
These values are normal? Just trying to understand the logs a bit.

These are my items:

Switch  Keypad_Hekken_Switch    "Keypad Hekken [%s]"           <door>                              { channel="zwave:device:30038385:node48:sensor_binary" }
Number  Keypad_Hekken_Scene     "Keypad Hekken Code [%s]"      <door>                              { channel="zwave:device:30038385:node48:scene_number" }
Switch  Keypad_Hekken_Access    "Keypad Hekken Toegang [%s]"   <door>                              { channel="zwave:device:30038385:node48:alarm_access" }
Switch  Keypad_Hekken_Diefstal  "Keypad Hekken Diefstal [%s]"  <door>                              { channel="zwave:device:30038385:node48:alarm_burglar" }
Number  Keypad_Hekken_Batterij  "Keypad Hekken [%s %%]"        <battery>   (ALL_bat, WO_bat)       { channel="zwave:device:30038385:node48:battery-level" }

My Thing:

Sorry, missed that line.

Lol, battery level is already on 70%, and the devices didn’t worked once properly. :stuck_out_tongue:

Seems that the keypad won’t initialize completely.
When I hit the ring button (twice seems to have more action then once), it should wake up.
Sometimes, the battery-level is communicatied. And every time, the thing is updated.

2019-02-06 12:40:43.982 [me.event.ThingUpdatedEvent] - Thing 'zwave:device:30038385:node52' has been updated.
2019-02-06 12:40:53.468 [me.event.ThingUpdatedEvent] - Thing 'zwave:device:30038385:node52' has been updated.
2019-02-06 12:40:57.809 [me.event.ThingUpdatedEvent] - Thing 'zwave:device:30038385:node52' has been updated.
2019-02-06 12:41:15.135 [me.event.ThingUpdatedEvent] - Thing 'zwave:device:30038385:node52' has been updated.
2019-02-06 12:41:28.603 [vent.ItemStateChangedEvent] - Keypad_Hekken_Batterij changed from 74 to 70
2019-02-06 12:41:28.683 [me.event.ThingUpdatedEvent] - Thing 'zwave:device:30038385:node52' has been updated.




Popp themselves won’t give any support it seems. Only answer I’m gettig is ‘secure Mode’. But no idea what/how/where I should put this. It’s a pitty how bad the service is from hardware producents. Only selling is in their portfolio. They’re lucky that we need hardware. :wink:

Answer Popp Support:

Please include device in secure Mode.
We do not test our devices with third party software.




@chris (or any others :wink: ), not sure if your back from holidays already. But if so, can you help me out with the analyse of the logs? Am I missing something? We’re talking about node52. I’ve already excluded/included the node for about 6 times. But every time the same endresult…

openhab.log (232.9 KB)

ps I’m using Zwave binding 2.5.0M1

I’m back (just) and in recovery mode a little - and trying to work through some of the mails here :wink:

I guess from Popps response that this device might only work fully in secure mode, and looking at the log, I don’t think that the device is included securely.

So, you will need to exclude and reset the device, then include it using the binding (ie not using any button on the stick if you have one). In theory, this should include securely. It’s also possible that you will need to change the “Secure Inclusion Mode” setting in your controller to all devices - I say this because it looks like this device is saying it’s a notification sensor, and therefore the binding won’t include it securely by default.

If this doesn’t work, then please provide a debug log of the inclusion.

I was just searching how I should do this. I’ve found the option to ‘all devices secure inclusion’. But nowhere I see a ‘inclusion mode button’ or so in the binding. :blush:
Any tips where to search?

There is no inclusion button as such - just include it through the inbox. This might be what you have already been doing, I just stated this as it is required for secure inclusion.