Mobile app unable to discover


sudo chmod +x /home/pi/oh2/

that will make makehab executable. just change location to match your install. tried to invite you to the convo, didnt work. for android, check out post different take on ui. promising ui other than habdroid. i just installed it, much better looks than habdroid. also, can follow it on google+


I used the install script down below, not sure if I did it wrong, but the autodiscovery is still not finding it.

Edit: works now, not sure what the issue was.

Does openhab need to be stopped for this script to work properly? and is it advisable to set it up in a CRON job to do every week or so?

definitely stop openhab, as it deletes files. i dont know if id auto update as sometimes there are issues with releases.

so I deleted everything in my /openhab directory and ran the script. Installed openhab fine… only problem I’m having right now is that when I try to bind an item to my Hue bulbs I don’t get a prompt for an item to bind to. Curiously under _default it works fine, but not in my sitemap. Not sure if this is an issue with me, Openhab 2, or the hue snapshot.

Edit: looking more into it, my sonos doesn’t give an option with the associated items file either. Is there a readily identifiable problem with the given .items file I have?
I did check permissions and everything is owned by my user openhab

Group Bedroom
Group Lights
Group Sonos

/*	Lights		*/

Dimmer			Alexa				"Overhead"			<hue>	 			(Bedroom,Lights) 	["homekit:Switch"]		
Color			Lamp			"Lamp"					<hue>				(Bedroom,Lights)	["homekit:Switch"]
Switch			Switch			"Switch"				(Bedroom,Lights)						["homekit:Switch"]

/*	Sonos		*/
Switch		Sonos_Bedroom_Taylor_Power		"Taylor's Bedroom Sonos Power"		(Sonos)	
Dimmer		Sonos_Bedroom_Taylor_Volume		"Taylor's Bedroom Sonos Volume"		(Sonos)

why did you delete?

Because I ran the script without stopping the service and some funky stuff started happening. I also wasn’t sure if I was on the online vs offline distro so I figured best to start fresh, and save my .items and .sitemap files remotely.

the makehab deletes what it needs to for future reference. should keep all sitemaps and items fimes in /conf/sitemaps (items) .

all u have to do is stop openhab, then run makehab.

I wasn’t sure, and I haven’t got things very mature yet in my sitemap so starting fresh isn’t hard. Still don’t know why items won’t show up in my paperUI though. Have you updated / having this issue?

last time i updated was 2 days ago. also, i use habmin for most channel configs

and i would make copies of you sitemap and items file for saving remotely if u are concerned, but just copies. leave them where they belong for use in oh2

question for you now…does your sonos work? do you have more than 1?

I’m working on getting Habmin setup. I still couldn’t get any items to show up when I tried binding them in the paperUI. I’ll keep you posted as I go through this.

if you used makehab, it should already be installed

I commented it out before, as I didn’t think I was going to go that route. Since the paperUI is giving me issues I figured I would try it. I can now bind items to things so it seems as though everything is going smoothly. I’m going to try the Sonos now.

have you looked into rotini?

I have asked to join, pending approval at the moment.

you will like it.

Hope so,

Status update: openhab is not refreshing the items and sitemaps automatically. Not sure what is going on, but changes I make require systemctl restarts which is extremely annoying.

Sonos: Seems to be working at the moment. At least with volume controls. I’d really like to know why the runtime isn’t auto-updating.