Mosquitto broker / MQTT Gosund Smart Plug won't react to ON/OFF

Hello there,

I am running Openhabian 2.5.10-1

I’ve flashed some smart plugs with tasmota.
Now I am trying to control them with openhab.

I followed this guide →

the guide is very useful and understandable.

My problem is, that my tasmota smart plug is not reacting to my commands.
The log shows:
2021-04-11 03:06:04.405 [ome.event.ItemCommandEvent] - Item 'sBrilliantSwitch' received command ON 2021-04-11 03:06:04.411 [nt.ItemStatePredictedEvent] - sBrilliantSwitch predicted to become NULL 2021-04-11 03:06:05.793 [ome.event.ItemCommandEvent] - Item 'sBrilliantSwitch' received command OFF 2021-04-11 03:06:05.797 [nt.ItemStatePredictedEvent] - sBrilliantSwitch predicted to become NULL

I’ve then started to check the broker.
Inside of the PaperUI, the broker is marked as “online”.
Also, I tried to see the connection with putty with the command:
mosquitto_sub -d -t +/Steckdose01/#

When I change the item nothing happens…

I think it is not a problem with my configuration (.things and .items)

I think it’s a problem with my phoscon CONBEE USB Stick…
Cause when I open the webpage from my RPI-IP I get directed to the main page of that USB-Stick (CONBEE II)
After I refreshed the webpage I can see a PINGREQ at Putty while I am tracing the Broker…

My question:
Will, it possible to change the MYQTT Broker IP while it’s running on the same Raspberry with Openhab and the CONBEE Stick for DeconZ ?

Or am I wrong and my configuration is just faulty?

Bridge MQTT:broker:myMQTTBroker "My only one and best MQTT server" [ host="192.168.178.XX", username="TEST", password="TEST", clientID="OpenHAB2" ]
(XX and TEST is not the original code… I’ve edited for here)

// Switch Light Thing mqtt:topic:Steckdose01 "Light switch" { Channels: Type switch : switch "Power Switch" [ stateTopic="stat/Steckdose01/POWER", commandTopic="cmnd/Steckdose01/POWER", on="ON", off="OFF" }

Switch sBrilliantSwitch "Brilliant Light Switch" { channel="mqtt:topic:Steckdose01:switch" }

Maybe I find some help :slight_smile:

I would be happy if I get some help.

Thank you and greetings

If you unplug stick is it working?

The Mosquito Brokers ip is the same as the server it is running on.

Is there anything helpful in the log?

Dose it work after a reboot.?

How are you editing the files?

It may be your things file

Delete things files and change to one file to test.

Bridge mqtt:broker:myMQTTBroker "My only one and best MQTT server" [ host ="192.168.178.XX", secure =false, username ="TEST", password ="TEST" , clientID ="OpenHAB2" ]
    Thing topic Steckdose01 "Light switch" [ availabilityTopic ="tele/Steckdose01/LWT", payloadAvailable ="Online", payloadNotAvailable ="Offline"] {
        Type switch : PowerSwitch "Light Switch"   [ stateTopic ="stat/Steckdose01/POWER", commandTopic ="cmnd/Steckdose01/POWER", on="ON", off="OFF"]


I use to test if things are working

Switch sBrilliantSwitch "Brilliant Light Switch" {channel="mqtt:topic:myMQTTBroker:Steckdose01:PowerSwitch"}
1 Like

which ports do you use ?
In case you the browser and you do not end up on the page that you wanted to see it sounds like the same port is being used for two things ( in meaning of services ).
So what webpage did you intend to open when you were redircted to the main page of CONBEE ?

autoupdate thinks your Item is linked to an inoperative channel. This does point to your configuration.


yes, I got an update problem with the .thing.
I fixed this now the Item is receiving the command “on” and “off” for example
2021-04-11 12:27:56.629 [ome.event.ItemCommandEvent] - Item 'sPorchLight' received command OFF 2021-04-11 12:27:56.636 [nt.ItemStatePredictedEvent] - sPorchLight predicted to become OFF 2021-04-11 12:27:56.675 [vent.ItemStateChangedEvent] - sPorchLight changed from ON to OFF 2021-04-11 12:28:05.495 [ome.event.ItemCommandEvent] - Item 'sPorchLight' received command ON

I’ve named it differently from my first try because I followed the guide again.

Now, this is correctly set, it won’t work again :<

When I open my Raspberry IP address inside a browser I get
Error: Connection failed

I must say, I’ve unplugged the CONBEE II Stick → when I plug it in, I get directly to the MainPage of the CONBEE II.

To my shame, I don’t really know which ports I use, cause I don’t have much knowledge about port handling.

I know that I use :8080 for my openhab side but I think, that’s not that info u want :slight_smile:
The Bridge for the deconz Binding has no port specified in the code. I just have to put the IP and the unic apikey in it.

yeah, I tried to unplug it and reboot it, unfortunately, it does not work :frowning:

summarized, the .thing should work correctly now as I can see in the logs.
I don’t get directed to a Webpage when I open my IP from the raspi.

Should under my IP the MQTT Broker open inside a web browser?
Cause I really don’t see it… I don’t know it at all.

Have a look at Port (computer networking) - Wikipedia it describes what a port in computer networking means.
In case you use an URL in a browser that starts with http and there is no specific port number is mentioned it uses port 80. In case you use https in an URL and do not mention a specific port number it is port 443.
To get an overview which ports are used by your services you may run

sudo netstat -tulpn | more

in a shell. This will show them. Those which have LISTEN in the report are the listening ports.
In case you do not specify a specific port in the browser and you are redirected to the CONBEE page it looks like your CONBEE stick is listening at port 80. You should be able to see that by using the above command. In my case my CONBEE stick is running at port 8090. This also needs to be mentioned in the bridge definition.
What did you expect to see in the browser when you entered you raspis IP address ?

ok that makes sense.

i tried your command after I started the deconz binding and plug the conbee again.

I can see, that as you say the deCONZ ist running under Port 80.
The Mosquitto is running under 1883.

When I understand it correctly, that should not be a problem then.
And both services should run parallel on the raspberry… correct ?

Now I understand why the default port from my tasmota smart plug is 1883.
So this Is correct I think.

mhh what did I expect, I think nothing :smiley:
Cause I don’t know if the mosquito service has an webpage or something like that.

I just tried to figure out why the tasmota smart plug wont react.
Cause inside the MQTT settings the host is my IP Address from the raspberry.
And I thought that this could be a problem with the conbee.

But when the ports are correct that should work parallel when I understand it correctly.

Then is the next question, why the smart plug isn’t reacting… while the mqtt and smartplug thing is “online”.

this is my bridge now:
Bridge mqtt:broker:myMQTTBroker "MQTT Broker" [ host="192.168.178.myip", port=1883, username="myuser", password="mypassword", clientID="OpenHAB2" ]

That is correct.
Is myip in


used to obfuscate the real ip or did you literally use it ? If the later is the case you need to replace myip with the real / correct part of the ip address.

nono its just edited by myself :slight_smile: is the original.

.thing (one file)
Bridge mqtt:broker:myMQTTBroker "MQTTBroker" [ host="", port=1883, username="MYUSER", password="MYPASSWORD", clientID="OpenHAB2" ]

Thing mqtt:topic:swPorchLight "Switch Porch Light" (mqtt:broker:myMQTTBroker) { Channels: Type switch : switch "Power Switch" [ stateTopic="stat/swPorchLight/POWER", commandTopic="cmnd/swPorchLight/POWER", on="ON", off="OFF" ] }

Switch sPorchLight "Porch Light" { channel="mqtt:topic:swPorchLight:switch" }

maybe I just do something wrong :confused:
By the way, the smart plug is a GOSUND SP1.

hm, i tried different forum posts and I come to that point, there are plenty of .things or .items styles… sometimes it uses JSONPATH inside the .item, and sometimes not… I choose the option as you can see above… but I tried it all actually…

I don’t really know what to do now <.<

I’m slightly confused:

  • You have a Gosund smart plug flashed with Tasmota
  • You’re trying to setup OH to control the smart plug via MQTT
  • Where does the CONBEE stick come into all of this? Isn’t that Zigbee? What’s the relation?

i didnt know it…
thats why i ask, I thought there will be a problem with the IP.
Cause under my localhost IP I only get directed to the CONBEE webpage… i didn’t know if that makes any trouble while the localhost IP from the MQTT is also the same…

but I learned, that should not affect each other cause there are using different ports.

I will change the title.

OK, got it!

Can you show us the MQTT parameters page in Tasmota?

What is your MQTT broker? Did you leave all settings at default when you installed your broker? If not, what did you change?

Is anything else using this MQTT broker? Can you prove it is working and relaying messages?

I don’t know either until I know.

IP is in where on the network the computer resides/is. Port is like window in a ship each service has its own port that you connect through.

I can’t see what you don’t post can you share the logs?
Can you use code fences when putting code into forum post just click on </> preformatted text and replace the text “type or paste code here”

Mosquitto is a MQTT broker service it dose not have a webpage console so you can’t point a browser to it. Use the MQTT Explorer I linked above. It will be your window into what is going on.

System integration is the hardest thing to do in IT you are doing great.

I think you are suffering from information overload or forum craziness.

Can you describe how you are doing thinks e.g.

I run openhab2 on a RPI 3 and connect to it from my windows 10 machine. I use VScode with the openHAB extension to edit my config files which has a LSP for making sure things work. It looks like

the items are

Switch Dining_light "Dining Light" { ga="Light", channel="mqtt:topic:myMQTTBroker:fan1:Power1" }
Dimmer Dining_fan "Dining Fan" { ga="Fan" [ speeds="0=off:zero,1=slow:low:one:on,2=medium:two,3=high:three:100", lang="en", ordered=true, roomHint="Dining" ], channel="mqtt:topic:myMQTTBroker:fan1:fanspeed" }
Switch Reachable "Online" {channel="mqtt:topic:myMQTTBroker:fan1:reachable"}

Yes I can change the fan speed by voice with my saying “hey google change the dining fan to medium”

Tasmota looks like this for my IFAN03 from itead

When I goto the console and type in status 0 I get

00:33:19 CMD: status 0 
00:33:19 MQT: IFANdining/stat/STATUS = {"Status":{"Module":71,"DeviceName":"Nextion IFAN dining","FriendlyName":["Nextion IFAN dining"],"Topic":"IFANdining","ButtonTopic":"0","Power":0,"PowerOnState":3,"LedState":1,"LedMask":"FFFF","SaveData":1,"SaveState":1,"SwitchTopic":"0","SwitchMode":[0,0,0,0,0,0,0,0],"ButtonRetain":0,"SwitchRetain":0,"SensorRetain":0,"PowerRetain":0}}
00:33:19 MQT: IFANdining/stat/STATUS1 = {"StatusPRM":{"Baudrate":9600,"SerialConfig":"8N1","GroupTopic":"tasmotas","OtaUrl":"","RestartReason":"Software/System restart","Uptime":"77T10:06:53","StartupUTC":"2021-01-24T13:26:26","Sleep":50,"CfgHolder":4617,"BootCount":23,"BCResetTime":"2021-01-24T14:26:35","SaveCount":1738,"SaveAddress":"F9000"}}
00:33:19 MQT: IFANdining/stat/STATUS2 = {"StatusFWR":{"Version":"9.1.0(tasmota)","BuildDateTime":"2020-11-07T11:57:45","Boot":31,"Core":"2_7_4_5","SDK":"2.2.2-dev(38a443e)","CpuFrequency":80,"Hardware":"ESP8285","CR":"434/699"}}
00:33:19 MQT: IFANdining/stat/STATUS3 = {"StatusLOG":{"SerialLog":0,"WebLog":2,"MqttLog":0,"SysLog":0,"LogHost":"","LogPort":514,"SSId":["UFO_WIFI_IoT",""],"TelePeriod":300,"Resolution":"558180C0","SetOption":["00028009","2805C8000100060000005A00000000000000","00000200","00006000","00000000"]}}
00:33:19 MQT: IFANdining/stat/STATUS4 = {"StatusMEM":{"ProgramSize":600,"Free":400,"Heap":23,"ProgramFlashSize":1024,"FlashSize":1024,"FlashChipId":"144051","FlashFrequency":40,"FlashMode":3,"Features":["00000809","8FDAE797","04368001","000000CF","010013C0","C000F981","00004004","00000000"],"Drivers":"1,2,3,4,5,6,7,8,9,10,12,16,18,19,20,21,22,24,26,27,29,30,35,37","Sensors":"1,2,3,4,5,6"}}
00:33:19 MQT: IFANdining/stat/STATUS5 = {"StatusNET":{"Hostname":"IFANdining-3126","IPAddress":"","Gateway":"","Subnetmask":"","DNSServer":"","Mac":"D8:F1:5B:8F:AC:36","Webserver":2,"WifiConfig":4,"WifiPower":17.0}}
00:33:19 MQT: IFANdining/stat/STATUS6 = {"StatusMQT":{"MqttHost":"","MqttPort":1883,"MqttClientMask":"DVES_%06X","MqttClient":"DVES_8FAC36","MqttUser":"bed","MqttCount":18,"MAX_PACKET_SIZE":1200,"KEEPALIVE":30}}
00:33:19 MQT: IFANdining/stat/STATUS7 = {"StatusTIM":{"UTC":"2021-04-11T23:33:19","Local":"2021-04-12T00:33:19","StartDST":"2021-03-28T02:00:00","EndDST":"2021-10-31T03:00:00","Timezone":"+01:00","Sunrise":"06:04","Sunset":"19:36"}}
00:33:19 MQT: IFANdining/stat/STATUS10 = {"StatusSNS":{"Time":"2021-04-12T00:33:19"}}
00:33:19 MQT: IFANdining/stat/STATUS11 = {"StatusSTS":{"Time":"2021-04-12T00:33:19","Uptime":"77T10:06:53","UptimeSec":6689213,"Heap":23,"SleepMode":"Dynamic","Sleep":10,"LoadAvg":99,"MqttCount":18,"POWER1":"OFF","FanSpeed":0,"Wifi":{"AP":1,"SSId":"UFO_WIFI_IoT","BSSId":"18:E8:29:4A:FB:E0","Channel":11,"RSSI":100,"Signal":-47,"LinkCount":8,"Downtime":"0T00:02:46"}}}

Notice I change the default structure of the mqtt topic to

I use MQTTE to see what is going on

Ok what to do now after taking a break and having something to eat if you haven’t already.

Confirm Tasmota is connected to you Mosquitto Broker using you preferred MQTT client (me MQTTE)

Check the topic structure and messages you are getting is what you assume them to be.

Try and command the device from the client to make sure your assumption of how to control it is correct.

This will turn my light on.

you will need topic cmnd/Steckdose01/POWER

Then look at the openHAB to MQTT side of things.

1 Like

First, thanks for your great answer and time. !

your detailed information helped me a lot actually.
I will try to answer as well as possible.

I run the same Visio setup I think :slight_smile:
Both things are marked.

I am getting this log:

You can see at the bottom, that my connection is faulty…
That was a good tip!

I didn’t know, that I can see something like this inside the console of Tasmota.

07:48:39.496 CMD: status 0
07:48:39.503 RSL: stat/Steckdose01/STATUS = {"Status":{"Module":55,"DeviceName":"Tasmota","FriendlyName":["Tasmota"],"Topic":"Steckdose01","ButtonTopic":"0","Power":0,"PowerOnState":3,"LedState":1,"LedMask":"FFFF","SaveData":1,"SaveState":1,"SwitchTopic":"0","SwitchMode":[0,0,0,0,0,0,0,0],"ButtonRetain":0,"SwitchRetain":0,"SensorRetain":0,"PowerRetain":0,"InfoRetain":0,"StateRetain":0}}
07:48:39.509 RSL: stat/Steckdose01/STATUS1 = {"StatusPRM":{"Baudrate":115200,"SerialConfig":"8N1","GroupTopic":"tasmotas","OtaUrl":"","RestartReason":"Software/System restart","Uptime":"0T00:19:13","StartupUTC":"2021-04-12T06:29:26","Sleep":50,"CfgHolder":4617,"BootCount":20,"BCResetTime":"2021-04-10T20:30:28","SaveCount":66,"SaveAddress":"FA000"}}
07:48:39.516 RSL: stat/Steckdose01/STATUS2 = {"StatusFWR":{"Version":"9.3.1(tasmota)","BuildDateTime":"2021.03.09 16:14:55","Boot":31,"Core":"2_7_4_9","SDK":"2.2.2-dev(38a443e)","CpuFrequency":80,"Hardware":"ESP8285","CR":"369/699"}}
07:48:39.521 RSL: stat/Steckdose01/STATUS3 = {"StatusLOG":{"SerialLog":2,"WebLog":2,"MqttLog":0,"SysLog":0,"LogHost":"","LogPort":514,"SSId":["Raspberry",""],"TelePeriod":300,"Resolution":"558180C0","SetOption":["00008009","2805C8000100060000005A0A000000000000","00000080","00006000","00000000"]}}
07:48:39.531 RSL: stat/Steckdose01/STATUS4 = {"StatusMEM":{"ProgramSize":594,"Free":408,"Heap":27,"ProgramFlashSize":1024,"FlashSize":1024,"FlashChipId":"144051","FlashFrequency":40,"FlashMode":3,"Features":["00000407","8FDAC787","04368001","000000CF","010013C0","C000F981","00004004","00001000","00000000"],"Drivers":"1,2,3,4,5,6,7,8,9,10,12,16,18,19,20,21,22,24,26,27,29,30,35,37,45","Sensors":"1,2,3,4,5,6"}}
07:48:39.538 RSL: stat/Steckdose01/STATUS5 = {"StatusNET":{"Hostname":"Steckdose01-3577","IPAddress":"","Gateway":"","Subnetmask":"","DNSServer":"","Mac":"C4:4F:33:86:ED:F9","Webserver":2,"WifiConfig":4,"WifiPower":17.0}}
07:48:39.543 RSL: stat/Steckdose01/STATUS6 = {"StatusMQT":{"MqttHost":"","MqttPort":1883,"MqttClientMask":"DVES_%06X","MqttClient":"DVES_86EDF9","MqttUser":"Steckdose01","MqttCount":0,"MAX_PACKET_SIZE":1200,"KEEPALIVE":30}}
07:48:39.549 RSL: stat/Steckdose01/STATUS7 = {"StatusTIM":{"UTC":"2021-04-12T06:48:39","Local":"2021-04-12T07:48:39","StartDST":"2021-03-28T02:00:00","EndDST":"2021-10-31T03:00:00","Timezone":"+01:00","Sunrise":"06:04","Sunset":"19:36"}}
07:48:39.553 RSL: stat/Steckdose01/STATUS9 = {"StatusPTH":{"PowerDelta":[0,0,0],"PowerLow":0,"PowerHigh":0,"VoltageLow":0,"VoltageHigh":0,"CurrentLow":0,"CurrentHigh":0}}
07:48:39.560 RSL: stat/Steckdose01/STATUS10 = {"StatusSNS":{"Time":"2021-04-12T07:48:39","ENERGY":{"TotalStartTime":"2021-04-10T20:30:28","Total":0.000,"Yesterday":0.000,"Today":0.000,"Power":0,"ApparentPower":0,"ReactivePower":0,"Factor":0.00,"Voltage":0,"Current":0.000}}}
07:48:39.567 RSL: stat/Steckdose01/STATUS11 = {"StatusSTS":{"Time":"2021-04-12T07:48:39","Uptime":"0T00:19:13","UptimeSec":1153,"Heap":27,"SleepMode":"Dynamic","Sleep":50,"LoadAvg":21,"MqttCount":0,"POWER":"OFF","Wifi":{"AP":1,"SSId":"Raspberry","BSSId":"DC:39:6F:14:1E:B0","Channel":7,"RSSI":100,"Signal":-50,"LinkCount":1,"Downtime":"0T00:00:03"}}}
07:48:46.294 MQT: Verbindungsversuch...
07:48:46.305 MQT: Verbindung fehlgeschlagen aufgrund von, rc 5. Wiederversuch in 120 s

My settings:

now it’s getting hard for me, I connected to MQTTE.
as you can see, I am able to see 3 “things” dont know why but for a first try okay.
All “things” are offline.
I think here is my problem.

I tried a lot, but I am not able to get it “online”.

under the point “tasmota” → discovery is this my device ?
cause the log of the tasmota device says connection failed :open_mouth:
that confuses me a bit.

so in my case I would type it at →

or at the discovered tasmota ?
under tastmota → discovery

cause of my failure above, I think that doesn’t work for me at the moment :slight_smile:

okay, I think the main problem is the connection to the device or to the MQTT broker.

I’m having trouble clearly following all this, but it looks like you’re having a fundamental issue connecting reliably to your MQTT broker - this needs to be sorted out first.

Again: what broker are you running? What version is it? Mosquitto has had a very recent update which requires existing configurations to be modified, but I don’t know if that’s the case for a fresh install.

I would at least remove the username and password from your broker to reduce the amount of things that can go wrong at this stage.


I think you need to resolve this connection issue first as @hafniumzinc points out.

as you are running openhabian using check version by trying to run mosquitto again


Where the green is highlighted

The topic is cmnd/Steckdose01/POWER

The box below is the Message you want to send to the topic. ON
You can use TOGGLE for testing then every time you publish it should change.

Please read commands over mqtt you probably already have.

1 Like

Thank you for your time,

it is a shame in which error I run…

I was so obsessed with all that information around the forums that I didn’t understand, that I was not saving my password for MQTT at the Tasmota device…
That was a hard process…

Okay, I am getting over it… :slight_smile:
That’s why my device on the screenshots is “offline”… well when I save the correct password it works… what a miracle… shame on me :smiley:

Well the MQTT Explorer is so helpful for me, that helps a lot.

Back to the question I am running mosquito 1.5.7.

My first Smart Plug works fine.
I can control it via MQTTE and also via Openhab.


		Type switch : ch1               "AN/AUS"          [ stateTopic="stat/Steckdose_01/POWER", commandTopic="cmnd/Steckdose_01/POWER", on="ON", off="OFF" ]
		Type number : ch1PowerTotal     "Energie Total"   [ stateTopic="tele/Steckdose_01/SENSOR", transformationPattern="JSONPATH:$.ENERGY.Total" ]
        Type number : ch1Power          "Leistung"        [ stateTopic="tele/Steckdose_01/SENSOR", transformationPattern="JSONPATH:$.ENERGY.Power" ]
		Type number : ch1Voltage        "Spannung"        [ stateTopic="tele/Steckdose_01/SENSOR", transformationPattern="JSONPATH:$.ENERGY.Voltage" ]
		Type number : ch1Current        "Strom"           [ stateTopic="tele/Steckdose_01/SENSOR", transformationPattern="JSONPATH:$.ENERGY.Current" ]


Switch S1_Switch "Steckdose Test"                         { channel="mqtt:topic:Steckdose_01:ch1" }
Number S1_Power_Total "Energie Total: [%.3f kWh]"         { channel="mqtt:topic:Steckdose_01:ch1PowerTotal" }
Number S1_Power_Today "Energie Heute: [%.3f kWh]"         { channel="mqtt:topic:Steckdose_01:ch1Power" }
Number S1_Voltage "Spannung: [%.0f V]"                    { channel="mqtt:topic:Steckdose_01:ch1Voltage" }
Number S1_Current "Strom: [%.3f A]"                       { channel="mqtt:topic:Steckdose_01:ch1Current" }

After the first Smartplug works fine for me, I noticed that the channels are randomly updated.
I found in the MQTT Binding a rule-> MQTT Things and Channels - Bindings | openHAB

I’ve tried to type the Status into the console of the tastmota device.
Status 8 should be the one I need for Updating current-voltage etc.

Console Tasmota Device

15:29:20.045 CMD: status 8
15:29:20.055 MQT: stat/Steckdose_01/STATUS8 = {"StatusSNS":{"Time":"2021-04-12T15:29:20","ENERGY":{"TotalStartTime":"2021-04-10T20:30:28","Total":0.054,"Yesterday":0.000,"Today":0.054,"Power":0,"ApparentPower":0,"ReactivePower":0,"Factor":0.00,"Voltage":0,"Current":0.000}}}

My rule looks like this:

rule "TEST"
	Time cron "0 0/1 * 1/1 * ? *"
	val mqttActions = getActions("mqtt","mqtt:broker:myMQTTBroker")
    logInfo("Tasmota.rules", "TASMOTA Update") 


It triggers every minute (just for testing) but anyways, the items are not getting updated in OH.

The rule is getting triggered, I just see the loginfo which I build into

2021-04-12 16:19:00.037 [INFO ] [smarthome.model.script.Tasmota.rules] - TASMOTA Update

I can also see via the MQTTE that the Status fields are getting updated with that rule → in MQTTE the Status fields are “lighten” up when it refreshes.

You haven’t got any Things listening for the topic state/Steckdose_01/STATUS8 so openHAB ignores it.

mhh, that confuses me a bit.

I thought when I update status 8 all things will receive the “updated” information.
That is probably wrong as you said.

So did I need to create for everything I want to update a status8 command ?
Or will “one” status 8 thing update all ?

I try actually this one here:

Type string : Power2      [stateTopic="stat/Steckdose_01/STATUS8", transformationPattern="JSONPATH:$.StatusSNS.Voltage"]

I’ve also tried it with

String Power2 "Tasmota Version [%.0f V] "                           { channel="mqtt:topic:Steckdose_01:Power2" }

I ran into an Error all the time which I can’t fix.

2021-04-12 19:35:00.059 [WARN ] [t.generic.ChannelStateTransformation] - Executing the JSONPATH-transformation failed: Invalid path '$.StatusSNS.Voltage' in '{"StatusSNS":{"Time":"2021-04-12T18:35:00","ENERGY":{"TotalStartTime":"2021-04-10T20:30:28","Total":0.060,"Yesterday":0.000,"Today":0.060,"Power":0,"ApparentPower":0,"ReactivePower":0,"Factor":0.00,"Voltage":0,"Current":0.000}}}'

It says invalid path… but StatusSNS should be correct and .voltage is also available inside the status8.
I don’t see what I do wrong :open_mouth:

Can you maybe explain me my fault ?