MQTT + Tasmota + H801 First Time Setup in OH3

Hello there,

I’ve dived into the deep end, and require some assistance making sense of how to link MQTT things and make them work…

A little background, after hearing that the H801 LED modules provided decent PWM dimming, both with RGB+W+WW, as well as being able to function as a 5 channel White controller as well, I ordered 4 of them to replace the various “MagicHome” LED controllers I have around the house.

I’ve soldered the pin headers, used a 3.3 volt FTDI controller to initially flash one of them with Tasmota successfully.
I’ve connected it to my WiFi, and set up all 5 outputs as individual channels (that appear to work) from it’s own web interface, and I’ve set it’s Topic to: tasmota_ul_office through it’s interface as well.

Now I’ve also set up Mosquitto, I’ve gotten the MQTT Binding installed, I’ve also gotten the Broker configured through OpenHAB 3… Although I’m running into issues with getting the things set up, as well as how to make sense of how the topic works, as I have been attempting to work on this all day without success of being able to turn it on/off or dim it through OpenHAB.

I initially tried to follow
[OH3] MQTT Setup and Configuration and
[OH3] Tasmota relay via MQTT (Sonoff Basic with optional DHT22)
although was unsuccessful during the second tutorial, and then moved the configurations to things files to attempt to keep it more organized, and easier to visualize what was happening although am unsure how to proceed…

Here are my configurations

mqttbroker.things:

mqtt:broker:mosquitto [
    host="192.168.1.27",
    secure=false,
    port=1883,
    username="openhab",
    password="password"
]

mqtt.things:

Bridge mqtt:broker:mosquitto "MQTT Broker" @ "Networking Closet" [
    host="192.168.1.27",
    secure=false,
    port=1883,
    username="openhab",
    password="password" ]
{

    Thing topic OfficeLED1 "Office LED 1" @ "Office" {
    Channels:
        Type switch :   led1    "Switch 1 Power"     [ stateTopic="stat/tasmota_ul_office/POWER1", commandTopic="cmnd/tasmota_ul_office/POWER1" ]
    }

}

And just to attempt to make a dumb switch to toggle it on and off to start (although I’d like to have dimming control)
switch.items:

Dimmer A_MySwitch_Dim   "A H801 Dimmer"     (UL_Office, Lights)     {mqtt=">[broker:cmnd/OfficeLED1/DIMMER:command:*:default],<[broker:stat/OfficeLED1/RESULT:state:JSONPATH($.Dimmer)]",autoupdate="false"}
Switch A_MySwitch       "A H801 Switch"     (UL_Office, Lights)     {mqtt=">[broker:cmnd/OfficeLED1/POWER:command:*:default],<[broker:stat/OfficeLED1/RESULT:state:JSONPATH($.POWER)]",autoupdate="false"}

Ultimately I’d like the ability to turn each channel on and off, as well as dim them via rules like I’ve set up with my TPLink Kasa dimmers. If anyone could assist in showing me what I’m doing wrong, I would appreciate it immensely. :slight_smile:

Thank you for your time!

Ok you are using a mixture of tutorials and have outdated information :slight_smile:

Do you want to do it in the UI or Config files?

Delete MQTT Bridges in UI
Delete ALL Current MQTT thing files and put only this in 1 file

Bridge mqtt:broker:mosquitto [ host ="192.168.1.27", secure =false, username ="openhab", password ="password" ]
{
 
    Thing topic OfficeLED1 "Office LED 1" @ "Office" [ availabilityTopic="tele/tasmota_ul_office/LWT", payloadAvailable="Online", payloadNotAvailable="Offline"] {
    Channels:
            Type switch :   led1     "Switch 1 Power"     [ stateTopic="stat/tasmota_ul_office/POWER1", commandTopic="cmnd/tasmota_ul_office/POWER1" ]
            Type dimmer :   DIM_led1 "Dimmer LED one"     [ stateTopic="stat/tasmota_ul_office/DIMMER", commandTopic="cmnd/tasmota_ul_office/DIMMER" ]
}


Then you items file

Switch   OfficeLED1Led1      "Switch 1 power"   {channel="mqtt:topic:mosquitto:OfficeLED1:led1"}
Dimmer   OfficeLED1DIMLed1   "Dimmer led one"   {channel="mqtt:topic:mosquitto:OfficeLED1:DIM_led1"}

You only really need the dimmer channel because you can send on off to tasmota using the dimmer channel

1 Like

I agree with @denominator. Your files:

  • Create two connections to Mosquitto
  • Uses very old v1 binding syntax for your Items, but you’re using the v2 binding and they’re not compatible (and v1 bindings no longer work in OH3)

As suggested remove everything that you’ve already tried, both from files and UI, then start again using the example provided by @denominator . You may need to add

, on="ON", off="OFF"

after your commandTopic on the switch Channel - I can never remember if openHAB is smart enough to not require this so I always add it in.

I’d also suggest using an MQTT sniffer like MQTT Explorer so that you can plug directly into Mosquitto and see what’s going on - which topics are relevant, and what the correct messages should be.

1 Like

openHAB is all capital only ON, OFF, DOWN, INCREASE etc.

tasmota use to be lower case only, now its either. All my old configs still have the mapping

1 Like

Thank you SO MUCH for pointing me in the right direction.

@denominator your code worked to toggle it on and off, but the dimmer control did not appear to do anything.

I did some slight renaming (mainly for my own convenience of keeping track of things), as well as there was a validation issue with the Bridge code (second set of curly brackets around the “Channels” was missing)

With a bit of tinkering in the Tasmota Console on the device, I found entering “channel1 50” would set channel 1 to 50% so I changed that and behold.

mqtt.things:

Bridge mqtt:broker:mosquitto "MQTT Broker" @ "Networking Closet" [
    host="192.168.1.27",
    secure=false,
    port=1883,
    username="openhab",
    password="password" ]
{

    Thing topic OfficeH801 "Office LED 1" @ "Office" [ availabilityTopic="tele/tasmota_ul_office/LWT", payloadAvailable="Online", payloadNotAvailable="Offline"] {
    Channels:
            Type switch :   channel1     "Channel 1 Power"     [ stateTopic="stat/tasmota_ul_office/power1", commandTopic="cmnd/tasmota_ul_office/power1", on="ON", off="OFF" ]
            Type dimmer :   channel1dim  "Channel 1 Dimmer"    [ stateTopic="stat/tasmota_ul_office/channel1", commandTopic="cmnd/tasmota_ul_office/channel1", min=0, max=100, step=1, ON="ON", OFF="OFF"]
    }

}

Items file:

Switch   OfficeH801_1      "Channel 1 Power"    {channel="mqtt:topic:mosquitto:OfficeH801:channel1"}
Dimmer   OfficeH801_1DIM   "Channel 1 Dimmer"   {channel="mqtt:topic:mosquitto:OfficeH801:channel1dim"}

Thank you @denominator and @hafniumzinc for your help. Confirmed working with universalDimmer too for fading the light on and off. :slight_smile:

Now that I have a baseline of what’s required, I can finish flashing and setting up the other 3 modules, and have what I need to get everything up and running.

This is such a great community. :slight_smile:

Sorry for Typo

Where did you get the topic channel1 from?

Look at the tasmota command documentation Commands - Tasmota

So sending 23 to the topic cmnd/tasmota_ul_office/DIMMER
is the same as typing DIMMER 23 in the tasmota console

Install JSON path Transformation if you have not allready

I the tasmota console enter setoption4 1
This changes how tasmota sends status to MQTT and makes it a little easier on the brain

Return MQTT response as
0 = RESULT topic (default)
1 = %COMMAND% topic

https://tasmota.github.io/docs/Commands/#setoptions

Change channel to

        Type dimmer :   channel1dim  "Channel 1 Dimmer"    [ stateTopic="stat/tasmota_ul_office/DIMMER", commandTopic="cmnd/tasmota_ul_office/DIMMER",  transformationPattern ="JSONPATH:$.Dimmer"]

You will be able to send ON, OFF, 0 - 100 INCREASE .etc to item and when you change it on the devices page you should see it change in openHAB aswell

Initially while playing around with the console I did the following:

I used “SetOption15” to enable control with Dimmer commands

SetOption15 Set PWM control for LED lights
0 = basic PWM control
1 = control with Color or Dimmer commands

And then I found the Channel topic from under “Light” Here:
https://tasmota.github.io/docs/Commands/#light

Channel 0..100 = set PWM channel dimmer value from 0 to 100%
+ = increase by 10
- = decrease by 10
When SetOption68 is set to 1 Channel<x> will follow Power<x> numbering with Relays first then PWM.
Example:
2 Relays and 3 PWM: Relay1 = Power1; Relay2 = Power2; PWM1 = Power3 and Channel3; PWM2 = Power4 and Channel4; PWM3 = Power5 and Channel5

I had found the Dimmer command, but while trying that in the console, it didn’t seem to do anything when I sent that command, although I’ll give your code a try here in just a moment. :slight_smile:

Okay, I tried what you suggested (Already had JSON path Transformation installed), in the Tasmota Console I entered setoption4 1, and swapped your code in, and the dimmer slider is dead. I made no other changes (unless my previous setoption15 and setoption68 may be interfering)

openhab.log:

2021-02-25 22:09:58.247 [WARN ] [t.generic.ChannelStateTransformation] - Executing the JSONPATH-transformation failed: Invalid path '$.Dimmer' in '{"POWER1":"ON","Channel1":22,"POWER2":"OFF","Channel2":0,"POWER3":"OFF","Channel3":0,"POWER4":"OFF","Channel4":0,"POWER5":"OFF","Channel5":0,"Color":"3800000000"}'
2021-02-25 22:09:59.628 [WARN ] [t.generic.ChannelStateTransformation] - Executing the JSONPATH-transformation failed: Invalid path '$.Dimmer' in '{"POWER1":"ON","Channel1":22,"POWER2":"OFF","Channel2":0,"POWER3":"OFF","Channel3":0,"POWER4":"OFF","Channel4":0,"POWER5":"OFF","Channel5":0,"Color":"3800000000"}'
2021-02-25 22:10:01.221 [WARN ] [t.generic.ChannelStateTransformation] - Executing the JSONPATH-transformation failed: Invalid path '$.Dimmer' in '{"POWER1":"ON","Channel1":22,"POWER2":"OFF","Channel2":0,"POWER3":"OFF","Channel3":0,"POWER4":"OFF","Channel4":0,"POWER5":"OFF","Channel5":0,"Color":"3800000000"}'
2021-02-25 22:10:58.018 [WARN ] [t.generic.ChannelStateTransformation] - Executing the JSONPATH-transformation failed: Invalid path '$.Dimmer' in '{"POWER1":"ON","Channel1":22,"POWER2":"OFF","Channel2":0,"POWER3":"OFF","Channel3":0,"POWER4":"OFF","Channel4":0,"POWER5":"OFF","Channel5":0,"Color":"3800000000"}'
2021-02-25 22:10:59.124 [WARN ] [t.generic.ChannelStateTransformation] - Executing the JSONPATH-transformation failed: Invalid path '$.Dimmer' in '{"POWER1":"ON","Channel1":22,"POWER2":"OFF","Channel2":0,"POWER3":"OFF","Channel3":0,"POWER4":"OFF","Channel4":0,"POWER5":"OFF","Channel5":0,"Color":"3800000000"}'
1 Like

Ok cool so we are configuring tasmota differently maybe.
setoption15 default is on

Can you change setoption68 0 and test.

Can you post the result of status 0 so I can config example the same

If you need to use setoption68 that can be achieved aswell.

the + and - are not valid commands for dimmer item in openHAB

Ah ha, Yup, my setoption68 was set to 1 (because I figured, if I wanted to drive multiple light strips and dim them individually that would probably be my best bet)

With that off, your code does indeed work, although wouldn’t that mean if I set up any additional LED strips on any of the other 4 channels, they’d all be dimmed at the same level? :slight_smile:

Gotta love the configurability of these things.

Status 0:

06:33:37.908 CMD: status 0
06:33:37.917 MQT: stat/tasmota_ul_office/STATUS = {"Status":{"Module":0,"DeviceName":"Office","FriendlyName":["Office1"],"Topic":"tasmota_ul_office","ButtonTopic":"0","Power":1,"PowerOnState":3,"LedState":1,"LedMask":"FFFF","SaveData":1,"SaveState":1,"SwitchTopic":"0","SwitchMode":[0,0,0,0,0,0,0,0],"ButtonRetain":0,"SwitchRetain":0,"SensorRetain":0,"PowerRetain":0,"InfoRetain":0,"StateRetain":0}}
06:33:37.948 MQT: stat/tasmota_ul_office/STATUS1 = {"StatusPRM":{"Baudrate":115200,"SerialConfig":"8N1","GroupTopic":"tasmotas","OtaUrl":"http://ota.tasmota.com/tasmota/release/tasmota.bin.gz","RestartReason":"Software/System restart","Uptime":"0T00:04:06","StartupUTC":"2021-02-26T05:29:31","Sleep":50,"CfgHolder":4617,"BootCount":32,"BCResetTime":"2021-02-25T19:56:23","SaveCount":382,"SaveAddress":"F6000"}}
06:33:37.985 MQT: stat/tasmota_ul_office/STATUS2 = {"StatusFWR":{"Version":"9.3.1(tasmota)","BuildDateTime":"2021-02-23T12:02:38","Boot":31,"Core":"2_7_4_9","SDK":"2.2.2-dev(38a443e)","CpuFrequency":80,"Hardware":"ESP8266EX","CR":"399/699"}}
06:33:38.002 MQT: stat/tasmota_ul_office/STATUS3 = {"StatusLOG":{"SerialLog":2,"WebLog":2,"MqttLog":0,"SysLog":0,"LogHost":"","LogPort":514,"SSId":["1BF7A5NoT",""],"TelePeriod":300,"Resolution":"558180C0","SetOption":["00008019","2805C8000100060000005A0A000000000000","00000080","00006000","00000000"]}}
06:33:38.034 MQT: stat/tasmota_ul_office/STATUS4 = {"StatusMEM":{"ProgramSize":593,"Free":408,"Heap":26,"ProgramFlashSize":1024,"FlashSize":1024,"FlashChipId":"1440EF","FlashFrequency":40,"FlashMode":3,"Features":["00000809","8FDAC787","04368001","000000CF","010013C0","C000F981","00004004","00001000","00000000"],"Drivers":"1,2,3,4,5,6,7,8,9,10,12,16,18,19,20,21,22,24,26,27,29,30,35,37,45","Sensors":"1,2,3,4,5,6"}}
06:33:38.068 MQT: stat/tasmota_ul_office/STATUS5 = {"StatusNET":{"Hostname":"tasmota_ul_office-5797","IPAddress":"192.168.50.6","Gateway":"192.168.50.1","Subnetmask":"255.255.255.0","DNSServer":"9.9.9.9","Mac":"98:F4:AB:CF:16:A5","Webserver":2,"WifiConfig":4,"WifiPower":17.0}}
06:33:38.092 MQT: stat/tasmota_ul_office/STATUS6 = {"StatusMQT":{"MqttHost":"192.168.1.27","MqttPort":1883,"MqttClientMask":"DVES_%06X","MqttClient":"DVES_CF16A5","MqttUser":"openhab","MqttCount":1,"MAX_PACKET_SIZE":1200,"KEEPALIVE":30}}
06:33:38.113 MQT: stat/tasmota_ul_office/STATUS7 = {"StatusTIM":{"UTC":"2021-02-26T05:33:38","Local":"2021-02-26T06:33:38","StartDST":"2021-03-28T02:00:00","EndDST":"2021-10-31T03:00:00","Timezone":"+01:00","Sunrise":"07:37","Sunset":"18:28"}}
06:33:38.133 MQT: stat/tasmota_ul_office/STATUS10 = {"StatusSNS":{"Time":"2021-02-26T06:33:38"}}
06:33:38.144 MQT: stat/tasmota_ul_office/STATUS11 = {"StatusSTS":{"Time":"2021-02-26T06:33:38","Uptime":"0T00:04:07","UptimeSec":247,"Heap":26,"SleepMode":"Dynamic","Sleep":10,"LoadAvg":99,"MqttCount":1,"POWER":"ON","Dimmer":11,"Color":"1C00000000","HSBColor":"0,100,11","White":0,"CT":153,"Channel":[11,0,0,0,0],"Scheme":0,"Fade":"OFF","Speed":1,"LedTable":"ON","Wifi":{"AP":1,"SSId":"1BF7A5NoT","BSSId":"1E:EC:DA:84:1D:66","Channel":8,"RSSI":82,"Signal":-59,"LinkCount":1,"Downtime":"0T00:00:03"}}}

Well I have 1 channel dimmers in wall

Still running tasmota 6.7.0 :slight_smile:

So you will need to use setoption68 so turn that back on and

SetOption37 5

Your template may look like
{"NAME":"H801","GPIO":[0,52,0,0,41,57,0,0,39,38,40,37,0],"FLAG":0,"BASE":20}
image
image

This will change everything in openHAB to … next post

Change thing channel to

    Channels:
            Type switch :   C1_Power   "Led 1 Name"        [ stateTopic="stat/tasmota_ul_office/POWER1", commandTopic="cmnd/tasmota_ul_office/POWER1", on="ON", off="OFF" ]
            Type dimmer :   C1_dimmer  "Led 1 Name Dimmer" [ stateTopic="stat/tasmota_ul_office/CHANNEL", commandTopic="cmnd/tasmota_ul_office/CHANNEL1",  transformationPattern ="JSONPATH:$.Channel1"]  
            Type switch :   C2_Power   "Led 2 Name"        [ stateTopic="stat/tasmota_ul_office/POWER2", commandTopic="cmnd/tasmota_ul_office/POWER2", on="ON", off="OFF" ]
            Type dimmer :   C2_dimmer  "Led 2 Name Dimmer" [ stateTopic="stat/tasmota_ul_office/CHANNEL", commandTopic="cmnd/tasmota_ul_office/CHANNEL2",  transformationPattern ="JSONPATH:$.Channel2"]  
            Type switch :   C3_Power   "Led 3 Name"        [ stateTopic="stat/tasmota_ul_office/POWER3", commandTopic="cmnd/tasmota_ul_office/POWER3", on="ON", off="OFF" ]
            Type dimmer :   C3_dimmer  "Led 3 Name Dimmer" [ stateTopic="stat/tasmota_ul_office/CHANNEL", commandTopic="cmnd/tasmota_ul_office/CHANNEL3",  transformationPattern ="JSONPATH:$.Channel3"]  
            Type switch :   C4_Power   "Led 4 Name"        [ stateTopic="stat/tasmota_ul_office/POWER4", commandTopic="cmnd/tasmota_ul_office/POWER4", on="ON", off="OFF" ]
            Type dimmer :   C4_dimmer  "Led 4 Name Dimmer" [ stateTopic="stat/tasmota_ul_office/CHANNEL", commandTopic="cmnd/tasmota_ul_office/CHANNEL4",  transformationPattern ="JSONPATH:$.Channel4"]  
            Type switch :   C5_Power   "Led 5 Name"        [ stateTopic="stat/tasmota_ul_office/POWER5", commandTopic="cmnd/tasmota_ul_office/POWER5", on="ON", off="OFF" ]
            Type dimmer :   C5_dimmer  "Led 5 Name Dimmer" [ stateTopic="stat/tasmota_ul_office/CHANNEL", commandTopic="cmnd/tasmota_ul_office/CHANNEL5",  transformationPattern ="JSONPATH:$.Channel5"]  

Items to


Switch   OfficeLED1C1Power    "Led 1 name"          {channel="mqtt:topic:mosquitto:OfficeH801:C1_Power"}
Dimmer   OfficeLED1C1Dimmer   "Led 1 name dimmer"   {channel="mqtt:topic:mosquitto:OfficeH801:C1_dimmer"}
Switch   OfficeLED1C2Power    "Led 2 name"          {channel="mqtt:topic:mosquitto:OfficeH801:C2_Power"}
Dimmer   OfficeLED1C2Dimmer   "Led 2 name dimmer"   {channel="mqtt:topic:mosquitto:OfficeH801:C2_dimmer"}
Switch   OfficeLED1C3Power    "Led 3 name"          {channel="mqtt:topic:mosquitto:OfficeH801:C3_Power"}
Dimmer   OfficeLED1C3Dimmer   "Led 3 name dimmer"   {channel="mqtt:topic:mosquitto:OfficeH801:C3_dimmer"}
Switch   OfficeLED1C4Power    "Led 4 name"          {channel="mqtt:topic:mosquitto:OfficeH801:C4_Power"}
Dimmer   OfficeLED1C4Dimmer   "Led 4 name dimmer"   {channel="mqtt:topic:mosquitto:OfficeH801:C4_dimmer"}
Switch   OfficeLED1C5Power    "Led 5 name"          {channel="mqtt:topic:mosquitto:OfficeH801:C5_Power"}
Dimmer   OfficeLED1C5Dimmer   "Led 5 name dimmer"   {channel="mqtt:topic:mosquitto:OfficeH801:C5_dimmer"}
2 Likes

Thank you so much! I wish I could buy you a beer, or whatever your preferred drink is. You’ve been so helpful, and this is all exactly what I was after. I doubt I’ll use all 5 channels on all 4 modules, but they are there if/when I need them, and I have some big plans.

I have a single MagicHome Module in the basement with with a wire up through the floor controlling some under-shelf lighting in my Pantry that I installed a few weeks ago, going to swap that out with one of these H801’s, and then use a second channel to run some wire just around the corner to power an LED strip under the stairs where my “Network Closet” and Servers are. Have a few Sonoff sensors on their way from AliExpress, was thinking a motion sensor to toggle those lights on for 10 minutes at a time, but I’m getting a bit off topic.

And to think I was tinkering, and tinkering, and re-writing, and googling, and tinkering, and googling for about 6 to 7 hours today with no luck, when I thought… I’ll try posting in the forum.

Wish I would have asked for help a little sooner… Once again, thank you very much for all your help, I really appreciate it! :slight_smile:

–Edit–
I can also definitely see why your code is superior to my previous channel1 value code, now OpenHAB is aware of the state, regardless of where it’s changed (even directly from the Tasmota page) and reflects the change of state on/off or dimming value almost in realtime on the OpenHAB page.

–Edit2–
Bought you a few Ko-fi’s to show my appreciation!

1 Like

Cool thanks

if you wanted to do another one in the MainUI you can do that too here is some code to look at its the same data just presented differently.

Create a new generic mqtt thing

UID: mqtt:topic:mosquitto:Office_Controler
label: Office LED Controller
thingTypeUID: mqtt:topic
configuration:
  payloadNotAvailable: Offline
  availabilityTopic: tele/tasmota_ul_office/LWT
  payloadAvailable: Online
bridgeUID: mqtt:broker:mosquitto
channels:
  - id: 1CHAN
    channelTypeUID: mqtt:switch
    label: First LED Light
    description: ""
    configuration:
      commandTopic: cmnd/tasmota_ul_office/POWER1
      stateTopic: stat/tasmota_ul_office/POWER1
  - id: 1chan_dim
    channelTypeUID: mqtt:dimmer
    label: 1st LED Dimmer
    description: ""
    configuration:
      postCommand: true
      min: 0
      qos: 1
      transformationPatternOut: JSONPATH:$.Channel1
      max: 1
      commandTopic: cmnd/tasmota_ul_office/CHANNEL1
      transformationPattern: stat/tasmota_ul_office/CHANNEL
      stateTopic: stat/tasmota_ul_office/CHANNEL

Then in the Model page you can create equipment from thing to create you items easily

Hey @denominator MQTT has been working great, except for some warnings in my openhab.log file, just wanted to see if something else needed to be tweaked?

Any time I use the call ItemNamePower.sendCommand(ON) or ItemNamePower.sendCommand(OFF) on any of those H801 channels, it works, and will turn said item on and off, although my log is filled with hundreds of the following warnings (one for any time a channel is toggled by on/off via the power/switch channel):

2021-02-28 00:41:07.517 [WARN ] [ab.binding.mqtt.generic.ChannelState] - Command '{"POWER2":"ON"}' not supported by type 'OnOffValue': No enum constant org.openhab.core.library.types.OnOffType.{"POWER2":"ON"}
2021-02-28 00:41:08.373 [WARN ] [ab.binding.mqtt.generic.ChannelState] - Command '{"POWER2":"OFF"}' not supported by type 'OnOffValue': No enum constant org.openhab.core.library.types.OnOffType.{"POWER2":"OFF"}
2021-02-28 00:43:12.396 [WARN ] [ab.binding.mqtt.generic.ChannelState] - Command '{"POWER2":"ON"}' not supported by type 'OnOffValue': No enum constant org.openhab.core.library.types.OnOffType.{"POWER2":"ON"}
2021-02-28 00:45:12.452 [WARN ] [ab.binding.mqtt.generic.ChannelState] - Command '{"POWER2":"OFF"}' not supported by type 'OnOffValue': No enum constant org.openhab.core.library.types.OnOffType.{"POWER2":"OFF"}

And the related output in the tasmota console on that H801

08:41:03.779 MQT: stat/tasmota_bl_basement/CHANNEL = {"POWER1":"OFF","Channel1":100,"POWER2":"ON","Channel2":100,"POWER3":"OFF","Channel3":0,"POWER4":"OFF","Channel4":0,"POWER5":"OFF","Channel5":0,"Color":"FFFF000000"}
08:41:07.286 MQT: stat/tasmota_bl_basement/POWER2 = {"POWER2":"ON"}
08:41:07.291 MQT: stat/tasmota_bl_basement/POWER2 = ON
08:41:08.143 MQT: stat/tasmota_bl_basement/POWER2 = {"POWER2":"OFF"}
08:41:08.147 MQT: stat/tasmota_bl_basement/POWER2 = OFF
08:43:12.160 MQT: stat/tasmota_bl_basement/POWER2 = {"POWER2":"ON"}
08:43:12.165 MQT: stat/tasmota_bl_basement/POWER2 = ON
08:45:12.210 MQT: stat/tasmota_bl_basement/POWER2 = {"POWER2":"OFF"}
08:45:12.214 MQT: stat/tasmota_bl_basement/POWER2 = OFF

I have found though, that instead of calling for On/Off of the Power Switch, instead rather calling the dimming function ItemNameDimmer.sendCommand(100) / ItemNameDimmer.sendCommand(0) for example works without any errors or warnings in the logs and correctly turns said light on or off.

Should I just do away with the power switches altogether and just start calling the dimming channel to turn lights on/off in rules? Or is there something I’m overlooking with the MQTT channels, and something with the on=“ON”, off=“OFF” bit?

Yeah tasmota sends it in JSON and just ON or OFF

You could filter it out with REGEX

What happends when you send ON to the dimmer channel ?

Ah ha, ON/OFF to the dimmer channel works as expected with no warnings, and triggers the built in fade-off duration. So really the Power channels can simply be commented out then eh? Or is there another hidden purpose that I’m just not quite realizing yet.

Nah just delete the channels and items you don’t need them and will not use the.

I was going to mention the only other bonus to having a dedicated on/off switch is for the sitemap to just quickly turn something on or off from ones phone if required, although I just found out that I can add the same item as both a Switch and Slider. Switch always goes from 0% to 100% when toggled on, and back to 0% when toggled off, and the Dimmer is available to drag if one wants a specific brightness, so I think I’ll remove those. :slight_smile: Thanks again!

Switch item=Light_UL_LivingRoomTVLEDDimmer
Slider item=Light_UL_LivingRoomTVLEDDimmer

Yeah maybe if you use the power topic it may rember the dimming level