My first Door Sensor

I have searched all over so I apologize if I have missed someplace where I can find the answer to this. I am new to openHAB and setting things up for the first time.

I have installed the Aeon Labs z-stick gen5 z-wave controller, configured for com 3 and it seems to be working. I have the Aeon labs recessed door sensor joined to the zwave network as node 2.

Using habadmin I have set the com3 and I can see the node 1 controller and node 2 sensor under devices. Using the Aeon IMA tool I can see Node 2 reporting Basic Set 0 or 255 as the door sensor is tripped. In the openhab command line I can see the node 2 is being ignored because there is no item bound for the event. I figure I don’t have any binding for this sensor.
(side note, in the etc/zwave folder I have a node1.xml file but not a node 2. This normal?)

At this point I have no idea what I am doing so I add this line to my .items file:
Contact Aeon_Door “Front Door” (FF_Office, Windows) {zwave=“2:command=SENSOR_BINARY,parameter=10”}

So in the demo site I see “Front Door” has been added to the first floor office but it doesn’t indicate if the door is open or closed. I am missing something here. (Still no node2.xml file in the etc/zwave folder.)

Any ideas on what I have missed?
Thank you for your time.

Changed my binding to be:
Contact Aeon_Door “Front Door [%s]” (FF_Office, Windows) {zwave=“2:command=sensor_binary,parameter=10,respond_to_basic=true”}

Now the demo interface does show if the door is open or closed, with a window graphic but one step at a time I suppose.

In the command prompt running openHAB I see this each time it opens:
[WARN ] [t.i.s.MapTransformationService] - Could not find a mapping for ‘-’ in the file ‘’

If I add “-=unsure” to that goes away but it seems like I should do something about this. Is this a message from the door sensor that I don’t have any case for?
Thanks so much.

Thanks for correcting my mistake. I changed to sensor_type=10, haven’t seen a difference yet but I’d rather be right!

I am also grateful for the tips on sensors. Amazon has the Fibaro and Philio at a higher price currently, but I will check them out for sure.

I will try to learn how rules work…now that I can tell the door is open, I’d like something to happen. Play a chime or something to start. Later once I know more attempt to make a true security system.
Thanks again!

Philio 4-in-1 Sensor. Best sensor I have.
Works like a charm. Way better than the new AeonLabs 6-in-1.

I think it may be as simple as this:

Contact Aeon_Door "Front Door [%s]"  <frontdoor> (FF_Office, Windows) {zwave ... 

The [%s] will put the contents of the state of the Item (in this case OPEN and CLOSED) to the right of the label text on the sitemap. The tells it to use the frontdoor icon set. When the door is open it will use frontdoor-open.png and when closed it will use frontdoor-closed.png.

If this doesn’t work, try using "respond_to_basic=true in place of or in addition to “parameter=10”.

That is about all I can think of right now. If this doesn’t work, look at the zwave binding wiki for how to bump up your zwave logging and post your logs here. Also be sure to tag this posting as zwave so the zwave developer will be sure to see it and hopefully be able to help.




I am having the sam problem: I have a pst02-A sensor. I can get the temperature, illuminance and battery life without a problem. But no motion and no contact. I have tried numerous things, with and without .map files. Same thing, no luck. Any pointer you can share? In the event.log the same thing happens. Nothing about motion and contact.

Number Door_Temperature “Temperature [%.1f C]” { zwave=“2:command=SENSOR_MULTILEVEL,sensor_type=1” }
Number Door_Illuminance “Illuminance [%.0f Lux]” (Door) { zwave=“2:command=SENSOR_MULTILEVEL,sensor_type=3” }
Contact Door_Motion “Motion [MAP(]” (Door) { zwave=“2:command=SENSOR_BINARY,sensor_type=12,respond_to_basic=true” }
Contact Door_Contact “Contact [MAP(]” (Door) { zwave=“2:command=SENSOR_BINARY,sensor_type=10,respond_to_basic=true” }
Number Door_Battery “Battery [%s %%]” (Door) { zwave=“2:command=BATTERY” }

The openhab.log has this info::
2015-10-02 01:33:17.465 [WARN ] [.z.internal.ZWaveActiveBinding] - NODE 2: No item bound for event, endpoint = 1, command class = BATTERY, value = 100, ignoring.
2015-10-02 01:33:17.466 [WARN ] [.z.internal.ZWaveActiveBinding] - NODE 2: No item bound for event, endpoint = 1, command class = ALARM, value = 0, ignoring.
2015-10-02 01:33:17.467 [WARN ] [.z.internal.ZWaveActiveBinding] - NODE 2: No item bound for event, endpoint = 1, command class = SENSOR_MULTILEVEL, value = 9, ignoring.
2015-10-02 01:33:17.468 [WARN ] [.z.internal.ZWaveActiveBinding] - NODE 2: No item bound for event, endpoint = 1, command class = SENSOR_MULTILEVEL, value = 76, ignoring.
2015-10-02 01:33:32.365 [WARN ] [.z.internal.ZWaveActiveBinding] - NODE 2: No item bound for event, endpoint = 1, command class = BATTERY, value = 100, ignoring.

ok, I got it. Figured out the config parameters were not set correctly. It works now.

I also do not receive updates from the PST02A :it shows temperature and lux correctly and the status of the door sensor but it doesn’t update the status of the door when I open or close it.

What is the parameter you have changed ?

many thanks

Hi @tomekz28, can you tell what you did to get the PST-02A working?


Federico, I will get back to you in a few days, providing you with config
settings. I do not have access to the system right now.

Best regards,

  • Tom


Ok, I figured it out. This is for PST-02A (aka Zipato Multisensor Quad PH-PSM02.EU)
In order to get motion and door reports bit 4 of parameter 7 needs to be set to 1 (“Using sensor binary report”)
By default parameter 7 has bit 2 set (“PIR super sensitivity mode”) so setting bit 4 is like this:

Bit:    7   6   5   4   3   2   1   0
        0   0   0   1   0   1   0   0  
Value 128  64  32  16   8   4   2   1
        0 + 0 + 0 + 16 + 0 + 4 + 0 + 0 = 20

However, I also wanted to receive an OFF event when the PIR was no longer detecting motion (can also be done programmatically in OpenHab and probably save battery life)
So I also set bit 1 in parameter 7, giving me a value of ‘22’

I also set the temperature scale to Celsius (bit 3 of parameter 5 set) so parameter 5 has a value of ‘8’)

I have increased the PIR sensitivity to 90 but I find it to miss on motion detection sometimes (anyone else with this problem?).
The thermometer seems to be awfully inaccurate, reporting over four degrees above the real temperature.

These are the items that work with the setup described above:

Number  Temp "Temp. [%.1f C]"        {zwave="12:0:command=SENSOR_MULTILEVEL,sensor_type=1"}
Number  Lux "Light [%.0f Lux]"    {zwave="12:0:command=SENSOR_MULTILEVEL,sensor_type=3"}
Contact Motion      "Motion [%s]" {zwave="12:0:command=SENSOR_BINARY,sensor_type=12,respond_to_basic=true"}
Contact Door     "Door state [%s]" {zwave="12:0:command=SENSOR_BINARY,sensor_type=10,respond_to_basic=true"}
Number  Battery    "Battery [%s %%]"             {zwave="12:0:command=BATTERY"}

These are the settings I used, in the attached screenshot.

In addition, I used the following settings in the *.items file:

Contact Multisensor_Tamper “Multisensor Tamper [%s]” (Door)
{ zwave=“6:command=SENSOR_BINARY,sensor_type=12,respond_to_basic=true” }

1 Like

Guys, is it possible to get the Lux value at a specific time point as this Philio posts sensor values when the window/door opens/closes only. Is there any kind of setting like e.g. “send sensor data when Lux > 50”


no idea? how to obtain sensor values when device is “sleeping”?


Normally a sensor is configured to send data periodically, or when something changes, so it depends on the sensor. You should consult the manual to see how to configure the parameters. You will likely need to set an association group with the controller so that the controller becomes the destination for the reports, but the reporting interval etc will be down to device configuration.

1 Like

Philio Reports brightness and temperature every time there is movement or door change.
Also you can enable cyclic reports. It is obviously shown in the screenshot from tomekz28.

1 Like

Thanks for your hints, guys, but it seems I can´t use this feature, as one “tick” equals 30 minutes.
I would like to get the illumination values at a certain time point to either enable lights in the floor or disable them.
Is there a way to get them manually or by a request?

Ok, just realized that the tick size of 30 can be amended. This might help, but I´m still interested in getting values manually or the sensor itself should send a signal if a certain value has been reached.

Not really. A battery device sleeps most of the time, so you can’t talk to it when it’s asleep. You could set the wakeup really small, and then this would work, but your battery would be dead very quickly.

1 Like