My.openhab not working after swapping raspberry pi

I had a working openhab on a RPi2. I had to swap to a different board but still a raspberry pi 2. So I just moved the sd card. Now it appears the my.openhab service is no longer working. I tried a couple times to delete the uuid and secret file under webapps/static, let it auto generate new ones and updated my online account with the new uuid and secret, but still no dice.

I’m running openhab 1.8. Like I said, my.openhab was working before. Is there something subtle I didn’t do?

Is there something that is suppose to show up in the logs or during start up that would be obvious it’s trying to connect to my.openhab? I have the correct addon in the addon folder, and it generated the secret and uuid file after I start it.

My next step would be to remove the add-on, uuid and secret, restart OH, then add it back. But with the announcement of the new myopenHAB perhaps now is a good time to switch to this new service.

It requires a different add-on jar and config is slightly different (no more .persist file) but it largely works the same.

Since my.openhab is going away in January it is a good time to switch. And perhaps in switching your problem will be solved.