[myopenhab - connection leaked] Strange log entry?

Same problem

same here, ive been getting it for a couple of days, Openhabian Openhab 2.4 on a Raspberry 3B+

There are some random issues with the cloud service, just watch


I think it’s important to note if you had to restart openhab or not to resolve the issue. I guess it can be somewhat normal to temporarily lose your internet connection, but we shouldn’t have to restart openhab, if so think we should create a bug.

1 Like

I’ve already restarted a couple of times, but I keep getting the same error messages in the log. While GoogleH sometimes works and sometimes does not

same problem here.
Did anyone solved the problem jet?

This happened to me last week, but it hasn’t returned since I restarted openHAB.

EDIT: I just got home and see that I had a bunch of these errors in my log about two hours ago…right about the time I was saying that it hadn’t reappeared. I feel like the guy hanging the “zero days without a workplace injury” sign.

I note from http://status.openhab.org that the the Cloud Service was down earlier, so maybe that was the issue.

every thing is said by this :kappa:

I checked the status right than, but there were no issues. Maybe just a delay.

btw it starts working again after restarting the openhab2.service but thats not really reliable :frowning:

There is an open bug on this. The cloud connector gets out of synch: see https://github.com/openhab/openhab-cloud/issues/134

You don’t have to restart openHAB completely, you could just restart the connector as noted in the bug:

As soon as you bundle:restart the openHAB Cloud Connector Bundle the Cloud again properly registers the instance as online

Yes, this is irritating because it stops Alexa and hits at inopportune times. I hope someone can help diagnose this.

1 Like

Thanks, that’s good to know.

Here’s a good post about restarting bundles with SSH, which could then be built into a rule with the Exec action. I might look into this, or I might just have OH reboot when it sees that the cloud connector is disconnected, since I already have that action set up.

[okhttp3.OkHttpClient                ] - A connection to https://myopenhab.org/ was leaked. Did you forget to close a response body?


[ERROR] [io.openhabcloud.internal.CloudClient] - Socket.IO error: {}

It started happening to me today. A restart didn’t fix it.

I have the same problem today.

I’m having the same issue just started early today.
Any suggestions?

me as well
here is example error

11:35:26.861 [ERROR] [.io.openhabcloud.internal.CloudClient] - Socket.IO error: {}
io.socket.engineio.client.EngineIOException: xhr poll error
	at io.socket.engineio.client.Transport.onError(Transport.java:71) [251:org.openhab.io.openhabcloud:2.4.0]
	at io.socket.engineio.client.transports.PollingXHR.access$100(PollingXHR.java:19) [251:org.openhab.io.openhabcloud:2.4.0]
	at io.socket.engineio.client.transports.PollingXHR$6$1.run(PollingXHR.java:124) [251:org.openhab.io.openhabcloud:2.4.0]
	at io.socket.thread.EventThread$2.run(EventThread.java:80) [251:org.openhab.io.openhabcloud:2.4.0]
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) [?:?]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) [?:?]
	at java.lang.Thread.run(Thread.java:748) [?:?]
Caused by: java.io.IOException: 502
	at io.socket.engineio.client.transports.PollingXHR$Request$1.run(PollingXHR.java:218) ~[?:?]
	... 1 more

about once a minute and here is a wierd warning

11:41:45.533 [WARN ] [okhttp3.OkHttpClient                 ] - A connection to https://myopenhab.org/ was leaked. Did you forget to close a response body?

Alexa actually still seems to be responding normally

IFTTT is not working, remote access is not working. It would be great it https://status.openhab.org/ would report the real status…

no joy, still getting errors

openhab> bundle:list | grep Cloud
251 │ Active   │  80 │ 2.4.0                  │ openHAB Cloud Connector Bundle
openhab> bundle:restart 251
12:06:21.301 [INFO ] [.io.openhabcloud.internal.CloudClient] - Shutting down openHAB Cloud service connection

@MDR5244 @m4rk @NDR008 and @GeKo
Dan just mentioned this in another thread
possible this is the problem

@Andrew_Rowe Thanks for the update!

1 Like

Thanks for the update!