Myopenhab & iOS notifications problem?

Tags: #<Tag:0x00007fc1fa8e4e00> #<Tag:0x00007fc1fa8e4d38> #<Tag:0x00007fc1fa8e4c48>

Hello all!

It seems that I have stopped receiving notifications on my iOS devices (iPhone & iPad). The last notification I received was yesterday morning.

I see no problem with my cloud connection (all notifications appear on myopenhab.org), plus I can still receive notifications on Android. Enabling DEBUG on the cloud connector didn’t produce any errors or warnings.

Even when I send custom notifications through myopenhab.org, I still get nothing on iOS (Android still works).

Is it something generic or just with me?

1 Like

I have the same issue. Unfortunatelly I don’t have an android device to test if it’s working at all.
But the symptoms are the same. Notifications are showing up in myopenhab.org. Custom notifications through myopenhab.org are not received by the iphone and no sign of any error in the openhab log.

I have 3 IOS devices (2 iphones + ipad) and no device is receiving any notiifcation. I tried restarting the IOS devices and restarting the server, but nothing helped.

Same issue here. Notifications triggered by rules are visible in MyOpenhab.org but are not pushed to my iphone.

I’m facing the same issue since some days. Not sure if it has started after the update to 2.5 unstable.

I’m still on 2.4 stable, so it’s not related to that :slight_smile:

my guess is that the Apple Push Notification Service certificate (commonly referred to as Apple Notification Service or APNS ) has expired.

This has to be renewed (as in make a new one in the developer account) every 365 days

1 Like

@digitaldan, can You have a look at this behavior?

I think the idea of @struvusmaximus is a good guess. Faced some issues like that at complete different environments with APNS. And I’ve also seen that the Notifications are available at the ios devices within the app at the tab “Notifications”. That means the communication between the openhab instance and myopenhab is working as expected and the issue has to be between myopenhab and Apple.

1 Like

I too am facing the same issue in iOS. I can see the notifications within the openHAB app, but no push notifications from the app to the phone.

Notifications also not coming through. Even used the test message functionality on the “Devices” tab and still nothing…

I just received two notifications to my devices (were automatically sent through OpenHab rules)
Manual notifications via myOpenHab Webpage are still not working.

Still nothing here… :frowning:

@digitaldan did you get a chance to look at it? :heart:

I also see notifications in myopenhab and the notifications section of the app but am not receiving any in both my wife’s and mine.

Hi all, sorry for missing this thread. Our certificate is good until September of 2019, but we did push out a new version of the IOS app this week which is likely the culprit . No changes were made to PNS, but I’m sure its some sort of certificate mismatch with the client build, its possible its using an old cert or something. I’m looking at it now.

2 Likes

Thanks Dan! If there is anything you need us to test out just let us know.

1 Like

I have a iPhone 6s and another iPhone 7 and both are working fine and have not had any issues as we use them often (many times per day) to get baby monitor notifications from openhab rules.
Updated app just now and it still works, only notice the sound is different when the app is open to closed.
Openhab 2.30 stable running on Odroid C2 with extra ram and heap size, rest should be pretty standard.
Have not done an apt get upgrade for a week on the server.

We are back online, people :slight_smile:
Just started receiving notifications again.

Thanks!

Mine doesn’t appear to be back online yet.

Tried to send a message from the website to my phone. Still not working.

Indeed, those don’t work (yet?). Rules seem to be ok, though (for me, at least).

Hello, same problem here.
I think it’s not OH 2.4 but iOS app update…
In myOpenHAB under “notifications” all messages are shown, but no message reaches my Phone

Jan