items not showing

Hi Kim, just to thank you for your advise on this one, with this info and just another change i saw on another post i made it to work!! thanks again. I will be posting my solution on the post i crated as advised for yourself!


When might the IFTTT integration be working again? I am trying to set up integration with my Samsung washer via IFTTT and OpenHAB Cloud but can’t get OpenHAB Cloud (or therefore IFTTT) to see my “Washing Finished” switch item.

Here is a workaround, although not easy to implement:

1 Like

Thanks for sharing! Although as you say, looks like a lot of work to set it all up


I have the same problem. I’d like to expose some virtual buttons to MyOpenCloud to use with IFTTT but I can’t find them.

I changed the state and there are correctly exposed but they don’t show up. Any hints?

That feature is disabled currently:

@DanE, you might have gotten this to work, but just in case, let me share what made it work for me. Once I set the Mode to “Notifications & Remote Access” in the openHAB Cloud connector, my items, that had the tagging, were discovered by Alexa. And yes, if the Mode is set back to “Notifications”, Alexa will loose access to the items.
To be honest, I do not feel that great to have all my items scanned by Alexa via the openHAB home skill…

1 Like

Wow, now I put so much time into this and didn’t get it to work. so at some point I gave up for the moment. This week when I checked everything again, I noticed that all my items are there. Now I can use all my items with alexa without doin any changes. very weird!

These both refer to making items files.

What about devices that are discovered within PaperUI?

They all need to be linked to Items.

Of course - but if I create the items in PaperUI and put the “Lighting” category on them, I don’t see them in Alexa. Is it required that I create the items in an items file rather than in PaperUI?

No, but for PaperUI created items you need to tag via REST Api:

Hi folks,
I tried many things since a fresh installed openhabian image, but are not able to get my items displayed under… all I see that my device is online, but no item show no matter how often i change status. Shows these exposed items that I have enabled via GUI and also others items via .item File to try both ways. But both have the same effect. :frowning:

Do I need a sitemap? or anything else like special ports?

  1. Why do you want to expose these Items? The only reason to do so is for IFTTT. If you are not using IFTTT, don’t expose Items.

  2. If you search the forum, you will see that exposing Item through is turned off. Too many people expose all their Items and don’t even use IFTTT and the server can’t keep up pending figuring out a fix.

I need this so Google Home sees them

No no no no no! No you don’t! This is why they had to turn it off.

From the docs right under Requirements:

Items DO NOT need to be exposed to and will not show up on, this is only needed for the IFTTT service!

Please go back and read the docs. Exposing Items through the Cloud Connector has never been required for Google Assistant nor Alexa integration. That is done through tags or metadata, as documented.


Hi rlkoshak, I have many clients who want to use openHAB and is an excellent market penetration to get adoption going in my country. I am however, saddened to see exposure of items for IFTTT still disabled by myopenhab cloud now for what seems to be over half a year now. Is openHAB foundation planning to re-enable this feature ever or not ?

Donate donate to openHAB foundation that is who runs the free cloud service.

Or setup your own cloud service and point your clients at it!

All I can recommend is to comment on the Issue in github.

I tried to get Google Home to oauth connect to myopenhab and got an error. Isn’t that the new recommended method to get items exposed to google home?