myopenHAB replaces my.openHAB!

Ok, so part of my problem was that apt thought that 2.0.0b4 was newer than the curreent snapshot (2.0.0~20161216033235). I’ve resolved that issue, and now have 2.0.0~20161216033235 installed. Even after rebooting entirely, I still don’t have the openHAB Cloud Connector showing up. Any other ideas?

Where are you looking? If in PaperUI it should be listed under Misc.

You should be able to find it using

feature:list | grep openhab-misc-openhabcloud

from the Karaf console.

If you do not my first thought is to wonder whether you actually have the latest snapshot. From what I’ve seen it is pretty binary. Either you have the latest snapshot and the add-on is there, or you don’t and its absent. Though I’ve little experience with the Online distro so there might be something going on there.

Alright, so even though apt tells me that I have the snapshot installed, karaf says I’m still on 2.0.0b4.

bundle:list | grep openHAB
161 | Active   |  90 | 2.0.0.b4              | openHAB Core

$ apt-cache policy openhab2-online 
  Installed: 2.0.0~20161216033235
  Candidate: 2.0.0~20161216033235
  Version table:
     2.0.0~20161216033235 0
        500  Packages
 *** 2.0.0~20161216033235 0
        100 /var/lib/dpkg/status

Any idea what’s going on?

Snapshot and Beta are two different apt repositories. Do you have both configured in apt? If so remove the beta sp the only repo is the snapshot repo. Apt might be confused by the fact you have two repos with openhab2-online.

I’m running 1.8, I’ve followed the steps and updated the UUID and secret and also activated the email. I can log onto myopenhab but the sitemap shows offline.
I don’t have any different settings in the openhab.cfg file,(everything is # out)
It looks like the binding doesn’t load. This is the only Error I see in the log but I’m not sure if it’s related.

Thanks Josh

2016-12-17 06:51:44.149 [ERROR] [o.o.i.o.internal.CloudClient  ] - Socket.IO error: not authorized

I had removed the beta repository entirely before installing from the snapshot repository. After attempting reinstalls a few more times, I’ve gotten the snapshot version to install and run (not sure what changed between attempts). I’m now having an issue where when I try to access port 8080 of my openHAB server, it’s stuck on the message:

Please stand by while UIs are being installed. This can take several minutes.

This is a separate issue from the topic of this thread, so I will continue trying to resolve these issues in another thread. Thanks, @rlkoshak, for your help.

You might link to this thread.

But I can tell you the answer right now.

When you first run and go to the web site you will be presented with a list of four “packages” to choose. If you press “skip” you will see that page but nothing ever gets installed. You need to manually configure everything through runtime.cfg and addons.cfg to get the UIs and your other addons installed.

So, I would assume b5 will support my Any ETA?

1 Like

I have tried this morning, Saturday, IFTTT.
Could it be that the switch to the new service has not happened yet?

Same here

hi, getting this in logs, no idea what it means :

2016-12-17 12:02:03.835 [WARN ] [io.openhabcloud.internal.CloudClient] - Jetty request 16817 failed: null

apart of that, git fetching the repos, the openhabcloud project does not popup under eclipse. When force-adding it, it is unhappy about

import org.eclipse.jetty.client.ContentExchange;

that don’t seem to exist. And indeed, for the 1st import the plugin dependency is C:…\openhab2-master\ws.metadata.plugins\org.eclipse.pde.core.bundle_pool\plugins\org.eclipse.jetty.client_9.2.12.v20150709.jar

==> this jar does not contain a class ContentExchange … really strange…

Correct. @digitaldan was working on the transfer yesterday, but apparently didn’t yet finish it successfully. I hope he will give an update on the status here soon!

Please provide details on the OH version that you are using.

Hi Kai,

using downloaded minutes ago. I had issues with my android device that first told me OH2 was offline, maybe it’s the reflecting log. now android seems to see the instance running.

off-topic : by the way, any reason why in this snapshot all (?) 1.9 bindings have a “1” in their name (in paperui) ? Breaking addons.cfg installs … examples :
binding-caldav-command1 - 1.9.0.SNAPSHOT
binding-myq1 - 1.9.0.SNAPSHOT
binding-denon1 - 1.9.0.SNAPSHOT

1 Like

I have successfully accessed my OH2 via LTE on my iPhone.
Great, that this is working.
But when looking at the device section of myopenhab, the iPhone is no registered.
Probably I will not be able to use notifications?

I very much apologize for the delay, I assumed the switchover would be less complicated but we had certification tests failing on both the old and new systems which was preventing us from switching as a new certification review is done anytime changes need to be made. The good news is all tests are passing on the new system as of now. The bad news is its the weekend and I don’t know if they will be able to review our account and implement the switch. As soon as we get certified I will post back in the forums with instruction on how to link to the new service.

IFTTT seems to be connecting to now, but my switch isn’t showing up. I know this is still a work in progress, I just want to make sure I’m doing it right. Is there anything I need to do besides add a comma separated list to the cfg file?

Here’s what I have:


I’ve also tried it without the quotes, and rebooted the system.


I am using no quote and I can see the items in myopenhab and also the events are transmitted correctly. But I am already on OH2. If you are also on OH2 then remove “openhabcloud:” in the .cfg file.

No, not yet - we still need some clarifications with the IFTTT guys, which won’t happen before Monday. I hope that we can have IFTTT active on myopenHAB by Tuesday. Will keep you posted here.