myopenHAB replaces my.openHAB!

Rule
sendNotification

Dont seam to work after af change to myopenhab.org

I have several sendbroadcastnotification commands in my rule. They do work with the new myopenhab.

Just made a quick check with sendnotification. Works for me!

Does it work when you send a message through myopenhab.org website (device section)?

no devices ?

Can I use the REST API with openhab Cloud and if yes what is the correct syntax.
I have tried

with http://myopenhab.org/CMD?myitemname=OFF
I am receiving: “Error 404 Not found”

https://myopenhab.org/CMD?myitemname=OFF
Receiving forbidden

I am using a tool which should add the login/password.
Do I have to use HTTP basic authentication?
If yes how does the syntax look taking into account that the login contains the “@” due to the email address is used as the login.

It’s not so easy to make a guess what may be your problem from a two-word-answer… :frowning:

Don’t you have any devices or don’t you know where to find the devices section?

It says no Devices, but i’m using the iPhone app with the new URL

Sorry to belabor this, but I am not seeing my exposed devices at all in IFTTT (you replied in my other thread). I’ve been banging my head on this and am curious if what I quoted above might mean that it is not a problem with my set up but rather a problem with myopenhab.org and IFTTT integration? Please let me know so that I can continue to work on figuring out what is wrong or just wait until things are resolved with IFTTT. I’m still running 1.3.8. Thanks

Can you access your sitemap with the iPhone app (local and/or remote)? Does the website myopenhab.org says that you are online?

Possibly. I don’t know how the tool you are using works. When I access it from Tasker I use basic auth. Also, note that that URL syntax will only work for OH 1.x. Setting an Item’s state using GET has never been officially supported and no longer exists in OH 2.0.

According to the quote that is part of your post, IFTTT will not be available until next Tuesday at the earliest.

That’s what I thought but it seemed like some folks are at least seeing some of their items in IFTTT whereas I cannot see them at all. That’s the reason I posed the question.

Yes using the iphone Sitemap, and its not local.

It says online On the www

Sorry, but then I have no other ideas…

I want to be able to see the item phone1 that is a Switch item. The the file /etc/openhab/configurations/openhab.cfg i have added openhabcloud:expose=phone1
Why does this not work?
I am running openhab 1.8.3.
Both notification and remote access is working.

Anyone that has a clu why its not working for me?

I will later use this for IFTTT but i understand that is not working right now.

I’m having a similar issue, I can see my OpenHAB is online, I’m able to remotely see my sitemap. However no items are showing on myopenhab page. I’ve tried with quotes and without in the config file.

Perhaps a few more details on the config, examples even…

I understand IFTTT failed and it’s coming at some point, but at this point I can’t see it would work for me as I have no items.

I’m having the same issue. I’ve tried changing the config file, changing items state, etc. Not sure what I’m missing!

Similar issue here. My config is:

openhabcloud:expose=Lock_Front_Door,Outdoor_BackDeckLEDs,Upstairs_Fire,Scene_LivingAreas,Locks

But Scene_LivingAreas and Locks do not get status sent to myopenhab.org. Scene_LivingAreas is a Number item, Locks is a group (I am not certain if groups should work).

I have the same problem as above running Openhab 1.8.3. I got an email on the 15th saying the IFTTT would stop working on the 16th so I’ve changed over and it’s broke. Don’t you think that a) You should’ve given a little more time and b) You should’ve tested this more thoroughly?

I’m using openHAB 2 encase that is different but I don’t think the config file is used for the new one. It SEEMS that it now it’s moved from my.openhab.org to the new myopenhab.org it needs a new extension and setup which uses the db files not the config files.
I have got my items back into myopenhab.org by removing the old my.openhab extention (using paperUI which is what I originally installed it with) and then I deleted the my.openhab config file and folder before then installed the new “openHAB Cloud Connector” extension (again in paperUI).
Next I restarted openHAB (just to be sure) and went to:

  • paperUI
  • Configuration
  • Services
  • IO
  • And clicked the “CONFIGURE” button on the “openHAB Cloud” tile thing
  • Then you can select the items you want to push with the tick boxes on the option “Items to expose to apps such as IFTTT” OR (due to some kinda of bug I am seeing with loads of random letters being added as items!) click the expert button and enter them in the “expose” field.

Save it and wait for myopenhab to pick them up. :slight_smile:

items not showing up in the new myopenhab. OH Version 1.8, suitable Java Version. System comes online, can connect through the iOS App und via Webservice, but the item list stays empty. Got 3 items to expose, already configured, restarted OH serveral times, no luck