MyQ/Chamberlain/Liftmaster Openhab connection problem

I’m an extreme OpenHAB newbie. Brand new OpenHAB install, fully patched on a Raspberry Pi 3:
Linux openhab 4.19.75-v7+ #1270 SMP Tue Sep 24 18:45:11 BST 2019

So far, I just told it to do the demo, got Openhab to notice some TPlink plugs and BigAss fan, and using the Paperclip menu they’re controlled nicely. Once I get the stuff I have integrated, I’ll start learning more about how to configure the interfaces to make more sense.

I had a pair of Liftmaster garage door openers installed with the full bells and whistles. 850s I think. That is completely configured up with the IOS app and works nicely on my home wireless (doors are static IPs).

I downloaded the Chamberlain MyQ binding into OpenHab (using OpenHab’s built in add-on function), and the binding appears to stubbornly refuse to detect the door openers. My guess is that the binding contacts “a” MyQ API (shoudl be same as what IOS uses) via the Internet and controls via that API. I’ve checked/rechecked the userid/password stuff, and looked for extraneous spaces (as someone else reported), and it just refuses. I try to fix/poke the binding for searching again, but I don’t even know if it notices my efforts.

I’m not using cloud (except insofar as a particular binding might be using it to talk to a specific device that won’t let me speak to it directly. I intend on getting away from internet connectivity required for any of this.]

This is where I get stumped:

  1. MyQ comes in Chamberlain, Liftmaster and one or two other flavors (brandings). Liftmaster is owned by Chamberlain. Could the doors be on a liftmaster server, and the binding talks to Chamberlain’s? Would it matter? I don’t see ANY indication that the Internet endpoint can be configured. Did anyone else find their (particularly) liftmaster functions stopped working recently?

  2. Chamberlain appears to have some page where it says all the various MyQ variants are being merged into the Chamberlain branding. I don’t know whether this is “old” or “new”, and whether it actually means anything in this context.

  3. I have no way of knowing when the binding tries to probe for the doors. Be perfectly happy to supply IPs and whatnot, but the binding doesn’t seem to work that way.

1 Like

The Chamberlain MyQ binding is a v1 binding. There are no Things, not features in PaperUI, and no automatic detection of anything with v1 bindings. You must configure it using the myq.cfg file and create and configure Items in .items files as documented in the binding’s docs.

That is unless you are using an unofficial MyQ binding that hasn’t been merged into the baseline yet. But if that were the case you wouldn’t have installed it through PaperUI.

The MyQ binding requires accessing their devices through their cloud service. OH doesn’t talk to the opener directly, just as your iOS app doesn’t talk to the opener directly. Everything goes through their cloud servers. The only way to get away from that is to install an alternative way to trigger the opener.

If you are using a MyQ App to control your openers, than you are probably OK. If you are using a Liftmaster app to control the openers, it’s possible and likely that Liftmaster had their own services and their own API before Chamberlain bought them. So the MyQ binding would not likely work.

It depends on whether they change or discontinue the API that the binding uses. If they do that it will break the openHAB binding.

Again, it doesn’t work that way. Read the docs to manually configure the binding and for how to manually create the Items.

And be aware that the binding does not talk to the openers directly. They go through the MyQ cloud API to access your openers. So all you need is your account information configured.

I appreciate that the binding does not talk to the doors directly, I’m trying to figure out when the binding is probing the API. I do see some connection failures to whatever the myq tries to talk to, but the timing of those do not make any sense relative what I’m doing. The myq.cfg file is configured with the userid/password used by the IOS apps.

What you’re saying is that I have to figure out all this item stuff. The documentation is singularly unenlightening.

I’d recommend you try the 2.5 binding that Scooter has released. Chamberlain has changed the API several times so perhaps that may be contributing to the 1.x binding issues you are having (I never used that version so I can’t say for certain).

Drop the jar in your addons folder and you should be able to setup a connection with your MyQ credentials right in Paper UI. Once you’ve setup the bridge, your opener should be discovered automatically.

I’ve tried the 2.5 binding you’re referring to (after removing the 1.x Binding that openhab offered me):

ls -l /usr/share/openhab2/*/*jar
-rw-r–r-- 1 openhabian openhabian 86319 Jan 15 20:29 /usr/share/openhab2/addons/org.openhab.binding.chamberlainmyq-2.5.0-SNAPSHOT.jar

I’ve put my credentials into this file:

ls -l /etc/openhab2/services/myq.cfg
-rw-rw-r-- 1 openhab openhab 506 Jan 15 20:31 /etc/openhab2/services/myq.cfg


It has been checked and rejected. It’s fine.

The ONLY unusual thing in my setup is that the userid (my email address) has a “+” sign in it, something like:


This is a legal address. Look up “tagged addresses”. However, I know somethings hiccup with it. But it does work with the IOS chamberlain app without trouble.

After all this: no sign whatsoever anything happened. No log entries. Nuttin.

Maybe I should see about changing my userid with Chamberlain. Sigh.

Sorry if I’m misunderstanding you, but the 2.5 binding doesn’t utilize the .cfg file. It’s configured through Paper UI. Add a myQ gateway thing and input your myQ credentials. Then try to add another device and your opener should be discoverable in Paper UI.

There seems no evidence that openhab has noticed the 2.5 Chamberlain jar file in the addons directory. The configuration/binding section in Paper doesn’t show myq at all even after a reboot.

Go to karaf and run bundle:list. What does it show for the myQ binding?

Reading through the README for the 2.5.x chamberlainmyq binding may help:

It’s possible the 1.x version of the binding is still installed. You can check for that as @ae_0017 noted by logging on to the karaf console and entering:

openhab> bundle:list -s -r | grep -i myq
288 │ Active │  80 │      │ org.openhab.binding.chamberlainmyq                       │ [osgi.identity; type="osgi.bundle"; version:Version=""; osgi.identity="org.openhab.binding.chamberlainmyq"]

If you find two active myq bindings, remove the 1.x version:

bundle:uninstall ###

Replace ### with the number in the leftmost column of the output from bundle:list.

1 Like

Thanks for the detailed instructions. There is no myq binding in the list - neither the 1.x nor the 2.5. Have I installed the Myq v2 .jar in the right place? Is there something wrong with the name perhaps?

I’m a very ancient (45+ years) Perl/C/UNIX hacker. Know nothing about Java, and I’d prefer to stay an Ok Boomer. Sorry :wink:

Did you happen to try and use “wget” to get the file? It’s hosted on Google Drive and I’ve found that can be unreliable (especially from mobile devices). I’d recommend downloading the file to a laptop/desktop and then using an SFTP transfer tool to drop it in the addons directly. Your path looks right for where you placed it.

Yes. v1 bindings don’t work in PaperUI. See

For all the documentation about how to create Items in .items files.

But since there is a 2.5 version of the binding, the above probably isn’t relevant any more. I only leave it here for future readers.

As a matter of fact, the v1 ChamberlainMyQ binding stopped working some time ago when Chamberlain (in their infinite wisdom) changed the API. AFAIK, the latest 2.5.x jar is currently the only working version, at least it works for me.

From one boomer to another, :+1: :ok_hand:

I don’t know if the JAR has been updated since I downloaded it, but I don’t think it has changed. I run a docker instance for my OH system, so ignore the paths, but the sha256sum could be used to check the download:

[scott@casabot ~]$ ls -l ~openhab/oh/openhab_addons/
total 304
-rw-rw-r-- 1 openhab openhab 259720 Nov  2 13:16 org.openhab.binding.amazonechocontrol_2.5.0.jar
-rw-rw-r-- 1 openhab openhab  46414 Dec 27 08:08 org.openhab.binding.chamberlainmyq-2.5.0-SNAPSHOT.jar
[scott@casabot ~]$ sha256sum ~openhab/oh/openhab_addons/org.openhab.binding.chamberlainmyq-2.5.0-SNAPSHOT.jar 
a44c22da60ff015f0b8336f99a1e147014678476b7e5653d686b5a2f067fbe1d  /home/openhab/oh/openhab_addons/org.openhab.binding.chamberlainmyq-2.5.0-SNAPSHOT.jar

Oh, bless google and their stupid “I know better than anyone else how it’s supposed to work” attitude. It downloaded a freaking HTML file.

Now it has the right file. Let’s see how that works.

Thanks for the checksum scottk

Thanks for the help so far. I finally managed to get the 2.5 binding recognized by openhab. The Paper UI config->binding->Chamberlain MyQ tells me that it supports garage doors, the web gateways and the lamp modules. But it doesn’t allow me to set anything (like the login/password). I haven’t needed the gateway to control it from IOS. Do I need it for openhab? Seems annoying to have to pay for yet another device. Have a recommendation?

Choose to manually add the “myQ Gateway” option. It will allow you to set your username and password that you use for the myQ app. Once you use your credentials and they are verified, your garage doors will be discoverable.

How do I “add Myq gateway manually”? The Paper addon/binding directory let’s me reinstall the 1.4x version (which I just got rid of) and the Configuration->Bindings->ChamberlainMyQ entry has no actions I can do at all.

Paper UI —> Configuration —> Things —> + —> Chamberlain myQ Binding —> Add Manually —> myQ Gateway

Nothing appears like this?