Neato-Binding (Vorwerk VR200) not working anymore: Error connection nucleo host

Tags: #<Tag:0x00007efeddc78610> #<Tag:0x00007efeddc78548>

Hello,

like described in Connecting Vorwerk Kobold VR200 to openHAB2
I connected my VR200 to openhab and this worked fine until I updated to openhab 2.2.0 stable.
Now it don’t work anymore and every 10min I get the following errors in openhab.log:

2018-04-17 20:44:42.202 [ERROR] [b.binding.neato.handler.NeatoHandler] - Error connection nucleo host: 
java.io.FileNotFoundException: https://nucleo.ksecosys.com/vendors/vorwerk/robots/4DSDEHZC-88C255974F26/messages
	at sun.net.www.protocol.http.HttpURLConnection.getInputStream0(HttpURLConnection.java:1890) [?:?]
	at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1492) [?:?]
	at sun.net.www.protocol.https.HttpsURLConnectionImpl.getInputStream(HttpsURLConnectionImpl.java:263) [?:?]
	at org.openhab.binding.neato.internal.VendorVorwerk.executeRequest(VendorVorwerk.java:76) [180:org.openhab.binding.neato:2.0.0.201705201246]
	at org.openhab.binding.neato.internal.NeatoRobot.callNeatoWS(NeatoRobot.java:105) [180:org.openhab.binding.neato:2.0.0.201705201246]
	at org.openhab.binding.neato.internal.NeatoRobot.sendGetState(NeatoRobot.java:173) [180:org.openhab.binding.neato:2.0.0.201705201246]
	at org.openhab.binding.neato.handler.NeatoHandler.refreshStateAndUpdate(NeatoHandler.java:139) [180:org.openhab.binding.neato:2.0.0.201705201246]
	at org.openhab.binding.neato.handler.NeatoHandler$1.run(NeatoHandler.java:159) [180:org.openhab.binding.neato:2.0.0.201705201246]
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) [?:?]
	at java.util.concurrent.FutureTask.runAndReset(FutureTask.java:308) [?:?]
	at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$301(ScheduledThreadPoolExecutor.java:180) [?:?]
	at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:294) [?:?]
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) [?:?]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) [?:?]
	at java.lang.Thread.run(Thread.java:748) [?:?]

In PaperUI I can see the thing with status offline. It looks like this:

in karaf-console I can see that the binding is active:
grafik

I switched to openHAB 2.3.0~20180406103010-1 (Build #1251) but that didn’t help.

Like I mentioned above, with openhab 2.1 it worked fine.

Can somebody help me? @fatman42285 @Giga522 @scurb ?

Have you already tried to start up all over again by deleting the binding, creating a new thing and login to your account?
have you installed: feature:install openhab-runtime-compat1x?
My openhab 2.2 release version is still working.

Yes I think so.
After deleting the thing PaperUi discovered it again. I renamed the jar file to jar_OFF and after a reboot it didn’t appear in karaf bundle:list anymore. Then I renamed it back to jar. Also did the install command.
With the vorwerk-app I can log in and can control the vr200.
But I will try once again tomorrow.
Thanks

Today tried to start up all over again, but openhab stops as soon as I want to work with PaperUI.
Other bindings do not work properly anymore.
There seems to be a general problem with my openhab installation.
Must do a more accurate troubleshooting.
Thanks so far.