Need help with eBus to get working - beginner

I need to help with eBus to get working. My HW is Vaillant VRC700 and eBus adapter v2 from Fhem.
Under OH3 3.3.0 I installed a eBUS Bridge :

and set serial port where adapter is connected:

rest of setup remain unchanged.
Then I connected wires from adapter to a heat unit ebus. After this I found in inbox three new detected devices and this I added as things:

under each thing is a lot of channels:

so I tried create one item (water temperature), but value is still NULL.
So looks like that somethink is wrong. Sorry for my stupid questions, but I tried to find some tutorial for complete beginners but no luck :frowning: . I will be grateful for any help to get it working.

Hi Alex. So apparently your eBus adapter is seeing nodes in the eBus network, which is good :slight_smile: However the binding does not recognise the vrc700 while it is one of the most documented machines…

Are you familiar with the openhab console? Please give the output from the command “ebus devices” to be able to compare it with the apparent built-in vrc700 configs.

thank you for your answer.
I’m really not much experienced, so spending a lot of time with searching and improving skills.
Openhab console you mean a command via putty ?
One more question : is ebusd necessary to get ebus working ?
once more thank you

but under putty not working


Please tell us more about your setup. You have a V2 ebus adapter from fhem. Which version? I also have a V2 as the raspi version (GPIO). So which version do you have connected to which device (openhab)? Is it realy connected via USB?

I used schematics from fhem v2.0 and created own board. Components are same as on schematics v2.0.
here is a picture :

and signals comes via CP2102 USB/RS232


Strange, when i compare | count the number of diods and resistance with the pictures from here it will not match yours.
So my suggestion is to install ebusd and see if the adaptor really works.

It can be. There can be a difference on Vin of 5V stabiliser. In v2.0 was one resistor removed but is still there a diode.

in the next versions they added a external DC/DC and also removed a diode.

Wichtige Hinweise zu Version 2.0

  • Der Kondensator C1 entfällt!
  • Der Widerstand R10 wird mit einer Drahtbrücke oder 1 Ohm Widerstand bestückt.

Ok than install ebusd and let’s see if you can read / write some values outside openhab

sure? :

before uninstall bridge and binding ?

Just install ebusd and let us see what we can do with your adapter. I don’t know what adapter @Chiuaua79 is using.

ok, please what is correct install instruction ?
apt -get install ebusd . ?

Also have a look on this



Download deb and install it manualy.

with or without mqtt support ?

You want to use usb!

must check which version is correct for dietpi v8.10


then is started ebusd with systemctl start ebusd
and checked log: