NEEO Remote Binding/Transport


(Tim Roberts) #302

@DiLucca
Tracked down the issue you are having. Please note you may want to back out to the prior version - the one you tried definitely has some major issues with it still - I’m still testing but hope to have a release this week still…


(DiLucca) #303

@tmrobert8 Thanks


(Tim Roberts) #304

I just posted the latest version at https://github.com/openhab/openhab2-addons/pull/3191

  1. Implemented new LIST type
  2. Updated to new NEEO SDK naming standards
  3. Updated to new notification API for 51.1+ firmware
  4. Added firmware to brain status page
  5. Fixed numerous bugs on things page
  6. Fixed search to match tokensearch exactly (improving the search results from openHAB)

New LIST type - this allows you to specify a list of values, their associated labels and optionally an icon. On the remote, the user can then select from that list and the associated value is sent to the underlying item. Example: let’s say I have a Russound music system and I have a channel that let’s me set the music source. I can create a list that associates value 1 with “AM/FM”, value 2 with “Pandora”, etc. Then on the remote, I can simply press the “Source” button - be presented a list showing “AM/FM”, “Pandora”, etc - selecting “Pandora” would send the value 2 to the underlying source channel.

NEEO internal naming standards are being enforced. STRONGLY recommend you drop and readd your existing devices from the NEEO Brain. Basically the prior versions of the transport did not follow (nor did I even know about!) the naming standards for the SDK, devices and sensors - this version now follows those standards. Prior devices will continue to work - however that will not be the case in future firmwares. Your best action would be to drop the current devices and readd them to the brain. See the readme for further details.

Please let me know if you have any issues with this version…

Tim


(DiLucca) #305

@tmrobert8

I have a couple of questions regarding the NEEO Types:

  1. I’ve set a ‘THERMOSTAT’ with 3 ‘Text Labels’, but when try to select the Thermostat on the remote it does not show the controls. Instead, it sends me back to the main menu right after activating the recipe. Am I missing something about the Thermostat functionality?

  2. What is the recommended NEEO Type for standalone items like Shades or Security? Given it’s not possible to ‘show’ ACCESSOIRE devices.


(Tim Roberts) #306
  1. THERMOSTATE (CLIMA under the scenes actually) is one of those undocumented types that you’ll need to experiment with to figure out what it requires. More than likely you need to add a power sensor and the power on/off buttons (seems like a requirement for anything with state management)
  2. That’s the tough one since there is no generic type. Either choose one that’s close or (what I do) choose the “TV” one - just need to make sure to map the power stuff from 1. Doesn’t look great but works. Been meaning to ask for a generic one - I’ll hit github issues and ask for one now…

(DiLucca) #307

Thanks @tmrobert8

I’ll probably wait for a generic device type. Their notes about Thermostat and Clima are not too encouraging:

Using these device types will result in drivers that have parts that won’t work as expected or even cause serious issues. Be aware that these issues will NOT be supported.


(DiLucca) #308

@tmrobert8

I think there is an issue with the Dimmer/Slider. It seems that the transport is sending a formatted string (with ‘%’) instead of just a numeral value.

[org.openhab.io.neeo.internal.NeeoApi] - Sending Notification to brain (NEEO-b4c9f3e2): {“type”:“6423029119788777472:FF_Master_WallSconces_Level-none”,“data”:“63 %”}


(Tim Roberts) #309

@DiLucca
In your setup on the transport->things page - make sure you don’t have a format defined. If you do, remove it - save it (you won’t need to drop/readd). Probably should make the format invalid for sliders…


(Tim Roberts) #310

Also note they have bugs on the remote (not the app) where switch and sliders are inconsistently updated from notification with SDK added devices. I’ve already got a bug note in for that one with them


(DiLucca) #311

@tmrobert8 (I’m only using the app to debug)

I’ve tried removing the ‘%’ from the ‘unit’ field but the transport still sends the formatted string with %. As far as removing Min & Max, I can’t save the configuration without those values.


(Tim Roberts) #312

@DiLucca
Sorry I was VERY unclear. In the transport->things - change the slider to a text label, remote the format then switch back a slider and save the item. Should fix the item for now - I will be fixing this in code later…


(DiLucca) #313

@tmrobert8 Presto! that works! Thx


(Rashmi Patel) #314

I have added the global cache binding so I can get my IP2SL and IP2IR working. After I added my map file (which contains Serial and IR codes for each device) and items file into the appropriate
directories, and go to need transport, I cannot seem to get any of my label for each function. For example:

I have global cache IP2IR which has my comcast box IR codes but when I click on the +(drop down) to assign button, the name shows up as Xfinity x1 family room instead of the code description in map file. Don’t know if that makes sense. I will post pictures to show you what I mean.

The same thing happens when I try to do it with global cache IP2SL.

On a side note, in my items file do I only need to include something like this:

String XFINITYFR “Xfinity Box in Family Room” { channel=“globalcache:itachIR:000C1E038B75:ir-m1#c1” }

Also I noticed that I cannot program a few buttons on neeo for my xfinity x1g-p box, such as guide, page up/down, last. is there a way to add these as buttons on neeo transport?

Thanks


(DiLucca) #315

@tmrobert8

I’m unable to find my virtual devices on the NEEO Search. Do I have any way to debug this issue?

UPDATE: I was able to finally add the device by playing with the Search (a lot). But I was not able to get the new LIST type to work. All I get when I press the list on the app is a ‘Try again’ blue button.

item:
Number GF_Dining_Shades “Dining Shades” (GF_Dining)

Sitemap:
Selection item=GF_Dining_Shades mappings=[0=“UP”, 1=“STOP”, 2=“DOWN”]

Transport Value/Label:
0 / UP
1 / STOP
2 / DOWN


(Rashmi Patel) #316

@tmrobert8

I have got the global cache IP2SL working and tested it out in basicUI. How do I use neeo transport to have my remote turn on/off tv. I did assign it as a button and neeo label (mapped to power on/off on remote) but when I try to test recipe, nothing works.

Also do I need to put anything in Format/Command/Range field for either IP2SL or IP2IR devices?

Thanks


(Tim Roberts) #317

@DiLucca

Search: the easiest way to search is simply “openhab” - that will list all your items in openhab exposed by the transport.

List: very weird - so what you are saying is that the list is appearing correctly on the remote but when you select an item (say the “STOP”) - you are getting a “Try Again” on the app? If you would enable debug (karaf console: “log:set DEBUG org.openhab.io.neeo” and see when you press a button whether there is a message saying “doPost” and anything happening after that.


(Tim Roberts) #318

@pintu1228
You need to assign the device you created as a “ACCESSORIE” (or ACCESSORY) then map the item to a button. Nothing needs to be done in the command field (you are simply sending an action to the underlying item and the underlying item takes care of the command details. Then add the item via the app and add the shortcut/recipe step to the button.

If it doesn’t work, turn on debug (from the karaf console “log:set DEBUG org.openhab.io.neeo”) and see if anything is happening when you send the command.


(DiLucca) #319

@tmrobert8

Search: I’ve tried the “openhab” approach with no luck. The search does find the transport sporadically, It may be a timeout issue.

List: The list itself does not show on the remote app. When I press the button to call the list a blank page slides up populated with only a blue button labeled ‘Try again’. Pressing it does not result on any activity on the DEBUG log.


(Rashmi Patel) #320

@tmrobert8

So i tried what you suggested but IP2SL doesnt work, it works fine when I test it through BasicUI from openhab.

I have attached picture of the neeo transport page and then when I go to remote to add devices, I add the openhab IP2SL, xfinity XG1-p cable box and denon 3400h receiver binding (as seen on neeo transport).

When I add the xfinity box, it asks to create a ‘cable salad’ and ask I need a TV, projector or audio system in order to get it working but I use IP2SL in order to control my TV.

I also tried to debug but can’t open karaf console, keeps saying connection refused. I have tried all ways to ssh into it but doesn’t let me connect.

Also is it possible to added light control (via ISY binding) in the remote to have a page for lighting or is this a part of transport??


Any help would be great,