Neo coolcam z-wave devices

I can confirm this…they simply haven’t changed the manual. Both versions have the same manual, but a different bevahiour.

Anyone with this device: please update the database accordingly.

I do have this device, but I don’t have the old device to compare. But mostly my lack of knowledge is blocking me. If someone is willing to take me by the hand I can execute the necessary steps.

That’s how to update the database, but how do I gather the data I need? Where do get which config parameter is what? How do I test this locally? I am really missing the basics. And the URL is helping but not that much.

From your manual.

The problem is that the product is delivered with the old incorrect manual. Is there an alternative way? Except trial and error?

So how do you know the parameters have changed?

That’s what mbronk seemed to have found out in the post:

I don’t think we should put speculations into the database … we need a recent manual.

Found this, looks we need to wait for the engineer to come back to work :grinning::sunglasses:

I do not know if it helps, but I ordered the following device from amazon a few days ago and also received it directly from china (NAS-WR01ZE).

Habmin says:

And here the manual:

currently I feel overwhelmed to edit the zwave database directly, sorry …

and here is a xml file:

network_ee7b3ad4__node_7.xml (10.9 KB)

I can’t find a node7.xml file?

  • Platform information:
    • Hardware: raspberry pi 3 b
    • OS: Raspbian GNU/Linux 9 (stretch)
    • Java Runtime Environment: Java™ SE Runtime Environment (build 1.8.0_181-b13)
    • openHAB version: 2.4.0 (Build) stable

openhab> bundle:list -s | grep zwave
275 x Active x 80 x x org.openhab.binding.zwave

This looks indeed like an updated manual! To be honest I also don’t feel confident to edit the XML.

I will try to find time for it tomorrow.

Thank you. I have seen, the scan is not the best, if you need a better I can scan the manual even better …

Fully agree! In fact, I have contacted both the vendor ( and the seller from whom I have bought my devices - to get an updated manual. The seller just replied moments ago, providing me with a PDF manual which seems to match-exactly what @miwok has already posted here (which is newer to what I had in the box w/ the device BTW).

Thing is… this new manual is still not a match to the devices I have wrt. their config pameters. And I am not ruling out anything, incl. having buggy FW on those devs, hence my previous Q - if anyone else is observing this exact weird behavior.

As far as wild speculation goes - aside the entries in the table I have marked with question marks, I am pretty confident that my devices are configurable via the parameters indicated by me (and not what the manual says).

  • Does it extrapolate to other devices with the same FW - no idea.
  • Would I trust myself with this info and update the DB? no :slight_smile:
  • Did it work on my 4 devices - yes!
    So at the moment I can only really say this: I can confirm 4 sightings where the current DB content is not a match to a device, no more, no less.

Hope someone would eventually be able to get something concrete fom the vendor (once the-engineer-who-knows is back at the office :wink: ).

EDIT: Here’s a PDF’ed version of the manual that I got. (over 1MB in size, so does not fit as an attachment + I don’t have any immediate location to post it at - the link is valid for 14d; if useful, hope someone can put it somewhere more ‘permanent’)

I have updated the device with the provided manual and edited the database accordingly.
As I don’t have this device I am not able to change parameters outside the scope of the manual, sorry.

According to the manual this parameter cannot be stored on the device, it is executed via factory reset.
I’ve added the meter_reset channel which can be linked to a Switch itemtype to reset the values.

Hi, the device works for me now. With the “including” there were problems at the beginning. The device always appeared as an “unkown device”. It was finally recognized with a new node number, everything works so well. Here is the node.xml: network_ee7b3ad4__node_9.xml (13.9 KB). I’m on the latest z-wave snapshot binding.

Thank you very much!

I still cannot get the temperature readings for the PIR sensor. Does anyone have any tips to get this right?

also on latest Z wave binding.

I tested it with my device, and I see the new clear kwh channel. However I am still not able to change the configuration values. It seems that there is a real difference between the manual and the real device.