Neo coolcam z-wave devices

zwave
Tags: #<Tag:0x00007fe0517f7ec8>

(Leo Verkaik) #287

Thanks guys,

You pushed me to the latest snapshot (I was runneing v 2.3), that indeed was the key to success !

Had to delete all z-wave devices and have PaperUI find them again.

Now the devices are all discovered :grinning::+1:

kind regards,

Leo


(Sjoerd Tromp) #288

Hi Guys,

I also aquired some of the new Neo Coolcam wall plugs with the new device ID. (type/ID 0200:1027). With the latest z-wave binding all the basic functionality works okay. I have however 2 issues:

  • KWH usage sometimes reports a large negative number and some hours later it switches back:
    PWR_SW_TVLR_KWH changed from -21474834.58 to -21474834.57
2019-02-11 22:24:55.621 [DEBUG] [nal.protocol.ZWaveTransactionManager] - lastTransaction null
2019-02-11 22:24:55.621 [DEBUG] [nal.protocol.ZWaveTransactionManager] - NODE 3: Application Command Request (ALIVE:DYNAMIC_VALUES)
2019-02-11 22:24:55.621 [DEBUG] [ng.zwave.internal.protocol.ZWaveNode] - NODE 3: Incoming command class COMMAND_CLASS_METER, endpoint 0
2019-02-11 22:24:55.621 [DEBUG] [ng.zwave.internal.protocol.ZWaveNode] - NODE 3: SECURITY NOT required on COMMAND_CLASS_METER
2019-02-11 22:24:55.622 [DEBUG] [tocol.commandclass.ZWaveCommandClass] - NODE 3: Received COMMAND_CLASS_METER V3 METER_REPORT
2019-02-11 22:24:55.622 [DEBUG] [.commandclass.ZWaveMeterCommandClass] - NODE 3: Meter: Type=Electric(1), Scale=kWh(0), Value=-21474766.37
2019-02-11 22:24:55.622 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 3: Got an event from Z-Wave network: ZWaveMeterValueEvent
2019-02-11 22:24:55.622 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 3: Got a value event from Z-Wave network, endpoint = 0, command class = COMMAND_CLASS_METER, value = -21474766.37
2019-02-11 22:24:55.623 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 3: Updating channel state zwave:device:cda3604b:node3:meter_kwh to -21474766.37 [DecimalType]
2019-02-11 22:24:55.623 [DEBUG] [nal.protocol.ZWaveTransactionManager] - NODE 3: Commands processed 1.
2019-02-11 22:24:55.623 [DEBUG] [nal.protocol.ZWaveTransactionManager] - NODE 3: Checking command org.openhab.binding.zwave.internal.protocol.ZWaveCommandClassPayload@344a62a6.
2019-02-11 22:24:55.623 [DEBUG] [nal.protocol.ZWaveTransactionManager] - NODE 3: Command verified org.openhab.binding.zwave.internal.protocol.ZWaveCommandClassPayload@344a62a6.
2019-02-11 22:24:55.623 [DEBUG] [nal.protocol.ZWaveTransactionManager] - NODE 3: notifyTransactionResponse TID:184 DONE
2019-02-11 22:24:55.624 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 3: Got an event from Z-Wave network: ZWaveTransactionCompletedEvent

Looks a bit like an singed/unsigned issue.

Did anyone experience this, and have any clue on how to fix it?

The other issue I encountered that the switches do not seem to react to any configuration parameter I send. Tried to switch of the lights, tried to disable the on/off button. All is ignored.

Did anyone encounter/experience this?


(G ) #289

Same issue here, but no clue how to fix this unfortunately.


(SiHui) #290

Just tested this by disabling and re-enabling the led indicator, works without any problems:


Make sure you are using HABmin to change any configuration parameters.

Also there seem to be no problem with the kwh:

2019-02-12 13:12:36.176 [vent.ItemStateChangedEvent] - Neo_PowPlug_2_kwh changed from 0.67 to 0.68
2019-02-12 22:49:00.414 [vent.ItemStateChangedEvent] - Neo_PowPlug_2_kwh changed from 0.68 to 0.69
2019-02-13 07:39:41.870 [vent.ItemStateChangedEvent] - Neo_PowPlug_2_kwh changed from 0.69 to 0.7
2019-02-13 16:20:55.350 [vent.ItemStateChangedEvent] - Neo_PowPlug_2_kwh changed from 0.7 to 0.71

(Sjoerd Tromp) #291

Hi Sihui,

Are you sure your devices have the same device/type id? 0200:1027? I’ve tried changing the config with paperUI and habmin. Both to no success. All my other devices (Qubino and aeotec) do respond correctly to config changes.


(Oliver) #292

Hi,

same here…No Config will be accepted and sometimes large negative values…

Best,
Olli


(SiHui) #293

No, I did not check the device type and id, just the model WR01ZE …

grafik

Probably that device has a new firmware version so we need to add it as a separate device.
Please post your xml and check the command classes, association groups and configuration parameters if those are different to the existing database entry.
https://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list/devicesummary/397


(Sjoerd Tromp) #294

Hi Sihui,

With the XML, you mean the node XML in /var/lib/openhab2/zwave/.xml?

I attached mine, and tried to compare them, but for me it’s not really clear what to check.

network_ca82ea18__node_7.xml (14.0 KB)


(SiHui) #295

Yes, thx. Will take a deeper look at the weekend. First impression: there are a lot of changes, the new device supports security, the old one not. Also firmware version has changed.
In the meantime could you please compare the configuration parameters and associations groups from your manual to the database?


(SiHui) #296

I’m not sure what to suggest here. Your device has additional command classes:

COMMAND_CLASS_SECURITY
COMMAND_CLASS_SECURITY_2
COMMAND_CLASS_TRANSPORT_SERVICE
COMMAND_CLASS_MULTI_CHANNEL_ASSOCIATION
COMMAND_CLASS_SUPERVISION

and a firmware version of 2.32

<applicationVersion>2.32</applicationVersion>

where the existing device (at least the one I own) does have a firmware version 3.94:

grafik

Are you sure your device model name is NAS-WR01ZE?

@chris, do we probably need a database entry with firmware version min=2.32 and firmware version max=2.32?


(Chris Jackson) #297

Are the main command classes, parameters and associations the same? Eg all the ones that have channels associated with them. The “management” classes that you list above don’t really matter tooo much I think - the binding will sort this out by itself.

On the other hand, it would not hurt to use a separate database entry either, it might not be required though…


(SiHui) #298

I’ve found differences:

device in question existing device
COMMAND_CLASS_ASSOCIATION_GRP_INFO COMMAND_CLASS_ASSOCIATION
association groups: 2 association groups: 3
E_A,E_KWh,E_V,E_W E_A,E_KWh,E_V,W_Cubic_Meters,E_W,E_KVAh

Both have 10 configuration parameters.

If you need to take a look at the xml file, here are both:

0003_1087.xml (16.3 KB)
network_ca82ea18__node_7.xml (14.0 KB)


(Oliver) #299

For me it seems to be all same command classes,parameters and associations (if I could trust the manuals and what i!! see in openHAB).Only Parameter 11(ClearAccumulatedEnery) is missing. Have a 3.94 and a 2.32 wall plug here. All Channels are working with the newer 2.32 and the current snapshot, but as SjoerdT mentioned…no configuration change is accepted.

Best,
Oli


(Chris Jackson) #300

The new device also supports the COMMAND_CLASS_ASSOCIATION…

It’s possible that the database doesn’t contain all the classes - without an XML from a device, it’s hard to be sure.

However, if the number of groups is different, then that’s an issue.

What device do you have? Can you provide the XML so we can check?


(Oliver) #301

Of course…
V2.32.xml (14.0 KB)
V3.94.xml (13.1 KB)


(SiHui) #302

Quite a lot of changes :sunglasses:


(Oliver) #303

Sorry, but I’m new to this z-wave stuff. But now I know where to look :wink:

Best,
Olli


(Marco Eulenfeld) #304

Hej,

any more help here needed to get those devices added? I just got 3 of those myself (not yet recocnized by OpenHab2) and would like to use them and have some time.

Tack


(SiHui) #305

Sorry, lost track :grinning:
Device added:
https://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list/devicesummary/1014
Could you please upload a recent manual and add config parameter 11? Thx.


(SiHui) #306

BTW, you need a recent zwave snapshot, 0200:1027 won’t work on 2.4 stable zwave binding.