Nest Binding for OH2

Tags: #<Tag:0x00007fc1fd773758>

It is probably just me but I can’t seem to figure out how to setup the Nest Binding. Logging into the Nest portal and setting up as a developer seems to no longer exist. I just get this on the Nest site.

“Thank you for your interest in the Works with Nest program. We’re currently restructuring our developer program and are no longer accepting new developers to the program or performing client integration reviews for existing developers until the new program is implemented. Stay tuned for further details and announcements.”

Clicking the link in the Binding information takes me to an OAuth Clients Details page which asks a bunch of information I am not sure of.

Would someone be able to confirm for me if it is still possible to setup the Nest binding?

Thank you,
Jason…

Hi,

Ignore it…it threw me for a few days and I got into a bit of a hump about not being able to add my nest to the binding.

If you just log into the developer site with the login details you used when you set up the next originally, (and what you have on the official nest app), it will let you in and you can carry on with the set up.

Thanks for the prompt reply. I’m still missing something. When I go to the developer site https://developers.nest.com, there is no logon. Just a get started


If I hit Get Started, I get a Sign up. No logon option.

If I try sign up, I am taken to a page that indicates, “Thank you for your interest in the Works with Nest program. We’re currently restructuring our developer program and are no longer accepting new developers…” And the only option is to create new OAuth code.


I have no idea what to enter for creating the OAuth code.


I choose a device for permissions, and this popup comes up. Again not sure what to enter.

I am not that novice when it comes to computers. I am an IT Professional. But this has me baffled. Any guidance is greatly appreciated.

J…

You’re almost there…I’m in IT too and it totally flummoxed me as well…Nest certainly don’t make anything particularly easy to follow.

So, here’s what I put in

Enter OAuth client name - OpenHabBinding (I just made a name something memorable)
Description - Control my Nest
Categories - Home Automation
Users - 1
Support URL - www.bob.com (made it up)
Let Default oAuth Redirect URI empty

Followed the rest of the example in the Nest documentation, ie

* Leave both "OAuth Redirect URI" fields empty to enable PIN-based authorization.
* Grant all the permissions you intend to use. When in doubt, enable the permission because the binding needs to be reauthorized when permissions change at a later time.

After creating the Product, your browser shows the Product Overview page. This page contains the **Product ID** and **Product Secret** authorization parameters that are used by the binding. Take note of both parameters or keep this page open in a browser tab. Now copy and paste the "Authorization URL" in a new browser tab. Accept the permissions and you will be presented the **Pincode** authorization parameter that is also used by the binding.

That should do it…

Hope that helps, good luck

Everything up to selecting permissions works. When I check the box for any of the item types, I get:

What am I supposed to enter in this? Won’t let me move on until I fill this in.

Thank you very much.
J…

I can’t exactly remember what I put but I don’t think it was ‘important’. I think I just put something relevant in there so I knew what it was…ie for my thermostat I guess I would have just put something like, ‘Nest Thermostat changes in OpenHab’ or something similar.

Try it, if it’s wrong you can always just delete the oAuth and start again…

Wow. It really is not difficult. Nest just makes it look complicated. I got everything all setup thanks to you. Thank you very much.

Hope someone else who has this issue finds this thread as it is not difficult at all and Nest is not looking for anything particular to be filled out.

Thanks for all the help.
J…

No problems, glad you got it sorted.

Are there any new instruction available? I’m totally going in circles here.

Thanks
Jeff

Probably best not to use Nest. Support’s going away in the near future.

To add on to @namraccr’s post, works with nest had an EoL announcement earlier this year; while it is still operational Google doesn’t allow us to access the API interface to enable the communications to your equipment.

I believe the kill switch was slated for Aug 31st? I stopped paying attention after I swapped out my Nest and put in a Zwave thermostat.