Netatmo API issue for thermostat on OH2

Hi all,
lately I’m having issues with the Netatmo Thermostat binding and noticed that muy log file is full of the following:

2021-02-04 17:58:02.221 [ERROR] [nternal.handler.NetatmoDeviceHandler] - Unable to connect Netatmo API : java.lang.IllegalStateException: Expected an int but was BOOLEAN at line 1 column 162 path $.body.devices[0].plug_connected_boiler

I’ve updated to OH2 2.5.12-1 hoping that it might have been fixed in the latest release, but unfortunately not. Have you noticed the same? Is anyone working on fixing it?


Yes, this is a known change in Netatmo API. Solved in the v3 of the binding (not currently merged)

1 Like

Thanks! I’m currently in the process of migrating from scratch to OH3 and that might take a while… In the meanwhile it would be great to have those changes merged also for OH2 :slight_smile:

It will not be possible because of all the changes I made in the current PR. Unless, somebody else takes cares of the v2 of the binding.

Does it, btw already implement the Energy API?

Yes, everything is implemented, and should be working.

1 Like

Hi, how can i use the energy binding in OH 3.
The current version of the binding does not find any valves.


Hello, I’m on the version 3.0.1-2, but I have the same error. When will it be available the fix? Thanks!

What “same error” ? The absence of Valve handing in the binding ? We’ve started to work on it here

No, this one:

2021-02-04 17:58:02.221 [ERROR] [nternal.handler.NetatmoDeviceHandler] - Unable to connect Netatmo API : java.lang.IllegalStateException: Expected an int but was BOOLEAN at line 1 column 162 path $.body.devices[0].plug_connected_boiler

This one will not be corrected by me in v2.x, unless someone volonteers to do it. Changes introduced in the current PR in v3 are so important, they can not easily be backported.

Hi @glhopital, I have that error too, but on OH3 (release 3.0.1) and not only on OH2.x. After the change of the Netatmo APIs, have the changes been introduced also to the Netatmo Binding for OH3? If not, any ETA?

Changes have been made on the currently under review PR, available here, it is not currently merged - so unavailable for normal binding download. You can test the new binding by yourself, feed-back and issues welcome. We’re many currently using it - and everything seems fine. Valves may btw be added soon.


Awesome, thanks!

Can somebody just fix that “boiler”-channel issue on OH2 binding? OH3 don’t really work for me at all…Thx in advc

Hi @glhopital, has the revamped Netatmo binding for OH3 been merged with the latest OH3.1 release or is it still WIP and I need to download the .jar separately? Any sort of ETA to merge it? Thanks!

No it has not been merged in OH3.1, despite our efforts we were not ready enough while we have made big progresses and added many new modules. You can download latest jar and available in the first comment of the PR. If guess we’ll now be targetting OH3.2. No rush.

1 Like

Great, that’s what I wanted to hear. I know, it’s an entire revamp, not just a quick enhancement. I haven’t deployed the jar earlier assuming the merge with OH3.1, in this case I’ll do and when the merge happens, I’ll just remove it :wink:

Hi @glhopital, I didn’t have a chance to test earlier the binding until now. In case, which is the procedure to deploy the .jar on OH3?

  • uninstall the openhab shipped netatmo jar
  • stopping all OH services ?
  • copy your .jar to /usr/share/openhab/addons
  • restarting all OH services?

Does the binding show up as “Started” when running “feature:list | grep netatmo” in the Openhab Console? My first attempt failed and there wasn’t any netatmo binding and all my Netatmo related Things were unavailable. What’s wrong in the procedure?


In order to get started :

remove previous binding installation
comment or remove previously defined things
drop the jar in addons folder
go in add things, and configure the netatmo binding to access your account
launch discovery of things