NETATMO Openhab 2.3

I’am not able to configure Netatmo Thermostat with Openhab 2.3 …
Any Idea?

Here the same issue:

Hi Pierluigi,

Did you check this?

Tks… but I don’t undesrtand. My case is new installation of OH2 and I don’t have an existing .thing file …

OK, maybe my answer was too fast. Do you use PaperUI? Did you activate the readThermostat Switch in the API Thing configuration.

Yes, I am using PaperUI … I added Netatmo binding, I added Netatmo API and it is online. I added Main Indoor Station and it is online but doesn’t work (no data). I added the thermostat and i have a UNINITIALIZED - HANDLER_INITIALIZING_ERROR.
When I used previous version of OH2 the automatic discovery worked … now it doesn’t go …

I’m sorry for that.

@glhopital Do you have any thoughts on this?

Hi, I have exactly the same issue that @njogu with both, the lastest (2.3.0) and the 2.2.0 version. The firmware version from my Netatmo Rele is 160 and Netatmo Thermostate is 64. The Rele is ONLINE but no data and the Thermostate is UNINITIALIZED.

I tried with a fresh installation in Ubuntu 17-04 & 17-10 with the same result. I tried too with the Synology OpenHAB2 app in my NAS and I get the same.

Any ideas?

Hi , I pushed a PR that may give answers to this problem. I suppose you’re a new user of the Thermostat and probably no monthly Bilan has been issued. This was not tested in the code.

@glhopital Thank you for helping.

This in not the situation … before worked with previous version … :frowning:

No idea? Not any help?

Did you try v2.3 with the PRs merged this week-end ?

No … what I’have to install? Which version of Openhab2 and Addons?

See here: - Snapshot Release

The same problem …
2018-01-09 21:43:31.799 [ERROR] [nternal.DiscoveryServiceRegistryImpl] - Cannot trigger scan for thing types ‘[netatmo:NHC, netatmo:NATherm1, netatmo:NAMain, netatmo:NACamera, netatmo:NAWelcomeHome, netatmo:NAPlug, netatmo:NAWelcomePerson, netatmo:NAModule3, netatmo:NAModule4, netatmo:NAModule1, netatmo:NAModule2]’ on ‘NetatmoModuleDiscoveryService’!
retrofit.RetrofitError: OAuthProblemException{error=‘invalid_request’, description=‘null’, uri=‘null’, state=‘null’, scope=‘null’, redirectUri=‘null’, responseStatus=0, parameters={}}
at retrofit.RetrofitError.networkError( ~[206:org.openhab.binding.netatmo:]
at retrofit.RestAdapter$RestHandler.invokeRequest( [206:org.openhab.binding.netatmo:]
at retrofit.RestAdapter$RestHandler.invoke( [206:org.openhab.binding.netatmo:]

I installed: sudo apt-get install openhab2=2.3.0~20180109005608-1

No ideas?

There is ongoing work on it. See