Network binding error resolving host name

Hello all,

I have updated OH 2.1 to 2.2 and I having problems with Network binding. In my setup, I’m using several MQTT sensor nodes what request their IP by DHCP so, their names are included in my local DNS server. When the host name can be resolved, OH starts correctly but if it can’t OH starts with a errors. Following you can view the log entries:

2018-01-09 10:59:33.811 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'default.rules'
2018-01-09 10:59:35.046 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'micasa.sitemap'
2018-01-09 10:59:35.506 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'MiCasa.things'
2018-01-09 10:59:35.993 [ERROR] [] - Configuration for hostname is faulty Sonoffxxxd: unknown error
	at Method) ~[?:?]
	at$2.lookupAllHostAddr( [?:?]
	at [?:?]
	at [?:?]
	at [?:?]
	at [?:?]
	at [?:?]
	at []
	at []
	at []
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:?]
	at sun.reflect.NativeMethodAccessorImpl.invoke( ~[?:?]
	at sun.reflect.DelegatingMethodAccessorImpl.invoke( ~[?:?]
	at java.lang.reflect.Method.invoke( ~[?:?]
	at org.eclipse.smarthome.core.internal.common.AbstractInvocationHandler.invokeDirect( [109:org.eclipse.smarthome.core:0.10.0.b1]
	at [109:org.eclipse.smarthome.core:0.10.0.b1]
	at [?:?]
	at java.util.concurrent.ThreadPoolExecutor.runWorker( [?:?]
	at java.util.concurrent.ThreadPoolExecutor$ [?:?]
	at [?:?]
2018-01-09 10:59:37.551 [INFO ] [b.core.service.AbstractActiveService] - HTTP Refresh Service has been started

Also I’m using text file to configure Things as following:


In 2.1 version I didn’t experiment this problem and if a host name could not be resolved, Network binding considered that it was offline.

Could anyone help me?
Thanks in advance,

Have you tried to use the FQN i.e.

Yes, I have tried it but with same result…

Change hostname=“Sonoffxxxd” to hostname=“IP-ADRESS”

With a hard coded IP address, it works but, I’m using DHCP just to avoid to use hard coded IP addresses…

You need internal DNS (at least a DNS forwarding service and names resolved through hosts file). I don’t know if sonos is special in this point, I don’t own a sonos system. All stuff at openHAB in my home LAN works with “fake” FQDN through DNS forwarder in my ipfire router.

I have an internal DNS server on my router and the names are resolved without problems by all hosts in the LAN. BTW, I’m not using any Sonos device. May be you are confused about the host name of in the above log: it is just a name…

Yes, misread Sonoff as Sonos … :flushed: