New items not found by Alexa

Hi, I’ve been using Openhab for months with no issue, I also configured and Alexa skill and it’s been working nice since now. A few months ago I could discover many devices from openhab and I could confgure them with no problem.

My openhab version is 3.1.0.

The problem is that last items I configure with Alexa metadata are not discovered in Alexa App. I’m pretty sure that I configure all parameters required, in fact, the Item is well served by myopenhab as you can see. Navigating to
this is the result:

  "link": "",
  "state": "18.0",
  "metadata": {
    "alexa": {
      "value": "TargetTemperature"
  "editable": true,
  "type": "Number",
  "name": "Heater_TargetTemperature",
  "label": "Heater Temperature",
  "category": "temperature",
  "tags": [
  "groupNames": [

I tried to uninstall skill in Alexa app ant re-install it with no luck.

Any advice?

Have you gone over the troubleshooting guide? You probably have a bad item configured.

Yes I did. In fact I tried to configure some items exactly as the ones that worked a few months ago and nothing, Alexa does not discover them. Server is ok and no relevant log lines related to it.

What type of item configuration may cause Alexa not to discover items?

It is usually complex group endpoints. The discovery process can silently fail preventing any items for being discovered. It usually seems like only new devices aren’t getting added since old ones are already present on your Alexa account.

If you delete all your existing items, are any devices getting discovered? Also, did you configure your Heater group for Alexa?

Thaks a lot Jeremy. Item is part of “Heater” parent group, “Heater” has also a “Living Room” Parent group, But I tried to remove parent group of the item and Alexa did not discover it.

What do you mean by “configure your Heater group for Alexa”. By now it has no Alexa metadata, should it?

My Openhab is Debian box running on a KVM VM, I’ll try to clone this VM to do some testing removing items and see if any of them causes the trouble.

I think there should be some kind of debug info related to Alexa discover provess, or maybe a Self Test to see if any item causes other items not to be discovered by Alexa.

Thanks again for your help,

I meant if you configured your Heater item as group endpoint. Thermostat devices are usually configured as such, per the documentation example, since they have multiple functionalities. Although it is fine to have a single endpoint if you only want to control the setpoint of your heater.

Regarding my question, I only care about Alexa metadata configuration at the group level. Group affiliation in OH has no effect if no metadata is set.

I think there should be some kind of debug info related to Alexa discover provess, or maybe a Self Test to see if any item causes other items not to be discovered by Alexa.

I wish this would be available but all the logic is done at the skill level currently. As far of testing, since you said it was working before, can you delete all your existing devices on the Alexa side and trigger a discovery? Do your previously discovered devices show up again?

If yes, then there is some kind of configuration issue with the latest items you are trying to configure for Alexa. I would rollback these changes and slowly stagger them to determine which item could potential cause the issue.

If no, I would scrape all your existing Alexa configuration and start with a simple light switch test. From there, stagger changes as I mentioned above.

I tried to remove a workinf item in Alexa App and try to discover new devices and it’s not been found, so problem is not with new ítems. I’ll try to remove last added ítems and see of some of them is causing the trouble.

I’ve seen that I’m not the only one experiencing this type of problems: