New Jeelink Openhab2 Binding

Have you flashed the sketch onto the stick? If yes, are you sure you configured the stick thing with the correct usb device? You logs show that nothing at all can be read from the stick, not even the line identifying the sketch.

no Volker, i didn’t flash anything? i’d tought it was not necessary with the new version of the binding, my bad.
so i have to follow the procedure above to flash the sketch?

Thx

Yes.

hi oliver,
did you solve your problem with the jeelink, I have the same problem?
(ras pi 3 + OH 2.2 jeelink v3 and 5 sensors). All 5 sensors go OFFLINE at the same time.
Thank you for your help!

There is an extra thread for the problem where sensors stop reporting temperatures: Jeelink stops receiving readings

Can you check if the led on the stick is still blinking when the sensors are offline?

hi volker,

thanks for pointing out the other thread. I’ll look at the next problem if the LEDs are still flashing. My workaround so far was my rpi every 2 days to restart. Unfortunately, the problem sometimes occurs a few hours after a reboot.

Thanks Volker, since i falshed the stick everything work like a charm.

hello volker,
it happened again.

2018-04-29 20:59:03.722 [hingStatusInfoChangedEvent] - 'jeelink:lacrosse:48' changed from ONLINE to OFFLINE
2018-04-29 20:59:07.754 [hingStatusInfoChangedEvent] - 'jeelink:lacrosse:18' changed from ONLINE to OFFLINE
2018-04-29 20:59:07.758 [hingStatusInfoChangedEvent] - 'jeelink:lacrosse:28' changed from ONLINE to OFFLINE
2018-04-29 20:59:08.719 [hingStatusInfoChangedEvent] - 'jeelink:lacrosse:10' changed from ONLINE to OFFLINE
2018-04-29 20:59:13.722 [hingStatusInfoChangedEvent] - 'jeelink:lacrosse:51' changed from ONLINE to OFFLINE

jeelink%20Fehler

I checked the LED, it did not blink anymore.
Then I entered the following command via the Karaf console:

bundle:restart org.openhab.binding.jeelink

And it worked again. Here are the log entries, maybe that will help you.

2018-04-30 20:45:07.719 [hingStatusInfoChangedEvent] - 'jeelink:lacrosse:28' changed from OFFLINE to UNINITIALIZED
2018-04-30 20:45:07.726 [hingStatusInfoChangedEvent] - 'jeelink:lacrosse:28' changed from UNINITIALIZED to UNINITIALIZED (HANDLER_MISSING_ERROR)
2018-04-30 20:45:07.730 [hingStatusInfoChangedEvent] - 'jeelink:lacrosse:48' changed from OFFLINE to UNINITIALIZED
2018-04-30 20:45:07.738 [hingStatusInfoChangedEvent] - 'jeelink:lacrosse:48' changed from UNINITIALIZED to UNINITIALIZED (HANDLER_MISSING_ERROR)
2018-04-30 20:45:07.740 [hingStatusInfoChangedEvent] - 'jeelink:lacrosse:18' changed from OFFLINE to UNINITIALIZED
2018-04-30 20:45:07.748 [hingStatusInfoChangedEvent] - 'jeelink:lacrosse:18' changed from UNINITIALIZED to UNINITIALIZED (HANDLER_MISSING_ERROR)
2018-04-30 20:45:07.751 [hingStatusInfoChangedEvent] - 'jeelink:lacrosse:51' changed from OFFLINE to UNINITIALIZED
2018-04-30 20:45:07.756 [hingStatusInfoChangedEvent] - 'jeelink:lacrosse:51' changed from UNINITIALIZED to UNINITIALIZED (HANDLER_MISSING_ERROR)
2018-04-30 20:45:07.759 [hingStatusInfoChangedEvent] - 'jeelink:lacrosse:10' changed from OFFLINE to UNINITIALIZED
2018-04-30 20:45:07.763 [hingStatusInfoChangedEvent] - 'jeelink:jeelinkUsb:84e3ec08' changed from ONLINE to UNINITIALIZED
2018-04-30 20:45:07.765 [hingStatusInfoChangedEvent] - 'jeelink:lacrosse:10' changed from UNINITIALIZED to UNINITIALIZED (HANDLER_MISSING_ERROR)
2018-04-30 20:45:07.798 [hingStatusInfoChangedEvent] - 'jeelink:jeelinkUsb:84e3ec08' changed from UNINITIALIZED to UNINITIALIZED (HANDLER_MISSING_ERROR)
2018-04-30 20:45:07.993 [hingStatusInfoChangedEvent] - 'jeelink:jeelinkUsb:84e3ec08' changed from UNINITIALIZED (HANDLER_MISSING_ERROR) to INITIALIZING
2018-04-30 20:45:08.005 [hingStatusInfoChangedEvent] - 'jeelink:jeelinkUsb:84e3ec08' changed from INITIALIZING to ONLINE
2018-04-30 20:45:08.058 [hingStatusInfoChangedEvent] - 'jeelink:lacrosse:18' changed from UNINITIALIZED (HANDLER_MISSING_ERROR) to INITIALIZING
2018-04-30 20:45:08.068 [hingStatusInfoChangedEvent] - 'jeelink:lacrosse:48' changed from UNINITIALIZED (HANDLER_MISSING_ERROR) to INITIALIZING
2018-04-30 20:45:08.071 [hingStatusInfoChangedEvent] - 'jeelink:lacrosse:51' changed from UNINITIALIZED (HANDLER_MISSING_ERROR) to INITIALIZING
2018-04-30 20:45:08.072 [hingStatusInfoChangedEvent] - 'jeelink:lacrosse:10' changed from UNINITIALIZED (HANDLER_MISSING_ERROR) to INITIALIZING
2018-04-30 20:45:08.074 [hingStatusInfoChangedEvent] - 'jeelink:lacrosse:28' changed from UNINITIALIZED (HANDLER_MISSING_ERROR) to INITIALIZING
2018-04-30 20:45:08.076 [hingStatusInfoChangedEvent] - 'jeelink:lacrosse:10' changed from INITIALIZING to UNKNOWN
2018-04-30 20:45:08.079 [hingStatusInfoChangedEvent] - 'jeelink:lacrosse:28' changed from INITIALIZING to UNKNOWN
2018-04-30 20:45:08.081 [hingStatusInfoChangedEvent] - 'jeelink:lacrosse:48' changed from INITIALIZING to UNKNOWN
2018-04-30 20:45:08.084 [hingStatusInfoChangedEvent] - 'jeelink:lacrosse:18' changed from INITIALIZING to UNKNOWN
2018-04-30 20:45:08.086 [hingStatusInfoChangedEvent] - 'jeelink:lacrosse:51' changed from INITIALIZING to UNKNOWN
2018-04-30 20:45:10.854 [hingStatusInfoChangedEvent] - 'jeelink:lacrosse:48' changed from UNKNOWN to ONLINE
2018-04-30 20:45:11.508 [hingStatusInfoChangedEvent] - 'jeelink:lacrosse:18' changed from UNKNOWN to ONLINE
2018-04-30 20:45:11.757 [hingStatusInfoChangedEvent] - 'jeelink:lacrosse:10' changed from UNKNOWN to ONLINE
2018-04-30 20:45:12.481 [hingStatusInfoChangedEvent] - 'jeelink:lacrosse:51' changed from UNKNOWN to ONLINE
2018-04-30 20:45:14.626 [hingStatusInfoChangedEvent] - 'jeelink:lacrosse:28' changed from UNKNOWN to ONLINE

That is what I hoped. If the LED is not blinking any longer, the binding can not read readings. It looks like the stick has hung up (or lost connection to the sensors). If restarting the bundle makes everything work again, I can add some code to the binding that automatically reconnects in case no readings have been read for a while. As I am quite busy at the moment, this may take some time.

The problem exists also under FHEM, see the following posts in the FHEM forum:

https://forum.fhem.de/index.php/topic,29640.0.html
https://forum.fhem.de/index.php?topic=78579.0

The last post also mentions the following option for FHEM:

Attr myJeeLink timeout 60,15

format: <timeout, checkInterval> Checks every ‘checkInterval’ seconds if the last data reception is longer than ‘timout’ seconds ago.
If this is the case, a reset is done for the IO-Device.

Maybe you can implement that in OH?

Or, can that be a problem of the sketch as well?
I flashed the following sketch:

https://svn.fhem.de/trac/browser/trunk/fhem/contrib/arduino/36_LaCrosse-LaCrosseITPlusReader.zip

I have posted a link to a test version in the other thread.

Changes have just been merged for 2.4 that add units to the channels. A side-effect of this is that channels ‘currentWatt’ and ‘maxWatt’ have been renamed to ‘currentPower’ and ‘maxPower’. So in case you update your 2.4 snapshot version make sure to re-discover all ec3k and pc301 things.

Continuing the discussion from New Jeelink Openhab2 Binding:

Hey there!
I’ve updated to openhab 2.3.0 and jeelink addon 2.3.0 and tried to configure the pca301 like the wiki says with

Number:Power SocketWattage {channel="jeelink:pca301:1-160-236:currentPower"}

but it does’nt work :frowning:
So i tried
“currentWatt” instead of “currentPower”
now it works

Is there a fault in the wiki?

And the consumptionTotal puts out (example) 430,0 kWh instead of 0,4 kWh.
Is there a fix and can we use the reset function of pca301 to reset the statistics?

Thanks!

edit: if you are on 2.3.0, then use the old stuff
from 2.4.0 you have the new stuff

during an upgrade from 2.3 to 2.4, apt shows me:

Warning:  Jeelink Binding: The 'currentWatt' and 'maxWatt' channels have been replaced with 'currentPower' and 'maxPower' channels

here? https://www.openhab.org/addons/bindings/jeelink/ (that’s for 2.4)

To see the docs for 2.3, use: https://www.openhab.org/v2.3/addons/bindings/jeelink/ (there is a version menu to the top right)

Is there a new version again?
Did the 2.3 update 5 days ago…

no, not yet
the 2.4 is in testing (but includes many goodies :slight_smile:)
see more here: [OH 2.4.0 M6] Testing Results

Dear all
Sorry if this question was already answered, I was not following this topic for a while.

After the latest openhab update I get the following error during startup.

2018-12-01 14:06:04.951 [ERROR] [org.openhab.binding.jeelink         ] - FrameworkEvent ERROR - org.openhab.binding.jeelink
org.osgi.framework.BundleException: Could not resolve module: org.openhab.binding.jeelink
Another singleton bundle selected: osgi.identity; type="osgi.bundle"; version:Version="2.3.0.201803081647"; osgi.identity="org.openhab.binding.jeelink"; singleton:="true"

Could somebody help me to fix this.

Thank you in advance.

BR
Matze

Sounds like you have two versions of the plugin installed.

Yes, I know, it looks like this.
But I do not know where this comes from?
I have no jar file any more and just installed the binding via PaperUI.
Any hint what could be wrong?
Should I uninstall the binding? How to do that?

Thank you in advance.

I got it.
I found that there are two JeeLink Bindings installed, via the karaf console.
I unistalled one and everything is ok now.

BR
Matthias