New LightwaveRF Link Binding Issue

Hello All,

I am new here and first off would just like to say a huge thanks for OpenHAB, been using for a couple of weeks now and really enjoying it.

I recently purchased a few LightwaveRF products, mostly dimmers and a LightwaveRF Link, this is the newer model that does not include a display, is much smaller and has only a single link button.

There appears to be some issues with this product and the available binding file v1.7.1, I have found that I can modify the settings so that I can either monitor the LightwaveRF traffic, ie I see the data in the logs and the OpenHAB GUI updates the status of the switches when manually operated, or I can configure it so that I can control the products but get no feedback updated when a switch / dimmer is activated outside of the OpenHAB GUI.

The believe the following logged string shows the LightwaveRF Link firmware version :-

2015-11-11 16:00:34.022 [DEBUG] [l.internal.LightwaveRFReceiver:182 ]- Message received: 100,?V=“N2.91Y”

To change the behavior from control to monitor or back again all I have to do is swap over the receive and send ports in the openhab.cfg file, I did try setting both to the same port and got a binding error, I have also tried changing the IP from broadcast to a static but that made no difference so have left it on broadcast.

Is anyone else experiencing similar issues?



I have the same Lightwaverf link as you. Firstly how did you register your mac with the link? I am not finding any info about how to register my PC with the link.

I am receiving errors in Openhab along the lines of cannot send message xyz.

Anyone been able to successfully use this new LWRF link with openhab?


Ahh yes I missed the binding part, that too didn’t work with the new Link, I am running on CentOS so was able to send a binding request from the machine running OpenHAB using netcat, once received I could then click the binding button on the link box.

Netcat has been quite useful, here are some of the commands I was using, you will need to replace with your link ip address :-

echo -ne “666,!Fp" | nc -u 9760
echo -ne "666,!F
p” | nc -u 9760
echo -ne “666,!Fp" | nc -u 9760
echo -ne "001,!F
p” | nc -u 9760
echo -ne “100,!F*p” | nc -u 9760
echo -ne “226,!R2D1F1” | nc -u 9760
echo -ne “226,!R2D1F0” | nc -u 9760
echo -ne “226,!R2D1FdP1” | nc -u 9760
echo -ne “226,!R2D1FdP31” | nc -u 9760
echo -ne “226,!R2D1FdP1” | nc -u 9760
echo -ne “226,!R2D1FdP31” | nc -u 9760

If I recall the top ones are to do with binding, R2D1F1 turns on first dimmer in room 2, F0 turns it off, fdP10 would set a dim level.

Let me know how you get on.

Awesome thanks Ill give that a go and let you know.

I hope the new link will be supported by the binding soon!


I’ve been having a bit of trouble getting this to work in the binding. I’ve got a pull request in here:

You could also try a copy of the binding here:

and report back if it works.

At the moment I don’t use the binding to update status in Openhab as that isn’t as important to me but I do want to get it to work so any testing you can do will help.

For control it is working for me on binding 1.7.1 once you swap the send / receive ports over, I had to link it using the netcat commands I posted above.

I am using LightwaveRF 1G and 2G dimmers and some plug in switches.

The dimming function isn’t working but I am not sure if I should have a rule to handle that function.

OK I have done some back to back testing this evening as most of the previous testing was about a week ago. Tonight I tried lightwave binding versions 1.7.1 and 1.8.0, I got the same results on both.

With receive port set to 9761 and send port 9760 I can switch my dimmers on and off from OH GUI although dimming does not work, if I use the official lightwave app on an iOS device I can fully control the dimmers but the changes are not reflected in OH GUI, if I manually operate the dimmer switches these changes are also not picked up by the OH GUI.

With the ports swapped over I can no longer operate the dimmers from within OH, if I use the official app again I can control and dim as expected but the changes are updated in the OH GUI, manually operating the dimmer switches still does not update the OH GUI.

I tried 1.8.0 and the registration now works correctly without having to follow Wez’s Netcat commands, however I am seeing issues with the dimming, when set to zero the lights go to their full brightness.

Manually operating lightwave switches will never update in Openhab or any system. When you manually operate the switches no message is sent so no way a home automation system can know. If this is critical to you you’ll need to use something other that lightwave.

I’ll give it another go to get this to work without it being one option or the other.

Thanks for the info Neil, I can live without updates from them being manually operated.

Hi I’ve fixed these issues see here:

Hi, I thought I’d jump in here with some feedback. I dropped in the 1.8.0_alpha3 LightwaveRF bundle into my 1.7.1 installation tonight, and I had my first success with my LWRF sockets the first time since starting with OH, which I am delighted about!! I seem to have control but not monitoring.

I have the newer model LWRF Link box (without the display), which I think is the source of the original connection problems.

My ports are configured as below:


Which allows me to control the sockets from OH. However If I use the LW Android App to switch the socket off, This change does not get reflected in the OH Web UI. Interestingly though, I see this message appearing on the event log.

2015-11-30 21:07:48.748 [WARN ] [.l.internal.LightwaveRfBinding] - No item for incoming message[001,?V="N2.91Y"

So, thank you Neil and others for your efforts in getting this working. I’ll continue to persevere with this, and dive into the add-on code to get a better handle on what it’s doing.


I’m up to alpha 5 now so try this one:


Sorry to hijack this thread, however, I’m having issues with getting my new Lightwave Link box (without the LCD display) working with OH 1.8.1

I’ve documented most of the issues I’ve had (including logs and tcpdumps) at LightwaveRF Link Connection (new style without LCD Display) but the short version of what I’ve tried so far is as followed:

  • Both 1.8.1 and 1.8.0_alpha12 versions of the lightwave bindings
  • The default and reversed port numbers from this thread
  • Broadcast and specific IP Address for the wifi link set on separate occasions/restarts in openhab.cfg
  • Putting the link into “pairing mode” whilst restarting the server

The link shows up fine on the LW Android app and I can read data from my energy monitor so I know that it’s working as a stand-alone platform, I just can’t get it integrated with OpenHAB!

I’ve also created an items file as follows:

Group gLWTEST "LightWave" /* LightwaveRF Link Info */ String LW_WifiL_Ver "Wifi Link Version [%s]" <network> (gLWTEST) {lightwaverf="serial=wifilink,type=VERSION"} String LW_WifiL_IP "Wifi Link IP Address [%s]" <network> (gLWTEST) {lightwaverf="serial=wifilink,type=WIFILINK_IP"} DateTime LW_WifiL_Dusk "Wifi Link Dusk Time [%1$tT, %1$tF]" <network> (gLWTEST) {lightwaverf="serial=wifilink,type=WIFILINK_DUSK_TIME"} DateTime LW_WifiL_Dawn "Wifi Link Dawn Time [%1$tT, %1$tF]" <network> (gLWTEST) {lightwaverf="serial=wifilink,type=WIFILINK_DAWN_TIME"} Number LW_WifiL_Uptime "Wifi Link Uptime [%.2f]" <network> (gLWTEST) {lightwaverf="serial=wifilink,type=WIFILINK_UPTIME"} String LW_WifiL_Long "Wifi Link Longitude [%s]" <network> (gLWTEST) {lightwaverf="serial=wifilink,type=WIFILINK_LONGITUDE"} String LW_WifiL_Lat "Wifi Link Latitude [%s]" <network> (gLWTEST) {lightwaverf="serial=wifilink,type=WIFILINK_LATITUDE"}

and I am including it in my sitemap like this:

Frame label="Lightwave" { Group item=gLWTEST label="Lightwave" icon="network" }

All the items show up in the interface, however, they do not have any data, not even the IP Address :frowning:

Any help would be very much appreciated.


Ignore the above, I had some firewall rules in place on my OH server.

I enabled UDP/9760 and UDP/9761 and it’s working :slightly_smiling:

Hi guys sorry to jump in old thread and hope this question belongs here. I have read through the forum but cant find a solution…I too have been using openhab and would like to say a huge thanks to all involved…

I have problem at basic stage of install

When adding the lightwave binding to openhabian. I drop the binding Jar file into the folder /usr/share/openhab2/addons the wifi link doesn’t seem to flash… I have tried force command but still to no avail… wondering if im missing dependencies within openhabian? any help is appreciated because my heads gone lol…

what hub model have you, i guess you found the ip of the hub and applied the manual link request ?