New SD install (openhab4) but no zigbee adapter

RPI 4 4G
Latest SD download (12 aug) Openhab 4.0.1
Zigbee stick: sonoff zigbee 3.0 usb dongle plus

My intention is to start with zigbee2mqtt (i stop with deconz).

  • Copy on SD
  • Run first time RPI
  • 34 Change password
  • 23 Install Mosquito
  • Add a thing Mosquito broker → Online
  • 2A Install Zigbee2MQTT
    The expected Warning
    But then no adapter to select
    When I look with LSUSB I see the adapter.
    What step do I oversee?

I have tried an older release of openhab 3.4.5.
There is no problem when I do the same steps.
Maybe it was to early to switch to openhab 4.

Try to upgrade to latest release OH 4.0.2 and possibly also upgrade System (item 02 in config-tool).

Addition: I had the same problem and it worked after i did the mentioned updates!

I had the same issue and switched back to the Zigbee binding in OH because of this.
I looks like a bug in Bullseye.

1 Like

I have tried to update.
But not with a good result. Openhab doesn’t start anymore. A little strange from an almost clean and empty system. So no, not something I recommend. I stay on 3.4
Maybe a look on something else.

I haven’t switched to OH4 yet but let’s see if I can help:
To show the selection of adapters the install routine checks the content of /dev/serial/by-id.
What do you see in this folder?
As a workaround you can change “by-id” into “by-path” in the file /opt/openhabian/functions/nodejs-apps.bash.
I just checked on a fresh debian system with OH 4.0.2 and it worked without problems.

I think mine was also a fresh 4.0.2. Also with a sonoff zigbee 3.0 usb dongle plus?
Whitch step did I do wrong.or did I forgot?

I mentioned that it used to work but after openhabian update it stopped BUT today have been told that is not problem of openhab or openhabian and if I want it to be fixed then should find and fix it myself…

You could try to modify serial file to help discover device (Larsen described it well on my zigbee issue topic) and then install outside of openhabian. It worked on 3.4.4

I don’t think it’s got anything to do with you. It was/is a bug in debian/bullseye. As the problem is outside openhab it has to be solved by the operating system (I tried in debian/bookworm and there it works).
So the things you can try:

  1. update system via openhabian, reboot and try again
  2. edit nodejs-apps.bash as described above, reboot…
  3. patch system as described in Kristophs post