No Bindings after update from RC1 to 2.5.0~1

After updating from 2.5.0~RC1-1 to 2.5.0~1 I got a “… [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing '…” for almost every binding I’m using. I’ve waited for a hour and have done 2 restarts an one full cold reboot but it does not change. I’m always looping in Failed installing…

  • Platform information:
    • Hardware: RasbPi 4b / 2 GB
    • OS: Rasbien Buster
    • Java Runtime Environment: 8
    • openHAB version: 2.5.0_1

What process did you use to update?

as usual:
sudo apt-get update && sudo apt-get dist-upgrade -y

I’m on the “Beta Release” track

There are 3 main Repos.
Stable - currently 2.0.0-1
Testing - Milestones & Release Candidates
Unstable - Snashots

You need to change to the Stable repo before running those update & update commands.

Yes it is now “Testing”, formerly known as “Beta Release”. I guess this term was changed some time ago.
And without changing to stable my raspi loaded the 2.5.0~1 as most resent one

Nope. It’s been “testing” ever (well at least as far as I remember back).
Do you have the openhab2-addons and …-legacy packages installed ?
How is your system configured, eventually it is to download the addons (“remote” and “legacy” options in addons.cfg) ?

1 Like

Sorry, it was definitely “Beta Release” - I have an about 3 years old screen shot in my notices…

I have only legacy = false in my addons.cfg

Can you post the full “Failed installing '…” line?

I had an issue and a number of others have had an issue where the bindings were failing.

The errors were an incorrect %userdata%/config/org/openhab/addons.config file.

Yes, folks said that this file is auto-generated and should not be edited… It appears that if there is an error, the system might not clean up the file on its own.

A similar thread from a few days back:

1 Like

Yes, that is indeed the case. In theory, editing that file should be futile as it should be re-written by the system on its next restart, but manually editing the file, so far, has worked in my case.

I tried to change the addons.config and even tried to delete it let it generate new. The problem still remains, no way install any addon, even not from the scratch.

Now I restored my addons.config and switched back to RC1 and all works fine - all addons are back.

My complete install line was:

2019-12-18 14:21:45.976 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing ‘openhab-package-expert’: No matching features for openhab-package-expert/0
2019-12-18 14:21:46.115 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing ‘openhab-persistence-mapdb, openhab-binding-exec, openhab-misc-openhabcloud, openhab-binding-avmfritz, openhab-binding-network, openhab-binding
-amazonechocontrol, openhab-misc-hueemulation, openhab-ui-habpanel, openhab-binding-gpio1, openhab-ui-restdocs, openhab-binding-mqtt, openhab-transformation-map, openhab-ui-classic, openhab-ui-habmin, openhab-transformation-xslt, open
hab-transformation-exec, openhab-ui-paper, openhab-transformation-scale, openhab-binding-samsungtv, openhab-voice-voicerss, openhab-transformation-javascript, openhab-misc-ruleengine, openhab-transformation-regex, openhab-transformati
on-jsonpath, openhab-binding-zwave, openhab-binding-wifiled, openhab-binding-tankerkoenig, openhab-transformation-xpath, openhab-binding-hpprinter, openhab-persistence-rrd4j, openhab-ui-basic, openhab-binding-ntp, openhab-binding-open
weathermap, openhab-binding-fritzboxtr0641, openhab-binding-astro, openhab-binding-pushbullet, openhab-binding-knx’: Unable to resolve root: missing requirement [root] osgi.identity; osgi.identity=bundle; type=karaf.feature; version="
[4.2.7,4.2.7]"; filter:="(&(osgi.identity=bundle)(type=karaf.feature)(version>=4.2.7)(version<=4.2.7))"

Tried it again now a week later and the update works without any problems. I still have no clue what was going wrong the first time.

I’ve done it the same way, with ‘sudo apt-get update && sudo apt-get dist-upgrade -y’.

The only difference was that I was stopping openhab manually (‘sudo systemctl stop openhab2’) before I executed the update and started it it again after the update (‘sudo systemctl start openhab2’), but I don’t believe that this makes the difference.

I’ve untagged your ‘solution’ as it isn’t of value to others.

1 Like